]> git.pld-linux.org Git - packages/podman.git/blob - podman.spec
up to 3.4.1
[packages/podman.git] / podman.spec
1 Summary:        A tool for managing OCI containers and pods
2 Name:           podman
3 Version:        3.4.1
4 Release:        1
5 License:        Apache v2.0
6 Group:          Applications/System
7 #Source0Download: https://github.com/containers/podman/releases
8 Source0:        https://github.com/containers/podman/archive/v%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  e7709121ed468f809785a74fa8e0ae0b
10 Source1:        policy.json
11 Source2:        registries.conf
12 URL:            https://github.com/containers/podman
13 BuildRequires:  device-mapper-devel
14 BuildRequires:  go-md2man
15 BuildRequires:  golang
16 BuildRequires:  golang-varlink
17 BuildRequires:  gpgme-devel
18 BuildRequires:  libseccomp-devel
19 BuildRequires:  pkgconfig
20 BuildRequires:  rpm-build >= 4.6
21 BuildRequires:  systemd-devel
22 Requires:       conmon
23 Requires:       containernetworking-plugins
24 Requires:       crun
25 Suggests:       slirp4netns
26 Suggests:       uidmap
27 ExclusiveArch:  %{ix86} %{x8664} %{arm} aarch64 mips64 mips64le ppc64 ppc64le s390x
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Podman (the POD MANager) is a tool for managing containers and images,
32 volumes mounted into those containers, and pods made from groups of
33 containers. Podman is based on libpod, a library for container
34 lifecycle management that is also contained in this repository. The
35 libpod library provides APIs for managing containers, pods, container
36 images, and volumes.
37
38 %package -n bash-completion-podman
39 Summary:        bash-completion for podman
40 Group:          Applications/Shells
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       bash-completion >= 2.0
43 BuildArch:      noarch
44
45 %description -n bash-completion-podman
46 This package provides bash-completion for podman.
47
48 %package -n fish-completion-podman
49 Summary:        Fish completion for podman command
50 Group:          Applications/Shells
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       fish
53 BuildArch:      noarch
54
55 %description -n fish-completion-podman
56 Fish completion for podman command.
57
58 %package -n zsh-completion-podman
59 Summary:        Zsh completion for podman command
60 Group:          Applications/Shells
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       zsh
63 BuildArch:      noarch
64
65 %description -n zsh-completion-podman
66 Zsh completion for podman command.
67
68 %prep
69 %setup -q
70
71 %build
72 %{__make} \
73         GO=/usr/bin/go \
74         GOPATH=$(pwd)/.gopath \
75         PREFIX="%{_prefix}" \
76         BINDIR="%{_bindir}" \
77         LIBEXECDIR="%{_libexecdir}" \
78         MANDIR="%{_mandir}" \
79         SHAREDIR_CONTAINERS="%{_datadir}/containers" \
80         ETCDIR="%{_sysconfdir}" \
81         TMPFILESDIR="%{systemdtmpfilesdir}" \
82         SYSTEMDDIR="%{systemdunitdir}" \
83         USERSYSTEMDDIR="%{systemduserunitdir}" \
84         PYTHON="%{__python3}"
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/containers,%{bash_compdir},%{fish_compdir},%{zsh_compdir}}
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT \
93         PREFIX="%{_prefix}" \
94         BINDIR="%{_bindir}" \
95         LIBEXECDIR="%{_libexecdir}" \
96         MANDIR="%{_mandir}" \
97         SHAREDIR_CONTAINERS="%{_datadir}/containers" \
98         ETCDIR="%{_sysconfdir}" \
99         TMPFILESDIR="%{systemdtmpfilesdir}" \
100         SYSTEMDDIR="%{systemdunitdir}" \
101         USERSYSTEMDDIR="%{systemduserunitdir}" \
102         PYTHON="%{__python3}"
103
104 cp -p %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/containers
105
106 $RPM_BUILD_ROOT%{_bindir}/podman completion -f $RPM_BUILD_ROOT%{bash_compdir}/podman bash
107 $RPM_BUILD_ROOT%{_bindir}/podman completion -f $RPM_BUILD_ROOT%{fish_compdir}/podman.fish fish
108 $RPM_BUILD_ROOT%{_bindir}/podman completion -f $RPM_BUILD_ROOT%{zsh_compdir}/_podman zsh
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(644,root,root,755)
115 %doc README.md
116 %dir %{_sysconfdir}/containers
117 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/containers/policy.json
118 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/containers/registries.conf
119 %attr(755,root,root) %{_bindir}/podman
120 %attr(755,root,root) %{_bindir}/podman-remote
121 %{systemdunitdir}/podman.service
122 %{systemdunitdir}/podman.socket
123 %{systemdunitdir}/podman-auto-update.service
124 %{systemdunitdir}/podman-auto-update.timer
125 %{systemdunitdir}/podman-restart.service
126 %{systemduserunitdir}/podman.service
127 %{systemduserunitdir}/podman.socket
128 %{systemduserunitdir}/podman-auto-update.service
129 %{systemduserunitdir}/podman-auto-update.timer
130 %{systemduserunitdir}/podman-restart.service
131 %{_mandir}/man1/podman*.1*
132 %{_mandir}/man5/oci-hooks.5*
133 /usr/lib/tmpfiles.d/podman.conf
134
135 %files -n bash-completion-podman
136 %defattr(644,root,root,755)
137 %{bash_compdir}/podman
138
139 %files -n fish-completion-%{name}
140 %defattr(644,root,root,755)
141 %{fish_compdir}/podman.fish
142
143 %files -n zsh-completion-%{name}
144 %defattr(644,root,root,755)
145 %{zsh_compdir}/_podman
This page took 0.074663 seconds and 3 git commands to generate.