]> git.pld-linux.org Git - packages/pingus.git/commitdiff
- acfix patch with fixes for autoconf 2.5x pingus-0_5_0pre3-3
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 12 Oct 2002 16:44:38 +0000 (16:44 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- gcc3 patch with ISO C++ fixes
- data-typos patch - fixes for three "404 File not found" textures
- removed obsolete libpng 1.2.2 hack, new %%doc
- added missing info page, release 3

Changed files:
    pingus-acfix.patch -> 1.1
    pingus-data-typos.patch -> 1.1
    pingus-gcc3.patch -> 1.1
    pingus.spec -> 1.20

pingus-acfix.patch [new file with mode: 0644]
pingus-data-typos.patch [new file with mode: 0644]
pingus-gcc3.patch [new file with mode: 0644]
pingus.spec

diff --git a/pingus-acfix.patch b/pingus-acfix.patch
new file mode 100644 (file)
index 0000000..7109feb
--- /dev/null
@@ -0,0 +1,18 @@
+--- pingus-0.5.0pre3/configure.in.orig Sat Oct 12 16:44:37 2002
++++ pingus-0.5.0pre3/configure.in      Sat Oct 12 16:45:53 2002
+@@ -344,7 +344,6 @@
+            data/worldmaps/Makefile
+            data/data/Makefile
+            data/demos/Makefile
+-           data/data/Makefile
+            doc/Makefile
+            po/Makefile.in intl/Makefile
+   data/images/core/menu/Makefile
+@@ -396,7 +396,6 @@
+   data/images/special/Makefile
+   data/images/special/pacman/Makefile
+   data/images/textures/Makefile
+-  data/images/Makefile
+   data/images/hotspots/misc/Makefile
+   data/images/hotspots/space/Makefile
+   data/images/hotspots/desert/Makefile
diff --git a/pingus-data-typos.patch b/pingus-data-typos.patch
new file mode 100644 (file)
index 0000000..18b2cf8
--- /dev/null
@@ -0,0 +1,26 @@
+--- pingus-0.5.0pre3/data/data/global.scr.orig Fri Jan 18 00:38:39 2002
++++ pingus-0.5.0pre3/data/data/global.scr      Sat Oct 12 17:59:39 2002
+@@ -27,8 +27,8 @@
+       danger      = ../images/groundpieces/ground/signposts/danger.png (type=surface, x=0, y=0, width=215, height=121);
+ //    crystal     = ../images/hotspots/crystal.png    (type=surface, x=0, y=0, width=60,  height=109);
+-      colum       = ../images/groundpieces/ground/misc/colum.png      (type=surface, x=0, y=0, width=142, height=184);
+-      colum_flat  = ../images/groundpieces/ground/misc/colum_flat.png (type=surface, x=0, y=0, width=184, height=122);
++      colum       = ../images/groundpieces/ground/misc/column.png      (type=surface, x=0, y=0, width=142, height=184);
++      colum_flat  = ../images/groundpieces/ground/misc/column_flat.png (type=surface, x=0, y=0, width=184, height=122);
+       colum_piece1 = ../images/groundpieces/ground/desert/column_piece1.png      (type=surface, x=0, y=0, width=103, height=66);
+       colum_piece2 = ../images/groundpieces/ground/desert/column_piece2.png      (type=surface, x=0, y=0, width=128, height=66);
+--- pingus-0.5.0pre3/data/levels/level2.xml.orig       Tue Jan 15 20:48:48 2002
++++ pingus-0.5.0pre3/data/levels/level2.xml    Sat Oct 12 18:11:24 2002
+@@ -33,8 +33,8 @@
+ <background type="surface">
+   <surface><resource type="datafile">
+-    <resource-datafile>thunderstorm</resource-datafile>
+-  <resource-ident>green</resource-ident>
++    <resource-datafile>textures</resource-datafile>
++  <resource-ident>Textures/thunderstorm</resource-ident>
+   </resource></surface>
+   <color>
+     <red>0</red>
diff --git a/pingus-gcc3.patch b/pingus-gcc3.patch
new file mode 100644 (file)
index 0000000..ac81a06
--- /dev/null
@@ -0,0 +1,20 @@
+--- pingus-0.5.0pre3/src/backgrounds/StarfieldBackground.cc.orig       Tue Jan 15 11:48:50 2002
++++ pingus-0.5.0pre3/src/backgrounds/StarfieldBackground.cc    Sat Oct 12 16:54:23 2002
+@@ -185,7 +185,7 @@
+ }
+ void
+-StarfieldBackgroundStars::draw_offset(int x_of, int y_of, float s = 1.0)
++StarfieldBackgroundStars::draw_offset(int x_of, int y_of, float s)
+ {
+   sur.put_screen (int(x_pos + x_of), int(y_pos + y_of));
+ }
+@@ -231,7 +231,7 @@
+ }
+ ///
+ void 
+-StarfieldBackground::draw_offset(int x_of, int y_of, float s = 1.0)
++StarfieldBackground::draw_offset(int x_of, int y_of, float s)
+ {
+   for (std::vector<StarfieldBackgroundStars>::iterator i = stars.begin ();
+        i != stars.end (); i++)
index 0915a55c031b40d6c20425bbe933b155240a2f1e..d36c5ed1557b8c63ecdacf64cdc2b377b93d8b1a 100644 (file)
@@ -2,7 +2,7 @@ Summary:        Pingus, a lemmings style game with penguins
 Summary(pl):   Gra typu lemmingi z pingwinami w roli g³ównej
 Name:          pingus
 Version:       0.5.0pre3
-Release:       2
+Release:       3
 License:       GPL
 Group:         X11/Applications/Games
 Source0:       http://dark.x.dtu.dk/~grumbel/%{name}/%{name}-%{version}.tar.bz2
@@ -11,6 +11,9 @@ Source2:      %{name}.png
 Patch0:                %{name}-datadir.patch
 Patch1:                %{name}-Clanlib-0.6.1.patch
 Patch2:                %{name}-amfix.patch
+Patch3:                %{name}-acfix.patch
+Patch4:                %{name}-gcc3.patch
+Patch5:                %{name}-data-typos.patch
 URL:           http://pingus.seul.org/
 BuildRequires: ClanLib-devel >= 0.6.1
 BuildRequires: Hermes-devel
@@ -42,19 +45,19 @@ Wspania
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 %build
 rm -f missing
 %{__aclocal}
 %{__autoconf}
 %{__automake}
-CPPFLAGS="-I%{_includedir} -I/usr/include/libxml2/libxml"
-if [ -f %{_pkgconfigdir}/libpng12.pc ] ; then
-       CPPFLAGS="$CPPFLAGS `pkg-config libpng12 --cflags`"
-fi
+CPPFLAGS="-I/usr/X11R6/include -I/usr/include/libxml2/libxml"
 %configure \
        CPPFLAGS="$CPPFLAGS" \
-       LDFLAGS="-L%{_libdir} %{rpmldflags}"
+       LDFLAGS="-L/usr/X11R6/lib %{rpmldflags}"
 %{__make}
 
 %install
@@ -70,16 +73,21 @@ mv -f $RPM_BUILD_ROOT%{_datadir}/games/pingus $RPM_BUILD_ROOT%{_datadir}/pingus
 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Games
 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
 
-gzip -9nf AUTHORS BUGS ChangeLog CREDITS FAQ NEWS TODO THANKS
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
+
+%postun
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
+
 %files
 %defattr(644,root,root,755)
-%doc *.gz
+%doc AUTHORS BUGS ChangeLog CREDITS FAQ NEWS TODO THANKS
 %attr(755,root,root) %{_bindir}/*
 %{_datadir}/%{name}
 %{_mandir}/man*/*
+%{_infodir}/*.info*
 %{_applnkdir}/Games/*
 %{_pixmapsdir}/*
This page took 0.043824 seconds and 4 git commands to generate.