]> git.pld-linux.org Git - packages/pingus.git/commitdiff
- updated datadir patch
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 26 Apr 2003 21:15:24 +0000 (21:15 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- removed obsolete Clanlib-0.6.1,amfix,acfix,gcc3,data-typos,info patches
- requires ClanLib >= 0.6.5 but won't build with ClanLib 0.7.x yet

Changed files:
    pingus-Clanlib-0.6.1.patch -> 1.2
    pingus-acfix.patch -> 1.2
    pingus-amfix.patch -> 1.2
    pingus-data-typos.patch -> 1.2
    pingus-datadir.patch -> 1.2
    pingus-gcc3.patch -> 1.2
    pingus-info.patch -> 1.2
    pingus.spec -> 1.24

pingus-Clanlib-0.6.1.patch [deleted file]
pingus-acfix.patch [deleted file]
pingus-amfix.patch [deleted file]
pingus-data-typos.patch [deleted file]
pingus-datadir.patch
pingus-gcc3.patch [deleted file]
pingus-info.patch [deleted file]
pingus.spec

diff --git a/pingus-Clanlib-0.6.1.patch b/pingus-Clanlib-0.6.1.patch
deleted file mode 100644 (file)
index 73c35fa..0000000
+++ /dev/null
@@ -1,180 +0,0 @@
---- pingus-0.5.0pre3.orig/src/PinguActionFactory.cc
-+++ pingus-0.5.0pre3/src/PinguActionFactory.cc
-@@ -67,7 +67,7 @@
- {
-   new PinguActionFactoryImpl<RocketLauncher> ("rocketlauncher");
-   new PinguActionFactoryImpl<Boarder> ("boarder");
--  new PinguActionFactoryImpl<Superman> ("");
-+  new PinguActionFactoryImpl<Superman> ("superman");
-   new PinguActionFactoryImpl<Angel> ("angel");
-   new PinguActionFactoryImpl<Basher> ("basher");
-   new PinguActionFactoryImpl<Blocker> ("blocker");
---- pingus-0.5.0pre3.orig/src/Client.cc
-+++ pingus-0.5.0pre3/src/Client.cc
-@@ -336,8 +336,8 @@
-   //CL_Input::chain_button_press.remove(this);
-   // Disconnect segfaults
--  CL_Input::sig_button_press.disconnect (on_button_press_slot); 
--  CL_Input::sig_button_release.disconnect (on_button_release_slot); 
-+  CL_Input::sig_button_press ().disconnect (on_button_press_slot); 
-+  CL_Input::sig_button_release ().disconnect (on_button_release_slot); 
-   enabled = false;
- }
---- pingus-0.5.0pre3.orig/src/editor/Editor.cc
-+++ pingus-0.5.0pre3/src/editor/Editor.cc
-@@ -98,9 +98,9 @@
-       //CL_Input::chain_button_release.push_back(event);
-       on_button_press_slot
--      = CL_Input::sig_button_press.connect(event, &EditorEvent::on_button_press);
-+      = CL_Input::sig_button_press().connect(event, &EditorEvent::on_button_press);
-       on_button_release_slot
--      = CL_Input::sig_button_release.connect(event, &EditorEvent::on_button_release);
-+      = CL_Input::sig_button_release().connect(event, &EditorEvent::on_button_release);
-       if (verbose) std::cout << "done: " << event_handler_ref_counter << std::endl;
-     }
-@@ -119,8 +119,8 @@
-   //CL_Input::chain_button_release.remove(event);
-   //CL_Input::chain_button_press.remove(event);
--  CL_Input::sig_button_press.disconnect (on_button_press_slot);
--  CL_Input::sig_button_release.disconnect (on_button_release_slot);
-+  CL_Input::sig_button_press().disconnect (on_button_press_slot);
-+  CL_Input::sig_button_release().disconnect (on_button_release_slot);
-   CL_System::keep_alive();
-   if (verbose) std::cout << "done: " << event_handler_ref_counter << std::endl;
---- pingus-0.5.0pre3.orig/src/PingusMain.cc
-+++ pingus-0.5.0pre3/src/PingusMain.cc
-@@ -803,8 +803,8 @@
-   if (print_fps)
-     Display::add_flip_screen_hook(&fps_counter);
-   
--  on_button_press_slot = CL_Input::sig_button_press.connect (&global_event, &GlobalEvent::on_button_press);
--  on_button_release_slot = CL_Input::sig_button_release.connect (&global_event, &GlobalEvent::on_button_release);
-+  on_button_press_slot = CL_Input::sig_button_press ().connect (&global_event, &GlobalEvent::on_button_press);
-+  on_button_release_slot = CL_Input::sig_button_release ().connect (&global_event, &GlobalEvent::on_button_release);
-   //pingus_story.display ();
-@@ -849,8 +849,8 @@
-     PingusMessageBox(" PingusError: " + err.get_message ());
-   }
--  CL_Input::sig_button_press.disconnect (on_button_press_slot);
--  CL_Input::sig_button_release.disconnect(on_button_release_slot);
-+  CL_Input::sig_button_press ().disconnect (on_button_press_slot);
-+  CL_Input::sig_button_release ().disconnect(on_button_release_slot);
- }
- int
---- pingus-0.5.0pre3.orig/src/worldmap/PingusWorldMapManager.cc
-+++ pingus-0.5.0pre3/src/worldmap/PingusWorldMapManager.cc
-@@ -49,9 +49,9 @@
- void
- PingusWorldMapManager::display ()
- {
--  on_button_press_slot   = CL_Input::sig_button_press.connect (this, &PingusWorldMapManager::on_button_press);
--  on_button_release_slot = CL_Input::sig_button_release.connect (this, &PingusWorldMapManager::on_button_release);
--  on_mouse_move_slot     = CL_Input::sig_mouse_move.connect (this, &PingusWorldMapManager::on_mouse_move);
-+  on_button_press_slot   = CL_Input::sig_button_press ().connect (this, &PingusWorldMapManager::on_button_press);
-+  on_button_release_slot = CL_Input::sig_button_release ().connect (this, &PingusWorldMapManager::on_button_release);
-+  on_mouse_move_slot     = CL_Input::sig_mouse_move ().connect (this, &PingusWorldMapManager::on_mouse_move);
-   init ();
-@@ -78,9 +78,9 @@
-       Display::flip_display ();
-     }
--  CL_Input::sig_button_press.disconnect(on_button_press_slot);
--  CL_Input::sig_button_release.disconnect(on_button_release_slot);
--  CL_Input::sig_mouse_move.disconnect(on_mouse_move_slot);
-+  CL_Input::sig_button_press ().disconnect(on_button_press_slot);
-+  CL_Input::sig_button_release ().disconnect(on_button_release_slot);
-+  CL_Input::sig_mouse_move ().disconnect(on_mouse_move_slot);
- }
- void
---- pingus-0.5.0pre3.orig/src/XMLhelper.hh
-+++ pingus-0.5.0pre3/src/XMLhelper.hh
-@@ -35,7 +35,7 @@
-   #include <libxml/parser.h>
-   #undef list
- #else
--  #include <parser.h>
-+  #include <libxml/parser.h>
- #endif
- #include "ResDescriptor.hh"
---- pingus-0.5.0pre3.orig/src/PingusMenuManager.cc
-+++ pingus-0.5.0pre3/src/PingusMenuManager.cc
-@@ -51,18 +51,18 @@
- {
-   puts ("register_events ()");
-   ++event_register_counter;
--  on_button_press_slot = CL_Input::sig_button_press.connect (this, &PingusMenuManager::on_button_press);
--  on_button_release_slot = CL_Input::sig_button_release.connect (this, &PingusMenuManager::on_button_release);
--  on_mouse_move_slot = CL_Input::sig_mouse_move.connect (this, &PingusMenuManager::on_mouse_move);
-+  on_button_press_slot = CL_Input::sig_button_press ().connect (this, &PingusMenuManager::on_button_press);
-+  on_button_release_slot = CL_Input::sig_button_release ().connect (this, &PingusMenuManager::on_button_release);
-+  on_mouse_move_slot = CL_Input::sig_mouse_move ().connect (this, &PingusMenuManager::on_mouse_move);
- }
- /// Unregister all event-handling stuff
- void 
- PingusMenuManager::unregister_events ()
- {
--  CL_Input::sig_button_press.disconnect (on_button_press_slot);
--  CL_Input::sig_button_release.disconnect (on_button_release_slot);
--  CL_Input::sig_mouse_move.disconnect (on_mouse_move_slot);
-+  CL_Input::sig_button_press ().disconnect (on_button_press_slot);
-+  CL_Input::sig_button_release ().disconnect (on_button_release_slot);
-+  CL_Input::sig_mouse_move ().disconnect (on_mouse_move_slot);
- }
- void 
---- pingus-0.5.0pre3.orig/src/ThemeSelector.cc
-+++ pingus-0.5.0pre3/src/ThemeSelector.cc
-@@ -198,9 +198,9 @@
-   current_theme = themes.end();
--  on_button_press_slot = CL_Input::sig_button_press.connect (event, &ThemeSelector::Event::on_button_press);
--  on_button_release_slot = CL_Input::sig_button_release.connect (event, &ThemeSelector::Event::on_button_release);
--  on_mouse_move_slot = CL_Input::sig_mouse_move.connect (event, &ThemeSelector::Event::on_mouse_move);
-+  on_button_press_slot = CL_Input::sig_button_press ().connect (event, &ThemeSelector::Event::on_button_press);
-+  on_button_release_slot = CL_Input::sig_button_release ().connect (event, &ThemeSelector::Event::on_button_release);
-+  on_mouse_move_slot = CL_Input::sig_mouse_move ().connect (event, &ThemeSelector::Event::on_mouse_move);
- }
- ThemeSelector::~ThemeSelector()
-@@ -214,9 +214,9 @@
-   // CL_Input::chain_button_press.remove(event);
-   // CL_Input::chain_button_release.remove(event);
-   
--  CL_Input::sig_button_press.disconnect (on_button_press_slot);
--  CL_Input::sig_button_release.disconnect (on_button_release_slot);
--  CL_Input::sig_mouse_move.disconnect (on_mouse_move_slot);
-+  CL_Input::sig_button_press ().disconnect (on_button_press_slot);
-+  CL_Input::sig_button_release ().disconnect (on_button_release_slot);
-+  CL_Input::sig_mouse_move ().disconnect (on_mouse_move_slot);
-   
-   delete event;
- }
---- pingus-0.5.0pre3.orig/src/OptionMenu.cc
-+++ pingus-0.5.0pre3/src/OptionMenu.cc
-@@ -339,8 +339,8 @@
-   //CL_Input::chain_button_press.push_back(event);
-   //CL_Input::chain_button_release.push_back(event);
-   
--  CL_Input::sig_button_press.connect (event, &OptionMenu::Event::on_button_press);
--  CL_Input::sig_button_release.connect (event, &OptionMenu::Event::on_button_release);
-+  CL_Input::sig_button_press ().connect (event, &OptionMenu::Event::on_button_press);
-+  CL_Input::sig_button_release ().connect (event, &OptionMenu::Event::on_button_release);
-   Display::set_cursor(CL_MouseCursorProvider::load("Cursors/cursor",
-                                                  PingusResource::get("game")));
diff --git a/pingus-acfix.patch b/pingus-acfix.patch
deleted file mode 100644 (file)
index 7109feb..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- pingus-0.5.0pre3/configure.in.orig Sat Oct 12 16:44:37 2002
-+++ pingus-0.5.0pre3/configure.in      Sat Oct 12 16:45:53 2002
-@@ -344,7 +344,6 @@
-            data/worldmaps/Makefile
-            data/data/Makefile
-            data/demos/Makefile
--           data/data/Makefile
-            doc/Makefile
-            po/Makefile.in intl/Makefile
-   data/images/core/menu/Makefile
-@@ -396,7 +396,6 @@
-   data/images/special/Makefile
-   data/images/special/pacman/Makefile
-   data/images/textures/Makefile
--  data/images/Makefile
-   data/images/hotspots/misc/Makefile
-   data/images/hotspots/space/Makefile
-   data/images/hotspots/desert/Makefile
diff --git a/pingus-amfix.patch b/pingus-amfix.patch
deleted file mode 100644 (file)
index ac5333d..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- pingus-0.5.0pre3/src/traps/Makefile.am.orig        Fri Aug 10 12:56:14 2001
-+++ pingus-0.5.0pre3/src/traps/Makefile.am     Mon May  6 22:46:49 2002
-@@ -30,6 +30,6 @@
-          LaserExit.cc  LaserExit.hh  \
-          Bumper.cc     Bumper.hh
--#         Teleport.cc   Teleport.hh   \
-+#         Teleport.cc   Teleport.hh
- ## EOF ##
diff --git a/pingus-data-typos.patch b/pingus-data-typos.patch
deleted file mode 100644 (file)
index 18b2cf8..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
---- pingus-0.5.0pre3/data/data/global.scr.orig Fri Jan 18 00:38:39 2002
-+++ pingus-0.5.0pre3/data/data/global.scr      Sat Oct 12 17:59:39 2002
-@@ -27,8 +27,8 @@
-       danger      = ../images/groundpieces/ground/signposts/danger.png (type=surface, x=0, y=0, width=215, height=121);
- //    crystal     = ../images/hotspots/crystal.png    (type=surface, x=0, y=0, width=60,  height=109);
--      colum       = ../images/groundpieces/ground/misc/colum.png      (type=surface, x=0, y=0, width=142, height=184);
--      colum_flat  = ../images/groundpieces/ground/misc/colum_flat.png (type=surface, x=0, y=0, width=184, height=122);
-+      colum       = ../images/groundpieces/ground/misc/column.png      (type=surface, x=0, y=0, width=142, height=184);
-+      colum_flat  = ../images/groundpieces/ground/misc/column_flat.png (type=surface, x=0, y=0, width=184, height=122);
-       colum_piece1 = ../images/groundpieces/ground/desert/column_piece1.png      (type=surface, x=0, y=0, width=103, height=66);
-       colum_piece2 = ../images/groundpieces/ground/desert/column_piece2.png      (type=surface, x=0, y=0, width=128, height=66);
---- pingus-0.5.0pre3/data/levels/level2.xml.orig       Tue Jan 15 20:48:48 2002
-+++ pingus-0.5.0pre3/data/levels/level2.xml    Sat Oct 12 18:11:24 2002
-@@ -33,8 +33,8 @@
- <background type="surface">
-   <surface><resource type="datafile">
--    <resource-datafile>thunderstorm</resource-datafile>
--  <resource-ident>green</resource-ident>
-+    <resource-datafile>textures</resource-datafile>
-+  <resource-ident>Textures/thunderstorm</resource-ident>
-   </resource></surface>
-   <color>
-     <red>0</red>
index f2ae71bcfc4a2d4bad8ceac5f6deb45158b3f331..a2ae6de11edc231dd9d0aa346d1088ba1f8c8c5c 100644 (file)
@@ -1,12 +1,11 @@
-diff -durN pingus-0.5.0pre2.orig/configure.in pingus-0.5.0pre2/configure.in
---- pingus-0.5.0pre2.orig/configure.in Fri Jul 27 21:44:48 2001
-+++ pingus-0.5.0pre2/configure.in      Fri Aug 10 14:41:05 2001
+--- pingus-0.6.0.orig/configure.ac     Fri Jul 27 21:44:48 2001
++++ pingus-0.6.0/configure.ac  Fri Aug 10 14:41:05 2001
 @@ -298,7 +298,7 @@
  AC_CHECK_FUNCS(select strdup)
  
  dnl Checking for the install prefix and then use it to define PINGUS_DATADIR
 -PINGUS_EXPAND_DIR(pingus_datadir, "$datadir/games/$PACKAGE")
 +PINGUS_EXPAND_DIR(pingus_datadir, "$datadir/$PACKAGE")
- AC_DEFINE_UNQUOTED(PINGUS_DATADIR, "$pingus_datadir")
+ AC_DEFINE_UNQUOTED(PINGUS_DATADIR, "$pingus_datadir", [Location of Pingus data files])
  
  dnl -- Define the localedir, needed for gettext --
diff --git a/pingus-gcc3.patch b/pingus-gcc3.patch
deleted file mode 100644 (file)
index ac81a06..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- pingus-0.5.0pre3/src/backgrounds/StarfieldBackground.cc.orig       Tue Jan 15 11:48:50 2002
-+++ pingus-0.5.0pre3/src/backgrounds/StarfieldBackground.cc    Sat Oct 12 16:54:23 2002
-@@ -185,7 +185,7 @@
- }
- void
--StarfieldBackgroundStars::draw_offset(int x_of, int y_of, float s = 1.0)
-+StarfieldBackgroundStars::draw_offset(int x_of, int y_of, float s)
- {
-   sur.put_screen (int(x_pos + x_of), int(y_pos + y_of));
- }
-@@ -231,7 +231,7 @@
- }
- ///
- void 
--StarfieldBackground::draw_offset(int x_of, int y_of, float s = 1.0)
-+StarfieldBackground::draw_offset(int x_of, int y_of, float s)
- {
-   for (std::vector<StarfieldBackgroundStars>::iterator i = stars.begin ();
-        i != stars.end (); i++)
diff --git a/pingus-info.patch b/pingus-info.patch
deleted file mode 100644 (file)
index 5e9831c..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- pingus-0.5.0pre3/doc/pingus.texi.orig      Tue Jun 20 22:35:15 2000
-+++ pingus-0.5.0pre3/doc/pingus.texi   Sat Nov  2 18:47:47 2002
-@@ -4,9 +4,9 @@
- @settitle Pingus
- @c %**end of header
--@dircategory Games
-+@dircategory Games:
- @direntry
--* Pingus: (pingus).           Pingus - A free Lemmings Clone
-+* Pingus: (pingus).                   Pingus - A free Lemmings Clone
- @end direntry
- @setchapternewpage off
index 034eda33f341f0c5d1962424f7a0b73f3840fa6c..d82fbc19a0bdd29822750e16bcec388a740db305 100644 (file)
@@ -9,14 +9,9 @@ Source0:       http://pingus.seul.org/files/%{name}-%{version}.tar.bz2
 Source1:       %{name}.desktop
 Source2:       %{name}.png
 Patch0:                %{name}-datadir.patch
-Patch1:                %{name}-Clanlib-0.6.1.patch
-Patch2:                %{name}-amfix.patch
-Patch3:                %{name}-acfix.patch
-Patch4:                %{name}-gcc3.patch
-Patch5:                %{name}-data-typos.patch
-Patch6:                %{name}-info.patch
 URL:           http://pingus.seul.org/
-BuildRequires: ClanLib-devel >= 0.6.1
+BuildRequires: ClanLib-devel >= 0.6.5
+BuildRequires: ClanLib-devel < 0.7.0
 BuildRequires: Hermes-devel
 BuildRequires: SDL-devel >= 1.2.0
 BuildRequires: SDL_mixer-devel
@@ -28,11 +23,9 @@ BuildRequires:       gtk+-devel > 1.2.1
 BuildRequires: glib-devel
 BuildRequires: libpng-devel
 BuildRequires: libstdc++-devel
-BuildRequires: libxml-devel
-BuildRequires: texinfo
+BuildRequires: libxml2-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-
 %description
 A cool lemmings game with penguins instead of lemmings!
 
@@ -43,21 +36,16 @@ Wspania
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
-%patch6 -p1
 
 %build
 rm -f missing
 %{__aclocal}
 %{__autoconf}
 %{__automake}
-CPPFLAGS="-I/usr/X11R6/include -I/usr/include/libxml2/libxml"
+#CPPFLAGS="-I/usr/X11R6/include -I/usr/include/libxml2/libxml"
 %configure \
-       CPPFLAGS="$CPPFLAGS" \
-       LDFLAGS="-L/usr/X11R6/lib %{rpmldflags}"
+       --with-clanGL
+#      LDFLAGS="-L/usr/X11R6/lib %{rpmldflags}"
 %{__make}
 
 %install
@@ -88,6 +76,5 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/*
 %{_datadir}/%{name}
 %{_mandir}/man*/*
-%{_infodir}/*.info*
 %{_applnkdir}/Games/*
 %{_pixmapsdir}/*
This page took 0.056782 seconds and 4 git commands to generate.