]> git.pld-linux.org Git - packages/pida.git/blob - pida.spec
- start update to 0.6.1
[packages/pida.git] / pida.spec
1 # TODO:
2 # - investigate the documentation format in doc
3 # - verify if such a big version jump actually works
4 # - move .po files to glibc dir and test if it works
5 #   are these used afterall, as they are .po sources not .mo compiled
6 # - moo_stub is just sample? kill it and can make package noarch.
7 #
8 Summary:        A framework for integrated development
9 Summary(pl.UTF-8):      Szkielet do programowania zintegrowanego
10 Name:           pida
11 Version:        0.6.1
12 Release:        0.1
13 License:        GPL v2+
14 Group:          Development/Tools
15 Source0:        http://pypi.python.org/packages/source/p/pida/%{name}-%{version}.tar.gz
16 # Source0-md5:  ca509c6140b826eacfe87ceb12034abc
17 Source1:        %{name}.desktop
18 URL:            http://pida.co.uk/
19 BuildRequires:  pkgconfig
20 BuildRequires:  python-devel
21 BuildRequires:  python-pygtk-devel
22 BuildRequires:  python-pygtk-glade
23 BuildRequires:  python-setuptools
24 BuildRequires:  rpm-pythonprov
25 Requires:       fontconfig
26 Requires:       python-gnome-desktop-gtksourceview
27 Requires:       python-gnome-gconf
28 Requires:       python-kiwi
29 Requires:       python-pygtkhelpers
30 Requires:       python-simplejson
31 Requires:       python-vte
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 PIDA is an integrated development environment (IDE) for UNIX-like
36 operating systems.
37
38 Unique Features:
39 - Vim embedding
40 - File browser that understands version status information for CVS,
41   Subversion, Darcs, Monotone, Mercurial, Bazaar-ng and Arch
42 - Built in GTK+ rapid application development
43 - Many more unique and obsessive touches
44
45 %description -l pl.UTF-8
46 PIDA to zintegrowane środowisko programistyczne (IDE) dla uniksowych
47 systemów operacyjnych.
48
49 Unikalne cechy:
50 - osadzony Vim
51 - przeglądarka plików uwzględniająca informacje o stanie wersji dla
52   systemów kontroli wersji CVS, Subversion, Darcs, Monotone, Mercurial,
53   Bazaar-ng i Arch
54 - wbudowane środowisko szybkiego tworzenia aplikacji GTK+
55 - wiele innych unikalnych i pożądanych drobiazgów
56
57 %prep
58 %setup -q
59
60 %build
61 %{__python} setup.py build
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
66
67 %{__python} setup.py install \
68         --install-data=%{_datadir}/%{name} \
69         --root=$RPM_BUILD_ROOT \
70         --optimize=2
71
72 cp $RPM_BUILD_ROOT%{py_sitedir}/%{name}/resources/pixmaps/pida-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}
73 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
74 %py_postclean
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc AUTHORS README
82 %attr(755,root,root) %{_bindir}/pida
83 %attr(755,root,root) %{_bindir}/pida-remote
84
85 # see todo at top of the spec
86 #%%dir %{py_sitedir}/pida/resources/locale
87 #%%dir %{py_sitedir}/pida/services/appcontroller/locale
88 #%%dir %{py_sitedir}/pida/services/browseweb/locale
89 #%%dir %{py_sitedir}/pida/services/buffer/locale
90 #%%dir %{py_sitedir}/pida/services/bugreport/locale
91 #%%dir %{py_sitedir}/pida/services/commander/locale
92 #%%dir %{py_sitedir}/pida/services/editor/locale
93 #%%dir %{py_sitedir}/pida/services/filemanager/locale
94 #%%dir %{py_sitedir}/pida/services/grepper/locale
95 #%%dir %{py_sitedir}/pida/services/help/locale
96 #%%dir %{py_sitedir}/pida/services/manhole/locale
97 #%%dir %{py_sitedir}/pida/services/notify/locale
98 #%%dir %{py_sitedir}/pida/services/openwith/locale
99 #%%dir %{py_sitedir}/pida/services/optionsmanager/locale
100 #%%dir %{py_sitedir}/pida/services/plugins/locale
101 #%%dir %{py_sitedir}/pida/services/project/locale
102 #%%dir %{py_sitedir}/pida/services/sessions/locale
103 #%%dir %{py_sitedir}/pida/services/shortcuts/locale
104 #%%dir %{py_sitedir}/pida/services/versioncontrol/locale
105 #%%dir %{py_sitedir}/pida/services/window/locale
106 #%%lang(fr) %{py_sitedir}/pida/resources/locale/fr_FR
107 #%%lang(fr) %{py_sitedir}/pida/services/appcontroller/locale/fr_FR
108 #%%lang(fr) %{py_sitedir}/pida/services/browseweb/locale/fr_FR
109 #%%lang(fr) %{py_sitedir}/pida/services/buffer/locale/fr_FR
110 #%%lang(fr) %{py_sitedir}/pida/services/bugreport/locale/fr_FR
111 #%%lang(fr) %{py_sitedir}/pida/services/commander/locale/fr_FR
112 #%%lang(fr) %{py_sitedir}/pida/services/editor/locale/fr_FR
113 #%%lang(fr) %{py_sitedir}/pida/services/filemanager/locale/fr_FR
114 #%%lang(fr) %{py_sitedir}/pida/services/grepper/locale/fr_FR
115 #%%lang(fr) %{py_sitedir}/pida/services/help/locale/fr_FR
116 #%%lang(fr) %{py_sitedir}/pida/services/manhole/locale/fr_FR
117 #%%lang(fr) %{py_sitedir}/pida/services/notify/locale/fr_FR
118 #%%lang(fr) %{py_sitedir}/pida/services/openwith/locale/fr_FR
119 #%%lang(fr) %{py_sitedir}/pida/services/optionsmanager/locale/fr_FR
120 #%%lang(fr) %{py_sitedir}/pida/services/plugins/locale/fr_FR
121 #%%lang(fr) %{py_sitedir}/pida/services/project/locale/fr_FR
122 #%%lang(fr) %{py_sitedir}/pida/services/sessions/locale/fr_FR
123 #%%lang(fr) %{py_sitedir}/pida/services/shortcuts/locale/fr_FR
124 #%%lang(fr) %{py_sitedir}/pida/services/versioncontrol/locale/fr_FR
125 #$%lang(fr) %{py_sitedir}/pida/services/window/locale/fr_FR
126
127 %if "%{py_ver}" > "2.4"
128 %{py_sitedir}/pida-*-py2.*.egg-info
129 %endif
130
131 %dir %{py_sitedir}/pida
132 #%%attr(755,root,root) %{py_sitedir}/moo_stub.so
133 %{py_sitedir}/pida/*.py[co]
134 %{py_sitedir}/pida/core
135 %{py_sitedir}/pida/editors
136 %dir %{py_sitedir}/pida/plugins
137 %dir %{py_sitedir}/pida/plugins/*.py[co]
138 %dir %{py_sitedir}/pida/resources
139 %{py_sitedir}/pida/resources/glade
140 %{py_sitedir}/pida/resources/pixmaps
141 %{py_sitedir}/pida/resources/uidef
142 %dir %{py_sitedir}/pida/resources/data
143 %dir %{py_sitedir}/pida/resources/data/gtkrc-2.0
144 %{py_sitedir}/pida/resources/data/*.py[co]
145 %{py_sitedir}/pida/resources/data/*.vim
146 %{py_sitedir}/pida/resources/data/*.el
147 %dir %{py_sitedir}/pida/services
148 %dir %{py_sitedir}/pida/services/appcontroller
149 %{py_sitedir}/pida/services/appcontroller/*.py[co]
150 %{py_sitedir}/pida/services/appcontroller/uidef
151 %dir %{py_sitedir}/pida/services/browseweb
152 #%%{py_sitedir}/pida/services/browseweb/glade
153 %{py_sitedir}/pida/services/browseweb/*.py[co]
154 %{py_sitedir}/pida/services/browseweb/uidef
155 %dir %{py_sitedir}/pida/services/buffer
156 %{py_sitedir}/pida/services/buffer/glade
157 %{py_sitedir}/pida/services/buffer/*.py[co]
158 %{py_sitedir}/pida/services/buffer/uidef
159 %dir %{py_sitedir}/pida/services/bugreport
160 %{py_sitedir}/pida/services/bugreport/glade
161 %{py_sitedir}/pida/services/bugreport/*.py[co]
162 %{py_sitedir}/pida/services/bugreport/uidef
163 %dir %{py_sitedir}/pida/services/commander
164 %{py_sitedir}/pida/services/commander/*.py[co]
165 %{py_sitedir}/pida/services/commander/pixmaps
166 %{py_sitedir}/pida/services/commander/uidef
167 %dir %{py_sitedir}/pida/services/contexts
168 %{py_sitedir}/pida/services/contexts/*.py[co]
169 %{py_sitedir}/pida/services/contexts/uidef
170 %dir %{py_sitedir}/pida/services/editor
171 %{py_sitedir}/pida/services/editor/*.py[co]
172 %dir %{py_sitedir}/pida/services/filemanager
173 %{py_sitedir}/pida/services/filemanager/*.py[co]
174 %{py_sitedir}/pida/services/filemanager/uidef
175 %dir %{py_sitedir}/pida/services/filewatcher
176 %{py_sitedir}/pida/services/filewatcher/*.py[co]
177 %dir %{py_sitedir}/pida/services/grepper
178 %{py_sitedir}/pida/services/grepper/glade
179 %{py_sitedir}/pida/services/grepper/*.py[co]
180 %{py_sitedir}/pida/services/grepper/uidef
181 %dir %{py_sitedir}/pida/services/help
182 %{py_sitedir}/pida/services/help/*.py[co]
183 %{py_sitedir}/pida/services/help/uidef
184 %dir %{py_sitedir}/pida/services/language
185 %{py_sitedir}/pida/services/language/glade
186 %{py_sitedir}/pida/services/language/*.py[co]
187 %{py_sitedir}/pida/services/language/pixmaps
188 %{py_sitedir}/pida/services/language/uidef
189 %dir %{py_sitedir}/pida/services/manhole
190 %{py_sitedir}/pida/services/manhole/*.py[co]
191 %{py_sitedir}/pida/services/manhole/uidef
192 %dir %{py_sitedir}/pida/services/notify
193 %{py_sitedir}/pida/services/notify/*.py[co]
194 %{py_sitedir}/pida/services/notify/uidef
195 %dir %{py_sitedir}/pida/services/openwith
196 %{py_sitedir}/pida/services/openwith/glade
197 %{py_sitedir}/pida/services/openwith/*.py[co]
198 %{py_sitedir}/pida/services/openwith/uidef
199 %dir %{py_sitedir}/pida/services/optionsmanager
200 #%%{py_sitedir}/pida/services/optionsmanager/glade
201 %{py_sitedir}/pida/services/optionsmanager/*.py[co]
202 %{py_sitedir}/pida/services/optionsmanager/uidef
203 %dir %{py_sitedir}/pida/services/plugins
204 %{py_sitedir}/pida/services/plugins/glade
205 %{py_sitedir}/pida/services/plugins/*.py[co]
206 %{py_sitedir}/pida/services/plugins/uidef
207 %dir %{py_sitedir}/pida/services/project
208 %{py_sitedir}/pida/services/project/glade
209 %{py_sitedir}/pida/services/project/*.py[co]
210 %{py_sitedir}/pida/services/project/uidef
211 %{py_sitedir}/pida/services/*.py[co]
212 #%%dir %{py_sitedir}/pida/services/sessions
213 #%%{py_sitedir}/pida/services/sessions/glade
214 #%%{py_sitedir}/pida/services/sessions/*.py[co]
215 #%%{py_sitedir}/pida/services/sessions/uidef
216 %dir %{py_sitedir}/pida/services/shortcuts
217 %{py_sitedir}/pida/services/shortcuts/*.py[co]
218 %{py_sitedir}/pida/services/shortcuts/uidef
219 %dir %{py_sitedir}/pida/services/statusbar
220 %{py_sitedir}/pida/services/statusbar/*.py[co]
221 %dir %{py_sitedir}/pida/services/versioncontrol
222 %{py_sitedir}/pida/services/versioncontrol/glade
223 %{py_sitedir}/pida/services/versioncontrol/*.py[co]
224 %{py_sitedir}/pida/services/versioncontrol/uidef
225 %dir %{py_sitedir}/pida/services/window
226 %{py_sitedir}/pida/services/window/*.py[co]
227 %{py_sitedir}/pida/services/window/uidef
228 %{py_sitedir}/pida/ui
229 %{py_sitedir}/pida/utils
230
231 %{_pixmapsdir}/*.png
232 %{_desktopdir}/*.desktop
This page took 0.095432 seconds and 4 git commands to generate.