]> git.pld-linux.org Git - packages/pida.git/blob - pida.spec
- add R: python-argparse (thanks to Witold Firlej)
[packages/pida.git] / pida.spec
1 # TODO:
2 # - investigate the documentation format in doc
3 # - verify if such a big version jump actually works
4 # - move .po files to glibc dir and test if it works
5 #   are these used afterall, as they are .po sources not .mo compiled
6 # - moo_stub is just sample? kill it and can make package noarch.
7 # - pida probably needs some .py files to run properly
8 #
9 Summary:        A framework for integrated development
10 Summary(pl.UTF-8):      Szkielet do programowania zintegrowanego
11 Name:           pida
12 Version:        0.6.2
13 Release:        0.1
14 License:        GPL v2+
15 Group:          Development/Tools
16 Source0:        http://pypi.python.org/packages/source/p/pida/%{name}-%{version}.tar.gz
17 # Source0-md5:  6ee61497996abd54f8a9dacd39b90c8c
18 Source1:        %{name}.desktop
19 URL:            http://pida.co.uk/
20 BuildRequires:  pkgconfig
21 BuildRequires:  python-devel
22 BuildRequires:  python-pygtk-devel
23 BuildRequires:  python-pygtk-glade
24 BuildRequires:  python-setuptools
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.219
27 Requires:       fontconfig
28 Requires:       python-argparse
29 Requires:       python-gnome-desktop-gtksourceview
30 Requires:       python-gnome-gconf
31 Requires:       python-kiwi
32 Requires:       python-pygtkhelpers
33 Requires:       python-simplejson
34 Requires:       python-vte
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 PIDA is an integrated development environment (IDE) for UNIX-like
39 operating systems.
40
41 Unique Features:
42 - Vim embedding
43 - File browser that understands version status information for CVS,
44   Subversion, Darcs, Monotone, Mercurial, Bazaar-ng and Arch
45 - Built in GTK+ rapid application development
46 - Many more unique and obsessive touches
47
48 %description -l pl.UTF-8
49 PIDA to zintegrowane środowisko programistyczne (IDE) dla uniksowych
50 systemów operacyjnych.
51
52 Unikalne cechy:
53 - osadzony Vim
54 - przeglądarka plików uwzględniająca informacje o stanie wersji dla
55   systemów kontroli wersji CVS, Subversion, Darcs, Monotone, Mercurial,
56   Bazaar-ng i Arch
57 - wbudowane środowisko szybkiego tworzenia aplikacji GTK+
58 - wiele innych unikalnych i pożądanych drobiazgów
59
60 %prep
61 %setup -q
62
63 %build
64 %{__python} setup.py build
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
69
70 %{__python} setup.py install \
71         --install-data=%{_datadir}/%{name} \
72         --root=$RPM_BUILD_ROOT \
73         --optimize=2
74
75 cp $RPM_BUILD_ROOT%{py_sitedir}/%{name}/resources/pixmaps/pida-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}
76 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
77 #%%py_postclean
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS README
85 %attr(755,root,root) %{_bindir}/pida
86 %attr(755,root,root) %{_bindir}/pida-build
87 %attr(755,root,root) %{_bindir}/pida-remote
88
89 # see todo at top of the spec
90 #%%dir %{py_sitedir}/pida/resources/locale
91 #%%dir %{py_sitedir}/pida/services/appcontroller/locale
92 #%%dir %{py_sitedir}/pida/services/browseweb/locale
93 #%%dir %{py_sitedir}/pida/services/buffer/locale
94 #%%dir %{py_sitedir}/pida/services/bugreport/locale
95 #%%dir %{py_sitedir}/pida/services/commander/locale
96 #%%dir %{py_sitedir}/pida/services/editor/locale
97 #%%dir %{py_sitedir}/pida/services/filemanager/locale
98 #%%dir %{py_sitedir}/pida/services/grepper/locale
99 #%%dir %{py_sitedir}/pida/services/help/locale
100 #%%dir %{py_sitedir}/pida/services/manhole/locale
101 #%%dir %{py_sitedir}/pida/services/notify/locale
102 #%%dir %{py_sitedir}/pida/services/openwith/locale
103 #%%dir %{py_sitedir}/pida/services/optionsmanager/locale
104 #%%dir %{py_sitedir}/pida/services/plugins/locale
105 #%%dir %{py_sitedir}/pida/services/project/locale
106 #%%dir %{py_sitedir}/pida/services/sessions/locale
107 #%%dir %{py_sitedir}/pida/services/shortcuts/locale
108 #%%dir %{py_sitedir}/pida/services/versioncontrol/locale
109 #%%dir %{py_sitedir}/pida/services/window/locale
110 #%%lang(fr) %{py_sitedir}/pida/resources/locale/fr_FR
111 #%%lang(fr) %{py_sitedir}/pida/services/appcontroller/locale/fr_FR
112 #%%lang(fr) %{py_sitedir}/pida/services/browseweb/locale/fr_FR
113 #%%lang(fr) %{py_sitedir}/pida/services/buffer/locale/fr_FR
114 #%%lang(fr) %{py_sitedir}/pida/services/bugreport/locale/fr_FR
115 #%%lang(fr) %{py_sitedir}/pida/services/commander/locale/fr_FR
116 #%%lang(fr) %{py_sitedir}/pida/services/editor/locale/fr_FR
117 #%%lang(fr) %{py_sitedir}/pida/services/filemanager/locale/fr_FR
118 #%%lang(fr) %{py_sitedir}/pida/services/grepper/locale/fr_FR
119 #%%lang(fr) %{py_sitedir}/pida/services/help/locale/fr_FR
120 #%%lang(fr) %{py_sitedir}/pida/services/manhole/locale/fr_FR
121 #%%lang(fr) %{py_sitedir}/pida/services/notify/locale/fr_FR
122 #%%lang(fr) %{py_sitedir}/pida/services/openwith/locale/fr_FR
123 #%%lang(fr) %{py_sitedir}/pida/services/optionsmanager/locale/fr_FR
124 #%%lang(fr) %{py_sitedir}/pida/services/plugins/locale/fr_FR
125 #%%lang(fr) %{py_sitedir}/pida/services/project/locale/fr_FR
126 #%%lang(fr) %{py_sitedir}/pida/services/sessions/locale/fr_FR
127 #%%lang(fr) %{py_sitedir}/pida/services/shortcuts/locale/fr_FR
128 #%%lang(fr) %{py_sitedir}/pida/services/versioncontrol/locale/fr_FR
129 #$%lang(fr) %{py_sitedir}/pida/services/window/locale/fr_FR
130
131 %if "%{py_ver}" > "2.4"
132 %{py_sitedir}/pida-*-py2.*.egg-info
133 %endif
134
135 %dir %{py_sitedir}/pida
136 #%%attr(755,root,root) %{py_sitedir}/moo_stub.so
137 %{py_sitedir}/pida/*.py[co]
138 %{py_sitedir}/pida/core
139 %{py_sitedir}/pida/editors
140 %dir %{py_sitedir}/pida/plugins
141 %dir %{py_sitedir}/pida/plugins/*.py[co]
142 %dir %{py_sitedir}/pida/resources
143 #%%{py_sitedir}/pida/resources/glade
144 %{py_sitedir}/pida/resources/pixmaps
145 %{py_sitedir}/pida/resources/uidef
146 %dir %{py_sitedir}/pida/resources/data
147 %dir %{py_sitedir}/pida/resources/data/gtkrc-2.0
148 #%%{py_sitedir}/pida/resources/data/*.py[co]
149 %{py_sitedir}/pida/resources/data/*.vim
150 %{py_sitedir}/pida/resources/data/*.el
151 %dir %{py_sitedir}/pida/services
152 %dir %{py_sitedir}/pida/services/appcontroller
153 %{py_sitedir}/pida/services/appcontroller/*.py[co]
154 %{py_sitedir}/pida/services/appcontroller/uidef
155 %dir %{py_sitedir}/pida/services/browseweb
156 #%%{py_sitedir}/pida/services/browseweb/glade
157 %{py_sitedir}/pida/services/browseweb/*.py[co]
158 %{py_sitedir}/pida/services/browseweb/uidef
159 %dir %{py_sitedir}/pida/services/buffer
160 %{py_sitedir}/pida/services/buffer/glade
161 %{py_sitedir}/pida/services/buffer/*.py[co]
162 %{py_sitedir}/pida/services/buffer/uidef
163 #%%dir %{py_sitedir}/pida/services/bugreport
164 #%%{py_sitedir}/pida/services/bugreport/glade
165 #%%{py_sitedir}/pida/services/bugreport/*.py[co]
166 #%%{py_sitedir}/pida/services/bugreport/uidef
167 %dir %{py_sitedir}/pida/services/commander
168 %{py_sitedir}/pida/services/commander/*.py[co]
169 %{py_sitedir}/pida/services/commander/pixmaps
170 %{py_sitedir}/pida/services/commander/uidef
171 %dir %{py_sitedir}/pida/services/contexts
172 %{py_sitedir}/pida/services/contexts/*.py[co]
173 %{py_sitedir}/pida/services/contexts/uidef
174 %dir %{py_sitedir}/pida/services/editor
175 %{py_sitedir}/pida/services/editor/*.py[co]
176 %dir %{py_sitedir}/pida/services/filemanager
177 %{py_sitedir}/pida/services/filemanager/*.py[co]
178 %{py_sitedir}/pida/services/filemanager/uidef
179 %dir %{py_sitedir}/pida/services/filewatcher
180 %{py_sitedir}/pida/services/filewatcher/*.py[co]
181 %dir %{py_sitedir}/pida/services/grepper
182 %{py_sitedir}/pida/services/grepper/glade
183 %{py_sitedir}/pida/services/grepper/*.py[co]
184 %{py_sitedir}/pida/services/grepper/uidef
185 %dir %{py_sitedir}/pida/services/help
186 %{py_sitedir}/pida/services/help/*.py[co]
187 %{py_sitedir}/pida/services/help/uidef
188 %dir %{py_sitedir}/pida/services/language
189 %{py_sitedir}/pida/services/language/glade
190 %{py_sitedir}/pida/services/language/*.py[co]
191 %{py_sitedir}/pida/services/language/pixmaps
192 %{py_sitedir}/pida/services/language/uidef
193 %dir %{py_sitedir}/pida/services/manhole
194 %{py_sitedir}/pida/services/manhole/*.py[co]
195 %{py_sitedir}/pida/services/manhole/uidef
196 %dir %{py_sitedir}/pida/services/notify
197 %{py_sitedir}/pida/services/notify/*.py[co]
198 %{py_sitedir}/pida/services/notify/uidef
199 %dir %{py_sitedir}/pida/services/openwith
200 %{py_sitedir}/pida/services/openwith/glade
201 %{py_sitedir}/pida/services/openwith/*.py[co]
202 %{py_sitedir}/pida/services/openwith/uidef
203 %dir %{py_sitedir}/pida/services/optionsmanager
204 #%%{py_sitedir}/pida/services/optionsmanager/glade
205 %{py_sitedir}/pida/services/optionsmanager/*.py[co]
206 %{py_sitedir}/pida/services/optionsmanager/uidef
207 %dir %{py_sitedir}/pida/services/plugins
208 %{py_sitedir}/pida/services/plugins/glade
209 %{py_sitedir}/pida/services/plugins/*.py[co]
210 %{py_sitedir}/pida/services/plugins/uidef
211 %dir %{py_sitedir}/pida/services/project
212 %{py_sitedir}/pida/services/project/glade
213 %{py_sitedir}/pida/services/project/*.py[co]
214 %{py_sitedir}/pida/services/project/uidef
215 %{py_sitedir}/pida/services/*.py[co]
216 #%%dir %{py_sitedir}/pida/services/sessions
217 #%%{py_sitedir}/pida/services/sessions/glade
218 #%%{py_sitedir}/pida/services/sessions/*.py[co]
219 #%%{py_sitedir}/pida/services/sessions/uidef
220 %dir %{py_sitedir}/pida/services/shortcuts
221 %{py_sitedir}/pida/services/shortcuts/*.py[co]
222 %{py_sitedir}/pida/services/shortcuts/uidef
223 %dir %{py_sitedir}/pida/services/statusbar
224 %{py_sitedir}/pida/services/statusbar/*.py[co]
225 %dir %{py_sitedir}/pida/services/versioncontrol
226 %{py_sitedir}/pida/services/versioncontrol/glade
227 %{py_sitedir}/pida/services/versioncontrol/*.py[co]
228 %{py_sitedir}/pida/services/versioncontrol/uidef
229 %dir %{py_sitedir}/pida/services/window
230 %{py_sitedir}/pida/services/window/*.py[co]
231 %{py_sitedir}/pida/services/window/uidef
232 %{py_sitedir}/pida/ui
233 %{py_sitedir}/pida/utils
234
235 %{_pixmapsdir}/*.png
236 %{_desktopdir}/*.desktop
This page took 0.072317 seconds and 3 git commands to generate.