]> git.pld-linux.org Git - packages/physfs.git/blob - physfs.spec
- release 3
[packages/physfs.git] / physfs.spec
1 Summary:        PhysicsFS file abstraction layer for games
2 Summary(pl.UTF-8):      PhysicsFS - warstwa abstrakcji plików dla gier
3 Name:           physfs
4 Version:        1.0.1
5 Release:        3
6 License:        BSD-like (see LICENSE)
7 Group:          Libraries
8 Source0:        http://www.icculus.org/physfs/downloads/%{name}-%{version}.tar.gz
9 # Source0-md5:  d0bd118c6b55fb1e020fe982d6ec6957
10 URL:            http://www.icculus.org/physfs/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  doxygen
14 BuildRequires:  libtool
15 BuildRequires:  ncurses-devel
16 BuildRequires:  readline-devel
17 BuildRequires:  zlib-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 PhysicsFS is a library to provide abstract access to various archives.
22 It is intended for use in video games, and the design was somewhat
23 inspired by Quake 3's file subsystem. The programmer defines a "write
24 directory" on the physical filesystem. No file writing done through
25 the PhysicsFS API can leave that write directory, for security. For
26 example, an embedded scripting language cannot write outside of this
27 path if it uses PhysFS for all of its I/O, which means that untrusted
28 scripts can run more safely. Symbolic links can be disabled as well,
29 for added safety. For file reading, the programmer lists directories
30 and archives that form a "search path". Once the search path is
31 defined, it becomes a single, transparent hierarchical filesystem.
32 This makes for easy access to ZIP files in the same way as you access
33 a file directly on the disk, and it makes it easy to ship a new
34 archive that will override a previous archive on a per-file basis.
35 Finally, PhysicsFS gives you platform-abstracted means to determine if
36 CD-ROMs are available, the user's home directory, where in the real
37 filesystem your program is running, etc.
38
39 %description -l pl.UTF-8
40 PhysicsFS to biblioteka udostępniająca abstrakcyjny dostęp do różnych
41 archiwów. Została stworzona z myślą o grach video, a projekt był
42 trochę wzorowany na podsystemie plików z Quake 3. Programista
43 definiuje "katalog zapisu" w fizycznym systemie plików. Żaden zapis do
44 pliku poprzez API PhysicsFS nie może wyjść poza ten katalog - ze
45 względu na bezpieczeństwo. Na przykład, wbudowany język skryptowy nie
46 może zapisywać poza tą ścieżką, jeżeli używa PhysicsFS do wszystkich
47 operacji wejścia/wyjścia, dzięki czemu można bezpiecznie uruchamiać
48 nie zaufane skrypty. Dowiązania symboliczne także mogą być wyłączone
49 dla poprawy bezpieczeństwa. Do odczytu pliku programista podaje
50 katalogi i archiwa, które składają się na "ścieżkę poszukiwań". Po
51 zdefiniowaniu tej ścieżki, staje się ona pojedynczym, przezroczystym
52 hierarchicznym systemem plików. Pozwala to na łatwy dostęp do plików
53 ZIP w taki sam sposób, jak do plików na dysku, a także ułatwia
54 dostarczenie nowego archiwum, które przykryje poprzednie na poziomie
55 plików. Ponadto PhysicsFS daje wyabstrahowane od platformy sposoby na
56 określenie, czy dostępne są CD-ROMy, katalog domowy użytkownika, gdzie
57 w prawdziwym systemie plików działa program itp.
58
59 %package devel
60 Summary:        Header files for PhysicsFS development
61 Summary(pl.UTF-8):      Pliki nagłówkowe do programowania z użyciem PhysicsFS
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       zlib-devel
65
66 %description devel
67 PhysicsFS is a library to provide abstract access to various archives.
68 This package contains the development headers and documentaion to
69 build programs using PhysicsFS.
70
71 %description devel -l pl.UTF-8
72 PhysicsFS to biblioteka udostępniająca abstrakcyjny dostęp do różnych
73 archiwów. Ten pakiet zawiera pliki nagłówkowe i dokumentację do
74 budowania programów z użyciem PhysicsFS.
75
76 %package static
77 Summary:        Static PhysicsFS libraries
78 Summary(pl.UTF-8):      Statyczne biblioteki PhysicsFS
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 PhysicsFS is a library to provide abstract access to various archives.
84 This package contains the static PhysicsFS libraries.
85
86 %description static -l pl.UTF-8
87 PhysicsFS to biblioteka udostępniająca abstrakcyjny dostęp do różnych
88 archiwów. Ten pakiet zawiera statyczne biblioteki PhysicsFS.
89
90 %package programs
91 Summary:        Program for testing PhysicsFS archives
92 Summary(pl.UTF-8):      Program do testowania archiwów PhysicsFS
93 Group:          Development/Libraries
94 Requires:       %{name} = %{version}-%{release}
95
96 %description programs
97 PhysicsFS is a library to provide abstract access to various archives.
98 This package contains the programs using for PhysicsFS archives
99 testing.
100
101 %description programs -l pl.UTF-8
102 PhysicsFS to biblioteka udostępniająca abstrakcyjny dostęp do różnych
103 archiwów. Ten pakiet zawiera program używany do testowania archiwów
104 PhysicsFS.
105
106 %prep
107 %setup -q
108
109 %build
110 %{__libtoolize}
111 %{__aclocal}
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 %configure
116 # unused beos.cpp causes unnecessary using CXXLINK... workaround
117 %{__make} \
118         CXXLINK="\$(LINK)"
119
120 doxygen
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT%{_mandir}/man3
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 install docs/man/man3/{PHYS*,phys*} $RPM_BUILD_ROOT%{_mandir}/man3
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc CHANGELOG CREDITS LICENSE TODO
140 %attr(755,root,root) %{_libdir}/lib*.so.*.*
141 %ghost %{_libdir}/lib*.so.1
142
143 %files devel
144 %defattr(644,root,root,755)
145 %doc docs/html
146 %attr(755,root,root) %{_libdir}/lib*.so
147 %{_libdir}/lib*.la
148 %{_includedir}/physfs.h
149 %{_mandir}/man3/*
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/lib*.a
154
155 %files programs
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_bindir}/test_physfs
This page took 0.809536 seconds and 3 git commands to generate.