]> git.pld-linux.org Git - packages/physfs.git/blob - physfs.spec
a97935788c8c0333f9f42311d76e67e6ae2baa6e
[packages/physfs.git] / physfs.spec
1 Summary:        PhysicsFS file abstraction layer for games
2 Summary(pl):    PhysicsFS - warstwa abstrakcji plików dla gier
3 Name:           physfs
4 Version:        0.1.8
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://www.icculus.org/physfs/downloads/%{name}-%{version}.tar.gz
9 URL:            http://www.icculus.org/physfs/
10 BuildRequires:  doxygen
11 BuildRequires:  ncurses-devel
12 BuildRequires:  readline-devel
13 BuildRequires:  zlib-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 PhysicsFS is a library to provide abstract access to various archives.
18 It is intended for use in video games, and the design was somewhat
19 inspired by Quake 3's file subsystem. The programmer defines a "write
20 directory" on the physical filesystem. No file writing done through
21 the PhysicsFS API can leave that write directory, for security. For
22 example, an embedded scripting language cannot write outside of this
23 path if it uses PhysFS for all of its I/O, which means that untrusted
24 scripts can run more safely. Symbolic links can be disabled as well,
25 for added safety. For file reading, the programmer lists directories
26 and archives that form a "search path". Once the search path is
27 defined, it becomes a single, transparent hierarchical filesystem.
28 This makes for easy access to ZIP files in the same way as you access
29 a file directly on the disk, and it makes it easy to ship a new
30 archive that will override a previous archive on a per-file basis.
31 Finally, PhysicsFS gives you platform-abstracted means to determine if
32 CD-ROMs are available, the user's home directory, where in the real
33 filesystem your program is running, etc. 
34
35 %description -l pl
36 PhysicsFS to biblioteka udostêpniaj±ca abstrakcyjny dostêp do ró¿nych
37 archiwów. Zosta³a stworzona z my¶l± o grach video, a projekt by³
38 trochê wzorowany na podsystemie plików z Quake 3. Programista
39 definiuje "katalog zapisu" w fizycznym systemie plików. ¯aden zapis do
40 pliku poprzez API PhysicsFS nie mo¿e wyj¶æ poza ten katalog - ze
41 wzglêdu na bezpieczeñstwo. Na przyk³ad, wbudowany jêzyk skryptowy nie
42 mo¿e zapisywaæ poza t± ¶cie¿k±, je¿eli u¿ywa PhysicsFS do wszystkich
43 operacji wej¶cia/wyj¶cia, dziêki czemu mo¿na bezpiecznie uruchamiaæ
44 nie zaufane skrypty. Dowi±zania symboliczne tak¿e mog± byæ wy³±czone
45 dla poprawy bezpieczeñstwa. Do odczytu pliku programista podaje
46 katalogi i archiwa, które sk³adaj± siê na "¶cie¿kê poszukiwañ". Po
47 zdefiniowaniu tej ¶cie¿ki, staje siê ona pojedynczym, przezroczystym
48 hierarchicznym systemem plików. Pozwala to na ³atwy dostêp do plików
49 ZIP w taki sam sposób, jak do plików na dysku, a tak¿e u³atwia
50 dostarczenie nowego archiwum, które przykryje poprzednie na poziomie
51 plików. Ponadto PhysicsFS daje wyabstrahowane od platformy sposoby na
52 okre¶lenie, czy dostêpne s± CD-ROMy, katalog domowy u¿ytkownika, gdzie
53 w prawdziwym systemie plików dzia³a program itp.
54
55 %package devel
56 Summary:        Header files for PhysicsFS development
57 Summary(pl):    Pliki nag³ówkowe do programowania z u¿yciem PhysicsFS
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}
60
61 %description devel
62 PhysicsFS is a library to provide abstract access to various archives.
63 This package contains the development headers and documentaion to
64 build programs using PhysicsFS.
65
66 %description devel -l pl
67 PhysicsFS to biblioteka udostêpniaj±ca abstrakcyjny dostêp do ró¿nych
68 archiwów. Ten pakiet zawiera pliki nag³ówkowe i dokumentacjê do
69 budowania programów z u¿yciem PhysicsFS.
70
71 %package static
72 Summary:        Static PhysicsFS libraries
73 Summary(pl):    Statyczne biblioteki PhysicsFS
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}
76
77 %description static
78 PhysicsFS is a library to provide abstract access to various archives.
79 This package contains the static PhysicsFS libraries.
80
81 %description static -l pl
82 PhysicsFS to biblioteka udostêpniaj±ca abstrakcyjny dostêp do ró¿nych
83 archiwów. Ten pakiet zawiera statyczne biblioteki PhysicsFS.
84
85 %package programs
86 Summary:        Program for testing PhysicsFS archives
87 Summary(pl):    Program do testowania archiwów PhysicsFS
88 Group:          Development/Libraries
89 Requires:       %{name} = %{version}
90
91 %description programs
92 PhysicsFS is a library to provide abstract access to various archives.
93 This package contains the programs using for PhysicsFS archives
94 testing.
95
96 %description programs -l pl
97 PhysicsFS to biblioteka udostêpniaj±ca abstrakcyjny dostêp do ró¿nych
98 archiwów. Ten pakiet zawiera program u¿ywany do testowania archiwów
99 PhysicsFS.
100
101 %prep
102 %setup -q
103
104 %build
105 %configure
106 %{__make}
107
108 doxygen
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT%{_mandir}/man3
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 install docs/man/man3/{PHYS*,phys*} $RPM_BUILD_ROOT%{_mandir}/man3
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc CHANGELOG CREDITS
128 %attr(755,root,root) %{_libdir}/lib*.so.*.*
129
130 %files devel
131 %defattr(644,root,root,755)
132 %doc docs/html
133 %attr(755,root,root) %{_libdir}/lib*.so
134 %{_libdir}/lib*.la
135 %{_includedir}/physfs.h
136 %{_mandir}/man3/*
137
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/lib*.a
141
142 %files programs
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/test_physfs
This page took 0.075534 seconds and 2 git commands to generate.