]> git.pld-linux.org Git - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
- typo
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 Summary:        phpMyAdmin - web-based MySQL administration
2 Summary(pl.UTF-8):      phpMyAdmin - administracja bazami MySQL przez WWW
3 Name:           phpMyAdmin
4 Version:        2.11.5.2
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/Databases/Interfaces
8 Source0:        http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
9 # Source0-md5:  17ac7e34fe4ed70385d166d7fb4f9f3d
10 Source1:        %{name}.conf
11 Source2:        %{name}-lighttpd.conf
12 Patch0:         %{name}-config.patch
13 URL:            http://www.phpmyadmin.net/
14 BuildRequires:  rpmbuild(macros) >= 1.268
15 Requires(triggerpostun):        sed >= 4.0
16 Requires:       php(ctype)
17 Requires:       php(mcrypt)
18 Requires:       php(mbstring)
19 Requires:       php(mysql)
20 Requires:       php(pcre)
21 Requires:       webapps
22 Requires:       webserver(access)
23 Requires:       webserver(php)
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _appdir         %{_datadir}/%{name}
28 %define         _webapps        /etc/webapps
29 %define         _webapp         %{name}
30 %define         _sysconfdir     %{_webapps}/%{_webapp}
31
32 %description
33 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
34 but also a single database. To accomplish the latter you'll need a
35 properly set up MySQL-user who can read/write only the desired
36 database. It's up to you to look up the appropiate part in the MySQL
37 manual. Currently phpMyAdmin can:
38 - create and drop databases
39 - create, copy, drop and alter tables
40 - delete, edit and add fields
41 - execute any SQL-statement, even batch-queries
42 - manage keys on fields
43 - load text files into tables
44 - create (*) and read dumps of tables
45 - export (*) and import data to CSV values
46 - administer multiple servers and single databases
47 - check referencial integrity
48 - create complex queries automatically connecting required tables
49 - create PDF graphics of your database layout
50 - communicate in more than 50 different languages
51
52 %description -l pl.UTF-8
53 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
54 uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
55 Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
56 baz, którymi chcemy administrować (więcej informacji w odpowiedniej
57 podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
58 - tworzyć i usuwać bazy
59 - wykonywać create, copy, drop oraz alter na tabelach
60 - dodawać, usuwać i modyfikować pola
61 - wykonywać dowolne zapytania SQL
62 - zarządzać kluczami na rekordach
63 - wczytywać tekst z plików do tabel
64 - obsługiwać ponad 20 języków
65 - zarządzać wieloma serwerami i pojedynczymi bazami danych
66 - eksportować i importować dane do wartości CSV
67 - tworzyć i czytać zrzuty tabel
68
69 %prep
70 %setup -q -n %{name}-%{version}-all-languages
71 %patch0 -p1
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/{js,lang,libraries/{auth,dbg,dbi,engines,export,tcpdf/font,import,transformations}}}
76
77 install *.php *.html *.css $RPM_BUILD_ROOT%{_appdir}
78 install lang/*.php $RPM_BUILD_ROOT%{_appdir}/lang
79 cp -rf pmd $RPM_BUILD_ROOT%{_appdir}
80 cp -rf themes $RPM_BUILD_ROOT%{_appdir}
81 install js/* $RPM_BUILD_ROOT%{_appdir}/js
82 install libraries/*.php $RPM_BUILD_ROOT%{_appdir}/libraries
83 install libraries/auth/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/auth
84 install libraries/dbg/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbg
85 install libraries/dbi/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbi
86 install libraries/engines/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/engines
87 install libraries/export/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/export
88 install libraries/import/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/import
89 install libraries/tcpdf/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf
90 install libraries/tcpdf/font/*.{php,z} $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf/font
91 install libraries/transformations/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/transformations
92
93 install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
94 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
95
96 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
97 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
98 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
99
100 cp -f libraries/tcpdf/README{,-tcpdf}
101 cp -f libraries/import/README{,-import}
102 cp -f libraries/transformations/README{,-transformations}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %triggerin -- apache1 < 1.3.37-3, apache1-base
108 %webapp_register apache %{_webapp}
109
110 %triggerun -- apache1 < 1.3.37-3, apache1-base
111 %webapp_unregister apache %{_webapp}
112
113 %triggerin -- apache < 2.2.0, apache-base
114 %webapp_register httpd %{_webapp}
115
116 %triggerun -- apache < 2.2.0, apache-base
117 %webapp_unregister httpd %{_webapp}
118
119 %triggerin -- lighttpd
120 %webapp_register lighttpd %{_webapp}
121
122 %triggerun -- lighttpd
123 %webapp_unregister lighttpd %{_webapp}
124
125 %files
126 %defattr(644,root,root,755)
127 %doc Documentation.* CREDITS ChangeLog INSTALL README TODO translators.html scripts libraries/tcpdf/README-tcpdf libraries/import/README-import libraries/transformations/README-transformations libraries/transformations/TEMPLATE* libraries/transformations/*.sh lang/*.sh
128 %dir %attr(750,root,http) %{_sysconfdir}
129 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
130 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
131 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
132 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
133 %dir %{_appdir}
134 %{_appdir}/js
135 %{_appdir}/lang
136 %{_appdir}/libraries
137 %{_appdir}/pmd
138 %{_appdir}/themes
139 %{_appdir}/*.css
140 %{_appdir}/*.html
141 %{_appdir}/*.php
This page took 0.039357 seconds and 4 git commands to generate.