]> git.pld-linux.org Git - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
- corrected CVE identifiers for 4 security flaws in previous commit log
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 # TODO
2 # - add codepress (http://codepress.org/index.php) patch
3 Summary:        phpMyAdmin - web-based MySQL administration
4 Summary(pl.UTF-8):      phpMyAdmin - administracja bazami MySQL przez WWW
5 Name:           phpMyAdmin
6 Version:        3.4.3.2
7 Release:        21
8 License:        GPL v2
9 Group:          Applications/Databases/Interfaces
10 Source0:        http://downloads.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
11 # Source0-md5:  9905538aa08d6dc9029a3f8d9e7fe8ea
12 Source1:        %{name}.conf
13 Source2:        %{name}-lighttpd.conf
14 Patch0:         %{name}-config.patch
15 Patch1:         %{name}-ServerSelectDisplayName.patch
16 Patch2:         %{name}-ServerSelectDisplayName-config.patch
17 URL:            http://www.phpmyadmin.net/
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires(triggerpostun):        sed >= 4.0
20 Requires:       php-common >= 4:5.2
21 Requires:       php-ctype
22 Requires:       php-mbstring
23 Requires:       php-mcrypt
24 Requires:       php-mysql
25 Requires:       php-pcre
26 Requires:       php-session
27 Requires:       php-simplexml
28 Requires:       webapps
29 Requires:       webserver(access)
30 Requires:       webserver(alias)
31 Suggests:       php-mysqli
32 Suggests:       webserver(indexfile)
33 Suggests:       webserver(php)
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _appdir         %{_datadir}/%{name}
38 %define         _webapps        /etc/webapps
39 %define         _webapp         %{name}
40 %define         _sysconfdir     %{_webapps}/%{_webapp}
41
42 %description
43 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
44 but also a single database. To accomplish the latter you'll need a
45 properly set up MySQL-user who can read/write only the desired
46 database. It's up to you to look up the appropiate part in the MySQL
47 manual. Currently phpMyAdmin can:
48 - create and drop databases
49 - create, copy, drop and alter tables
50 - delete, edit and add fields
51 - execute any SQL-statement, even batch-queries
52 - manage keys on fields
53 - load text files into tables
54 - create (*) and read dumps of tables
55 - export (*) and import data to CSV values
56 - administer multiple servers and single databases
57 - check referencial integrity
58 - create complex queries automatically connecting required tables
59 - create PDF graphics of your database layout
60 - communicate in more than 50 different languages
61
62 %description -l pl.UTF-8
63 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
64 uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
65 Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
66 baz, którymi chcemy administrować (więcej informacji w odpowiedniej
67 podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
68 - tworzyć i usuwać bazy
69 - wykonywać create, copy, drop oraz alter na tabelach
70 - dodawać, usuwać i modyfikować pola
71 - wykonywać dowolne zapytania SQL
72 - zarządzać kluczami na rekordach
73 - wczytywać tekst z plików do tabel
74 - obsługiwać ponad 20 języków
75 - zarządzać wieloma serwerami i pojedynczymi bazami danych
76 - eksportować i importować dane do wartości CSV
77 - tworzyć i czytać zrzuty tabel
78
79 %prep
80 %setup -q -n %{name}-%{version}-all-languages
81 %patch0 -p1
82 %patch1 -p0
83 %patch2 -p0
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
88
89 install *.php *.html *.css $RPM_BUILD_ROOT%{_appdir}
90 cp -a locale pmd themes js libraries $RPM_BUILD_ROOT%{_appdir}
91
92 install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
93 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
94
95 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
96 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
97 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
98
99 cp -f libraries/import/README{,-import}
100 cp -f libraries/transformations/README{,-transformations}
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %triggerin -- apache1 < 1.3.37-3, apache1-base
106 %webapp_register apache %{_webapp}
107
108 %triggerun -- apache1 < 1.3.37-3, apache1-base
109 %webapp_unregister apache %{_webapp}
110
111 %triggerin -- apache < 2.2.0, apache-base
112 %webapp_register httpd %{_webapp}
113
114 %triggerun -- apache < 2.2.0, apache-base
115 %webapp_unregister httpd %{_webapp}
116
117 %triggerin -- lighttpd
118 %webapp_register lighttpd %{_webapp}
119
120 %triggerun -- lighttpd
121 %webapp_unregister lighttpd %{_webapp}
122
123 %files
124 %defattr(644,root,root,755)
125 %doc Documentation.* CREDITS ChangeLog INSTALL README TODO scripts libraries/import/README-import libraries/transformations/README-transformations libraries/transformations/TEMPLATE* libraries/transformations/*.sh
126 %dir %attr(750,root,http) %{_sysconfdir}
127 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
128 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
129 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
130 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
131 %dir %{_appdir}
132 %{_appdir}/js
133 %{_appdir}/libraries
134 %{_appdir}/locale
135 %{_appdir}/pmd
136 %{_appdir}/themes
137 %{_appdir}/*.css
138 %{_appdir}/*.html
139 %{_appdir}/*.php
This page took 0.062436 seconds and 4 git commands to generate.