]> git.pld-linux.org Git - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
c6df5caf3b0dba2599015c2f0a15618cd1b49daf
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 Summary:        phpMyAdmin - web-based MySQL administration
2 Summary(pl):    phpMyAdmin - administracja bazami MySQL przez WWW
3 Name:           phpMyAdmin
4 %define         _pl     pl3
5 Version:        2.6.0
6 Release:        1.%{_pl}.1
7 License:        GPL v2
8 Group:          Applications/Databases/Interfaces
9 Source0:        http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}-%{_pl}.tar.bz2
10 # Source0-md5:  9580c5da497af4ff9ff3af7fa6e2793c
11 #Source0:       http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}.tar.bz2
12 Source1:        %{name}.conf
13 Patch0:         %{name}-config.patch
14 URL:            http://www.phpmyadmin.net/
15 #Requires:      mysql
16 Requires(postun):       perl-base
17 Requires:       php-mysql
18 Requires:       php-pcre
19 Requires:       php
20 Requires:       webserver
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _myadmindir     %{_datadir}/%{name}
25 %define         _sysconfdir     /etc/%{name}
26
27 %description
28 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
29 but also a single database. To accomplish the latter you'll need a
30 properly set up MySQL-user who can read/write only the desired
31 database. It's up to you to look up the appropiate part in the MySQL
32 manual. Currently phpMyAdmin can:
33 - create and drop databases
34 - create, copy, drop and alter tables
35 - delete, edit and add fields
36 - execute any SQL-statement, even batch-queries
37 - manage keys on fields
38 - load text files into tables
39 - create (*) and read dumps of tables
40 - export (*) and import data to CSV values
41 - administer multiple servers and single databases
42 - communicate in more than 20 different languages
43
44 %description -l pl
45 phpMyAdmin potrafi zarz±dzaæ ca³ymi bazami MySQL (potrzebne
46 uprawnienia superu¿ytkownika) jak i pojedynczymi bazami danych.
47 Potrzebny jest u¿ytkownik, który ma prawa zapisu/odczytu tylko tych
48 baz, którymi chcemy administrowaæ (wiêcej informacji w odpowiedniej
49 podrêcznika MySQL). Aktualnie phpMyAdmin potrafi:
50 - tworzyæ i usuwaæ bazy
51 - wykonywaæ create, copy, drop oraz alter na tabelach
52 - dodawaæ, usuwaæ i modyfikowaæ pola
53 - wykonywaæ dowolne zapytania SQL
54 - zarz±dzaæ kluczami na rekordach
55 - wczytywaæ tekst z plików do tabel
56 - obs³ugiwaæ ponad 20 jêzyków
57 - zarz±dzaæ wieloma serwerami i pojedynczymi bazami danych
58 - eksportowaæ i importowaæ dane do warto¶ci CSV
59 - tworzyæ i czytaæ zrzuty tabel
60
61 %prep
62 %setup -q -n %{name}-%{version}-%{_pl}
63 #%setup -q
64 %patch -p1
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT%{_myadmindir}/{css,lang,libraries/{auth,export,dbg,dbi,transformations}} \
69         $RPM_BUILD_ROOT{%{_sysconfdir},/etc/httpd}
70
71 install *.php *.html *.css $RPM_BUILD_ROOT%{_myadmindir}
72 #install images/*.{gif,png} $RPM_BUILD_ROOT%{_myadmindir}/images
73 install lang/*.php $RPM_BUILD_ROOT%{_myadmindir}/lang
74 cp -rf themes $RPM_BUILD_ROOT%{_myadmindir}/
75 install css/* $RPM_BUILD_ROOT%{_myadmindir}/css
76 install libraries/*.{js,php} $RPM_BUILD_ROOT%{_myadmindir}/libraries
77 install libraries/auth/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/auth
78 install libraries/export/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/export
79 install libraries/dbg/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/dbg
80 install libraries/dbi/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/dbi
81 install libraries/transformations/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/transformations
82
83 cp -rf scripts $RPM_BUILD_ROOT%{_myadmindir}
84
85 install config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}
86 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_myadmindir}/config.inc.php
87
88 install %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/%{name}.conf
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*%{name}.conf" /etc/httpd/httpd.conf; then
95         echo "Include /etc/httpd/%{name}.conf" >> /etc/httpd/httpd.conf
96         if [ -f /var/lock/subsys/httpd ]; then
97                 /usr/sbin/apachectl restart 1>&2
98         fi
99 elif [ -d /etc/httpd/httpd.conf ]; then
100         ln -sf /etc/httpd/%{name}.conf /etc/httpd/httpd.conf/99_%{name}.conf
101         if [ -f /var/lock/subsys/httpd ]; then
102                 /usr/sbin/apachectl restart 1>&2
103         fi
104 fi
105
106 %preun
107 if [ "$1" = "0" ]; then
108         umask 027
109         if [ -d /etc/httpd/httpd.conf ]; then
110                 rm -f /etc/httpd/httpd.conf/99_%{name}.conf
111         else
112                 grep -v "^Include.*%{name}.conf" /etc/httpd/httpd.conf > \
113                         /etc/httpd/httpd.conf.tmp
114                 mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
115         fi
116         if [ -f /var/lock/subsys/httpd ]; then
117                 /usr/sbin/apachectl restart 1>&2
118         fi
119 fi
120
121 %triggerpostun -- phpMyAdmin <= 2.5.3-2
122 if [ -f /home/services/httpd/html/myadmin/config.inc.php.rpmsave ]; then
123         mv -f /home/services/httpd/html/myadmin/config.inc.php.rpmsave /etc/phpMyAdmin/config.inc.php
124 else
125         if [ -f /home/httpd/html/myadmin/config.inc.php.rpmsave ]; then
126                 mv -f /home/httpd/html/myadmin/config.inc.php.rpmsave /etc/phpMyAdmin/config.inc.php
127         fi
128 fi
129 for i in `grep -lr "/home/\(services/\)*httpd/html/myadmin" /etc/httpd/*`; do
130         cp $i $i.backup
131         %{__perl} -pi -e "s#/home/httpd/html/myadmin#%{_myadmindir}#g" $i
132         %{__perl} -pi -e "s#/home/services/httpd/html/myadmin#%{_myadmindir}#g" $i
133         echo "File changed by trigger: $i (backup: $i.backup)"
134 done
135 if [ -f /var/lock/subsys/httpd ]; then
136         /usr/sbin/apachectl restart 1>&2
137 fi
138
139 %files
140 %defattr(644,root,root,755)
141 %doc Documentation.* CREDITS ChangeLog INSTALL README TODO translators.html scripts
142 %dir %{_sysconfdir}
143 %attr(640,root,http) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*
144 %config(noreplace) %verify(not size mtime md5) /etc/httpd/%{name}.conf
145 %dir %{_myadmindir}
146 %{_myadmindir}/css
147 %{_myadmindir}/themes
148 %{_myadmindir}/scripts
149 %{_myadmindir}/lang
150 %{_myadmindir}/libraries
151 %{_myadmindir}/*.css
152 %{_myadmindir}/*.html
153 %{_myadmindir}/*.php
This page took 0.061725 seconds and 2 git commands to generate.