]> git.pld-linux.org Git - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
- fix patch file name
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 # TODO
2 # - add codepress (http://codepress.org/index.php) patch
3 # - use system jquery (js/jquery), tcpdf (libraries/tcpdf) and php-gettext (libraries/gettext)
4 Summary:        phpMyAdmin - web-based MySQL administration
5 Summary(pl.UTF-8):      phpMyAdmin - administracja bazami MySQL przez WWW
6 Name:           phpMyAdmin
7 Version:        4.0.0
8 Release:        2
9 License:        GPL v2
10 Group:          Applications/Databases/Interfaces
11 Source0:        http://downloads.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
12 # Source0-md5:  42ab4ee21915687753861699635d2bde
13 Source1:        %{name}-apache.conf
14 Source2:        %{name}-lighttpd.conf
15 Source3:        %{name}-httpd.conf
16 Patch0:         %{name}-config.patch
17 Patch1:         %{name}-ServerSelectDisplayName.patch
18 Patch2:         %{name}-ServerSelectDisplayName-config.patch
19 URL:            http://www.phpmyadmin.net/
20 BuildRequires:  rpmbuild(macros) >= 1.268
21 Requires(triggerpostun):        sed >= 4.0
22 Requires:       php(core) >= 5.2
23 Requires:       php(ctype)
24 Requires:       php(filter)
25 Requires:       php(json)
26 Requires:       php(mbstring)
27 Requires:       php(mcrypt)
28 Requires:       php(mysql)
29 Requires:       php(pcre)
30 Requires:       php(session)
31 Requires:       php(simplexml)
32 Requires:       webapps
33 Requires:       webserver(access)
34 Requires:       webserver(alias)
35 Suggests:       php-mysqli
36 Suggests:       webserver(indexfile)
37 Suggests:       webserver(php)
38 Conflicts:      apache-base < 2.4.0-1
39 BuildArch:      noarch
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _appdir         %{_datadir}/%{name}
43 %define         _webapps        /etc/webapps
44 %define         _webapp         %{name}
45 %define         _sysconfdir     %{_webapps}/%{_webapp}
46
47 %description
48 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
49 but also a single database. To accomplish the latter you'll need a
50 properly set up MySQL-user who can read/write only the desired
51 database. It's up to you to look up the appropiate part in the MySQL
52 manual. Currently phpMyAdmin can:
53 - create and drop databases
54 - create, copy, drop and alter tables
55 - delete, edit and add fields
56 - execute any SQL-statement, even batch-queries
57 - manage keys on fields
58 - load text files into tables
59 - create (*) and read dumps of tables
60 - export (*) and import data to CSV values
61 - administer multiple servers and single databases
62 - check referencial integrity
63 - create complex queries automatically connecting required tables
64 - create PDF graphics of your database layout
65 - communicate in more than 50 different languages
66
67 %description -l pl.UTF-8
68 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
69 uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
70 Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
71 baz, którymi chcemy administrować (więcej informacji w odpowiedniej
72 podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
73 - tworzyć i usuwać bazy
74 - wykonywać create, copy, drop oraz alter na tabelach
75 - dodawać, usuwać i modyfikować pola
76 - wykonywać dowolne zapytania SQL
77 - zarządzać kluczami na rekordach
78 - wczytywać tekst z plików do tabel
79 - obsługiwać ponad 20 języków
80 - zarządzać wieloma serwerami i pojedynczymi bazami danych
81 - eksportować i importować dane do wartości CSV
82 - tworzyć i czytać zrzuty tabel
83
84 %prep
85 %setup -q -n %{name}-%{version}-all-languages
86 %patch0 -p1
87 %patch1 -p0
88 %patch2 -p0
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
93
94 install *.php *.css favicon.ico robots.txt $RPM_BUILD_ROOT%{_appdir}
95 cp -a locale themes js libraries $RPM_BUILD_ROOT%{_appdir}
96
97 install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
98 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
99
100 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
101 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
102 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %triggerin -- apache1 < 1.3.37-3, apache1-base
108 %webapp_register apache %{_webapp}
109
110 %triggerun -- apache1 < 1.3.37-3, apache1-base
111 %webapp_unregister apache %{_webapp}
112
113 %triggerin -- apache-base
114 %webapp_register httpd %{_webapp}
115
116 %triggerun -- apache-base
117 %webapp_unregister httpd %{_webapp}
118
119 %triggerin -- lighttpd
120 %webapp_register lighttpd %{_webapp}
121
122 %triggerun -- lighttpd
123 %webapp_unregister lighttpd %{_webapp}
124
125 %files
126 %defattr(644,root,root,755)
127 %doc ChangeLog README
128 %dir %attr(750,root,http) %{_sysconfdir}
129 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
130 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
131 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
132 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
133 %dir %{_appdir}
134 %{_appdir}/js
135 %{_appdir}/libraries
136 %{_appdir}/locale
137 %{_appdir}/themes
138 %{_appdir}/*.css
139 %{_appdir}/*.php
140 %{_appdir}/favicon.ico
141 %{_appdir}/robots.txt
This page took 0.217529 seconds and 3 git commands to generate.