]> git.pld-linux.org Git - packages/phpBB.git/commitdiff
- added favicon.ico, robots.txt to trigger
authordzeus <dzeus@pld-linux.org>
Sun, 22 Jan 2006 18:38:42 +0000 (18:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    phpBB.spec -> 1.85

phpBB.spec

index 2371d14ee9db69eb0660ee85354ed4153d25e033..e8c7e5eb05706da011eecdf36c015cf3e84218b0 100644 (file)
@@ -6,7 +6,7 @@ Summary(pl):    Forum dyskusyjne o du
 Name:          phpBB
 Version:       2.0.19
 %define        fver    20195
-Release:       0.7
+Release:       0.9
 License:       GPL v2
 Group:         Applications/WWW
 Source0:       http://dl.sourceforge.net/phpbb-php5mod/%{fver}.tar.bz2
@@ -147,20 +147,26 @@ done
 
 %triggerpostun -- %{name} < 2.0.19-0.5
 # rescue app config from various old locations
-if [ -f /home/services/httpd/html/phpBB/config.php.rpmsave ]; then
-       mv -f %{_sysconfdir}/config.php{,.rpmnew}
-       mv -f /home/services/httpd/html/phpBB/config.php.rpmsave %{_sysconfdir}/config.php
-fi
+for i in config.php favicon.ico robots.txt; do
+    if [ -f /home/services/httpd/html/phpBB/$i.rpmsave ]; then
+           mv -f %{_sysconfdir}/$i{,.rpmnew}
+           mv -f /home/services/httpd/html/phpBB/$i.rpmsave %{_sysconfdir}/$i
+    fi
+done
 
-if [ -f /home/httpd/html/phpBB/config.php.rpmsave ]; then
-       mv -f %{_sysconfdir}/config.php{,.rpmnew}
-       mv -f /home/httpd/html/phpBB/config.php.rpmsave %{_sysconfdir}/config.php
-fi
+for i in config.php favicon.ico robots.txt; do
+    if [ -f /home/httpd/html/phpBB/$i.rpmsave ]; then
+           mv -f %{_sysconfdir}/$i{,.rpmnew}
+           mv -f /home/httpd/html/phpBB/$i.rpmsave %{_sysconfdir}/$i
+    fi
+done
 
-if [ -f /etc/%{name}/config.php.rpmsave ]; then
-       mv -f %{_sysconfdir}/config.php{,.rpmnew}
-       mv -f /etc/%{name}/config.php.rpmsave %{_sysconfdir}/config.php
-fi
+for i in config.php favicon.ico robots.txt; do
+    if [ -f /etc/%{name}/$i.rpmsave ]; then
+           mv -f %{_sysconfdir}/$i{,.rpmnew}
+           mv -f /etc/%{name}/$i.rpmsave %{_sysconfdir}/$i
+    fi
+done
 
 # nuke very-old config location (this mostly for Ra)
 if [ -f /etc/httpd/httpd.conf ]; then
This page took 0.144656 seconds and 4 git commands to generate.