]> git.pld-linux.org Git - packages/phpBB.git/blob - phpBB.spec
- massive attack s/pld.org.pl/pld-linux.org/
[packages/phpBB.git] / phpBB.spec
1 Summary:        A feature-rich PHP discussion board
2 Summary(pl):    Forum dyskusyjne o du¿ych mo¿liwo¶ciach
3 Name:           phpBB
4 Version:        2.0.4
5 Release:        1.1
6 License:        GPL v2
7 Group:          Applications/WWW
8 Source0:        http://dl.sourceforge.net/phpbb/%{name}-%{version}.tar.gz
9 Source1:        http://dl.sourceforge.net/phpbb/lang_polish.tar.gz
10 Source2:        http://dl.sourceforge.net/phpbb/subSilver_polish.tar.gz
11 Source3:        http://dl.sourceforge.net/phpbb/lang_german.tar.gz
12 Source4:        http://dl.sourceforge.net/phpbb/subSilver_german.tar.gz
13 Source5:        http://dl.sourceforge.net/phpbb/lang_french.tar.gz
14 Source6:        http://dl.sourceforge.net/phpbb/subSilver_french.tar.gz
15 URL:            http://www.phpbb.com/
16 Requires:       php-pcre
17 Requires:       webserver
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _phpdir         /home/services/httpd/html/phpBB
22
23 %description
24 phpBB is a UBB-style dissussion board written in PHP backended by a
25 MySQL database. It includes features such as posting/replying/editing
26 messages, private messages, private forums, user and anonymous
27 posting, robust theming, user ranking by posts or by special, admin
28 definable, ranks, and much more.
29
30 %description -l pl
31 phpBB jest forum dyskusyjnym w stylu UBB napisanym w PHP z u¿yciem
32 bazy danych MySQL. Ma mo¿liwo¶ci takie jak: wysy³anie, odpisywanie,
33 edycja wiadomo¶ci, prywatne wiadomo¶ci, prywatne fora, wysy³anie jako
34 u¿ytkownik i anonimowe, bogaty wybór motywów, ranking u¿ytkowników
35 wed³ug ich wiadomo¶ci lub specjalne, definiowane przez administratora,
36 rankingi i wiele innych.
37
38 %package install
39 Summary:        A feature-rich PHP discussion board - installer
40 Summary(pl):    Forum dyskusyjne o du¿ych mo¿liwo¶ciach - instalator
41 Group:          Applications/Databases/Interfaces
42 Requires:       phpBB
43
44 %description install
45 Package needed for %{name} forum instalation.
46
47 %description install -l pl
48 Pakiet potrzebny do instalacji forum %{name}.
49
50 %prep
51 %setup -q -n %{name}2
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{_phpdir}/{admin,db,images,includes,install/schemas,language,templates}
56
57 install *.{php,inc}     $RPM_BUILD_ROOT%{_phpdir}
58 install admin/*.php     $RPM_BUILD_ROOT%{_phpdir}/admin
59 install db/*.php        $RPM_BUILD_ROOT%{_phpdir}/db
60 install includes/*.php  $RPM_BUILD_ROOT%{_phpdir}/includes
61 install install/*.{htm,php} $RPM_BUILD_ROOT%{_phpdir}/install
62 install install/schemas/*.sql $RPM_BUILD_ROOT%{_phpdir}/install/schemas
63
64 cp -R images/*          $RPM_BUILD_ROOT%{_phpdir}/images
65 cp -R language/*        $RPM_BUILD_ROOT%{_phpdir}/language
66 cp -R templates/*       $RPM_BUILD_ROOT%{_phpdir}/templates
67
68 tar zxfv %{SOURCE1} -C $RPM_BUILD_ROOT%{_phpdir}/language/
69 tar zxfv %{SOURCE2} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
70
71 tar zxfv %{SOURCE3} -C $RPM_BUILD_ROOT%{_phpdir}/language/
72 tar zxfv %{SOURCE4} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
73
74 tar zxfv %{SOURCE5} -C $RPM_BUILD_ROOT%{_phpdir}/language/
75 tar zxfv %{SOURCE6} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post install
81 echo "Remember to uninstall %{name}-install after initiation of %{name}!!"
82
83 %files
84 %defattr(644,root,root,755)
85 %doc docs/*
86 %attr(755,root,http) %dir %{_phpdir}
87 %attr(640,root,http) %config(noreplace) %{_phpdir}/config.php
88 %attr(640,root,http) %{_phpdir}/[^c]*.php
89 %attr(640,root,http) %{_phpdir}/common.php
90 %attr(640,root,http) %{_phpdir}/*.inc
91 %attr(750,root,http) %dir %{_phpdir}/admin
92 %attr(750,root,http) %dir %{_phpdir}/db
93 %attr(750,root,http) %dir %{_phpdir}/images
94 %attr(750,root,http) %dir %{_phpdir}/includes
95 %{_phpdir}/admin/*
96 %{_phpdir}/db/*
97 %{_phpdir}/images/*
98 %{_phpdir}/includes/*
99 %attr(750,root,http) %dir %{_phpdir}/templates
100 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver
101 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver/admin
102 %attr(640,root,http) %{_phpdir}/templates/subSilver/admin/*
103 %attr(640,root,http) %{_phpdir}/templates/subSilver/*.*
104 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver/images
105 %attr(640,root,http) %{_phpdir}/templates/subSilver/images/*.*
106 %attr(640,root,http) %{_phpdir}/language/*.htm
107
108 %lang(en) %{_phpdir}/language/lang_english
109 %lang(en) %{_phpdir}/templates/subSilver/images/lang_english
110
111 %lang(pl) %{_phpdir}/language/lang_polish
112 %lang(pl) %{_phpdir}/templates/subSilver/images/lang_polish
113
114 %lang(de) %{_phpdir}/language/lang_german
115 %lang(de) %{_phpdir}/templates/subSilver/images/lang_german
116
117 %lang(fr) %{_phpdir}/language/lang_french
118 %lang(fr) %{_phpdir}/templates/subSilver/images/lang_french
119
120 %files install
121 %defattr(644,root,root,755)
122 %doc install/schemas/*.zip
123 %attr(750,root,http) %dir %{_phpdir}/install
124 %attr(640,root,http) %{_phpdir}/install/*.php
125 %attr(640,root,http) %{_phpdir}/install/*.htm
126 %attr(750,root,http) %dir %{_phpdir}/install/schemas
127 %attr(640,root,http) %{_phpdir}/install/schemas/*.sql
This page took 0.155297 seconds and 3 git commands to generate.