]> git.pld-linux.org Git - packages/phpBB.git/blob - phpBB.spec
005c8cd68e36396541d627fa569c538879d2ae2b
[packages/phpBB.git] / phpBB.spec
1 Summary:        A feature-rich PHP discussion board
2 Summary(pl):    Forum dyskusyjne o du¿ych mo¿liwo¶ciach
3 Name:           phpBB
4 Version:        2.0.10
5 Release:        2.1
6 License:        GPL v2
7 Group:          Applications/WWW
8 #Source0:       http://dl.sourceforge.net/phpbb/%{name}-%{version}.tar.bz2
9 Source0:        http://dl.sourceforge.net/phpbb-php5mod/phpbb-php5-%{version}.tar.gz
10 # Source0-md5:  af1c2aaf49453223b5e6b59ddae61091
11 Source1:        http://dl.sourceforge.net/phpbb/lang_polish.tar.gz
12 # Source1-md5:  db020ef788d4bd50ce04014964e3e043
13 Source2:        http://dl.sourceforge.net/phpbb/subSilver_polish.tar.gz
14 # Source2-md5:  9367f7a761aef3795ffa296b413136b4
15 Source3:        http://dl.sourceforge.net/phpbb/lang_german.tar.gz
16 # Source3-md5:  afc686072978b896e18fa211210c3b13
17 Source4:        http://dl.sourceforge.net/phpbb/subSilver_german.tar.gz
18 # Source4-md5:  8340f310ee4892f3e19da3e000fdb708
19 Source5:        http://dl.sourceforge.net/phpbb/lang_french.tar.gz
20 # Source5-md5:  c81f843d4adf0a086efef590074478e6
21 Source6:        http://dl.sourceforge.net/phpbb/subSilver_french.tar.gz
22 # Source6-md5:  419157eb144fa81b7464a5f2edeea434
23 Source7:        %{name}.conf
24 URL:            http://www.phpbb.com/
25 Requires:       php-pcre
26 Requires:       webserver
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _phpdir         %{_datadir}/%{name}
31 %define         _sysconfdir     /etc/%{name}
32
33 %description
34 phpBB is a UBB-style dissussion board written in PHP backended by a
35 MySQL database. It includes features such as posting/replying/editing
36 messages, private messages, private forums, user and anonymous
37 posting, robust theming, user ranking by posts or by special, admin
38 definable, ranks, and much more.
39
40 %description -l pl
41 phpBB jest forum dyskusyjnym w stylu UBB napisanym w PHP z u¿yciem
42 bazy danych MySQL. Ma mo¿liwo¶ci takie jak: wysy³anie, odpisywanie,
43 edycja wiadomo¶ci, prywatne wiadomo¶ci, prywatne fora, wysy³anie jako
44 u¿ytkownik i anonimowe, bogaty wybór motywów, ranking u¿ytkowników
45 wed³ug ich wiadomo¶ci lub specjalne, definiowane przez administratora,
46 rankingi i wiele innych.
47
48 %package install
49 Summary:        A feature-rich PHP discussion board - installer
50 Summary(pl):    Forum dyskusyjne o du¿ych mo¿liwo¶ciach - instalator
51 Group:          Applications/Databases/Interfaces
52 Requires:       phpBB
53
54 %description install
55 Package needed for %{name} forum instalation.
56
57 %description install -l pl
58 Pakiet potrzebny do instalacji forum %{name}.
59
60 %prep
61 #%setup -q -n %{name}2
62 %setup -q -n phpbb-php5-%{version}.1
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT%{_phpdir}/{admin,db,images,includes,install/schemas,language,templates} \
67         $RPM_BUILD_ROOT{%{_sysconfdir},/etc/httpd}
68
69 install *.{php,inc}     $RPM_BUILD_ROOT%{_phpdir}
70 install admin/*.php     $RPM_BUILD_ROOT%{_phpdir}/admin
71 install db/*.php        $RPM_BUILD_ROOT%{_phpdir}/db
72 install includes/*.php  $RPM_BUILD_ROOT%{_phpdir}/includes
73 install install/*.php   $RPM_BUILD_ROOT%{_phpdir}/install
74 install install/schemas/*.sql $RPM_BUILD_ROOT%{_phpdir}/install/schemas
75
76 cp -R images/*          $RPM_BUILD_ROOT%{_phpdir}/images
77 cp -R language/*        $RPM_BUILD_ROOT%{_phpdir}/language
78 cp -R templates/*       $RPM_BUILD_ROOT%{_phpdir}/templates
79
80 cp config.php $RPM_BUILD_ROOT%{_sysconfdir}
81 ln -sf %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_phpdir}/config.php
82
83 tar zxfv %{SOURCE1} -C $RPM_BUILD_ROOT%{_phpdir}/language/
84 tar zxfv %{SOURCE2} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
85
86 tar zxfv %{SOURCE3} -C $RPM_BUILD_ROOT%{_phpdir}/language/
87 tar zxfv %{SOURCE4} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
88
89 tar zxfv %{SOURCE5} -C $RPM_BUILD_ROOT%{_phpdir}/language/
90 tar zxfv %{SOURCE6} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
91
92 install %{SOURCE7} $RPM_BUILD_ROOT/etc/httpd/%{name}.conf
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post install
98 echo "For instalation: http://<your.site.address>/<path>/install/install.php"
99 echo "For upgrade: http://<your.site.address>/<path>/install/upgrade.php"
100 echo
101 echo "Remember to uninstall %{name}-install after initiation/upgrade of %{name}!!"
102
103 if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*%{name}.conf" /etc/httpd/httpd.conf; then
104         echo "Include /etc/httpd/%{name}.conf" >> /etc/httpd/httpd.conf
105 elif [ -d /etc/httpd/httpd.conf ]; then
106         ln -sf /etc/httpd/%{name}.conf /etc/httpd/httpd.conf/99_%{name}.conf
107 fi
108 if [ -f /var/lock/subsys/httpd ]; then
109         /usr/sbin/apachectl restart 1>&2
110 fi
111
112 %preun
113 if [ "$1" = "0" ]; then
114         umask 027
115         if [ -d /etc/httpd/httpd.conf ]; then
116                 rm -f /etc/httpd/httpd.conf/99_%{name}.conf
117         else
118                 grep -v "^Include.*%{name}.conf" /etc/httpd/httpd.conf > \
119                         /etc/httpd/httpd.conf.tmp
120                 mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
121                 if [ -f /var/lock/subsys/httpd ]; then
122                         /usr/sbin/apachectl restart 1>&2
123                 fi
124         fi
125 fi
126
127 %triggerpostun -- %{name} < %{version}
128 echo "You have to install %{name}-install package to prepare upgrade!!!"
129 echo "For upgrade: http://<your.site.address>/<path>/install/upgrade.php"
130
131 %triggerpostun -- %{name} <= 2.0.10-1
132 if [ -f /home/services/httpd/html/phpBB/config.php.rpmsave ]; then
133         mv -f /home/services/httpd/html/phpBB/config.php.rpmsave /etc/phpBB/config.php
134 else
135         if [ -f /home/httpd/html/phpBB/config.php.rpmsave ]; then
136                 mv -f /home/httpd/html/phpBB/config.php.rpmsave /etc/phpBB/config.php
137         fi
138 fi
139 for i in `grep -lr "/home/\(services/\)*httpd/html/phpBB" /etc/httpd/*`; do
140         cp $i $i.backup
141         %{__perl} -pi -e "s#/home/httpd/html/phpBB#%{_phpdir}#g" $i
142         %{__perl} -pi -e "s#/home/services/httpd/html/phpBB#%{_phpdir}#g" $i
143         echo "File changed by trigger: $i (backup: $i.backup)"
144 done
145 if [ -f /var/lock/subsys/httpd ]; then
146         /usr/sbin/apachectl restart 1>&2
147 fi
148
149
150
151 %files
152 %defattr(644,root,root,755)
153 %doc docs/*
154 %attr(755,root,http) %dir %{_phpdir}
155 %attr(640,root,http) %{_phpdir}/[!c]*.php
156 %attr(640,root,http) %{_phpdir}/common.php
157 %attr(640,root,http) %{_phpdir}/*.inc
158 %attr(750,root,http) %dir %{_phpdir}/admin
159 %attr(750,root,http) %dir %{_phpdir}/db
160 %attr(750,root,http) %dir %{_phpdir}/images
161 %attr(640,root,http) %{_phpdir}/images/*.gif
162 %attr(640,root,http) %{_phpdir}/images/index.htm
163 %attr(750,root,http) %dir %{_phpdir}/images/smiles
164 %attr(1770,root,http) %dir %{_phpdir}/images/avatars
165 %attr(750,root,http) %dir %{_phpdir}/includes
166 %{_phpdir}/admin/*
167 %{_phpdir}/db/*
168 %{_phpdir}/images/smiles/*
169 %{_phpdir}/images/avatars/*
170 %{_phpdir}/includes/*
171 %{_phpdir}/templates/index.htm
172 %attr(750,root,http) %dir %{_phpdir}/templates
173 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver
174 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver/admin
175 %attr(640,root,http) %{_phpdir}/templates/subSilver/admin/*
176 %attr(640,root,http) %{_phpdir}/templates/subSilver/*.*
177 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver/images
178 %attr(640,root,http) %{_phpdir}/templates/subSilver/images/*.*
179 %attr(750,root,http) %dir %{_phpdir}/language
180 %attr(640,root,http) %{_phpdir}/language/*.htm
181
182 %lang(en) %{_phpdir}/language/lang_english
183 %lang(en) %{_phpdir}/templates/subSilver/images/lang_english
184
185 %lang(pl) %{_phpdir}/language/lang_polish
186 %lang(pl) %{_phpdir}/templates/subSilver/images/lang_polish
187
188 %lang(de) %{_phpdir}/language/lang_german
189 %lang(de) %{_phpdir}/templates/subSilver/images/lang_german
190
191 %lang(fr) %{_phpdir}/language/lang_french
192 %lang(fr) %{_phpdir}/templates/subSilver/images/lang_french
193
194 %files install
195 %defattr(644,root,root,755)
196 %dir %{_sysconfdir}
197 %attr(640,root,http) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*
198 %config(noreplace) %verify(not size mtime md5) /etc/httpd/%{name}.conf
199 %doc install/schemas/*.zip
200 %attr(750,root,http) %dir %{_phpdir}/install
201 %attr(640,root,http) %{_phpdir}/install/*.php
202 %attr(750,root,http) %dir %{_phpdir}/install/schemas
203 %attr(640,root,http) %{_phpdir}/install/schemas/*.sql
This page took 0.188616 seconds and 2 git commands to generate.