]> git.pld-linux.org Git - packages/php4.git/commitdiff
- updated auto/th/php-5_2_7-1 auto/ti/php-5_2_7-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 5 Dec 2008 23:09:23 +0000 (23:09 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-no_pear_install.patch -> 1.7
    php-sapi-ini-file.patch -> 1.8

php-no_pear_install.patch
php-sapi-ini-file.patch

index e233a82d7f1796a23a540be2a71311868296b363..158ff68193a9ad3c4a17b726c8630bf97671af5d 100644 (file)
@@ -1,11 +1,11 @@
 --- php-5.0.0b3.orig/configure.in      2003-12-24 17:30:44.000000000 +0100
 +++ php-5.0.0b3/configure.in   2003-12-24 17:31:45.000000000 +0100
-@@ -1149,7 +1149,7 @@
+@@ -1343,7 +1343,7 @@
  CXXFLAGS="$CXXFLAGS $standard_libtool_flag"
  
- all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_CLI_TARGET)"
+ all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_CLI_TARGET)"
 -install_targets="$install_modules install-build install-headers install-programs $install_pear"
 +install_targets="$install_modules install-build install-headers install-programs"
  
  case $PHP_SAPI in
-   cgi)
+   cli)
index 5f38403dd513f84964f82ace6d5127b77d20bbdd..b078e3ffa41cc8a04616d247b08f34420b361637 100644 (file)
@@ -1,14 +1,20 @@
---- php5.2-200710301730/main/php_ini.c 2007-08-31 11:31:28.000000000 +0300
-+++ php5.2-200710301730-sapi-ini-file/main/php_ini.c   2007-10-30 21:28:48.493329368 +0200
-@@ -463,6 +463,24 @@
-                               }
+--- php-5.2.7/main/php_ini.c.org       2008-12-05 23:30:07.843241117 +0100
++++ php-5.2.7/main/php_ini.c   2008-12-05 23:36:18.096968965 +0100
+@@ -475,21 +475,32 @@
                        }
                }
+-              /* Otherwise search for php-%sapi-module-name%.ini file in search path */
 +              /* Search (global) php.ini file in search path */
-+              if (!fh.handle.fp) {
+               if (!fh.handle.fp) {
+-                      const char *fmt = "php-%s.ini";
+-                      char *ini_fname;
+-                      spprintf(&ini_fname, 0, fmt, sapi_module.name);
+-                      fh.handle.fp = php_fopen_with_path(ini_fname, "r", php_ini_search_path, &php_ini_opened_path TSRMLS_CC);
+-                      efree(ini_fname);
 +                      fh.handle.fp = php_fopen_with_path("php.ini", "r", php_ini_search_path, &php_ini_opened_path TSRMLS_CC);
-+                      if (fh.handle.fp) {
-+                              fh.filename = php_ini_opened_path;
+                       if (fh.handle.fp) {
+                               fh.filename = php_ini_opened_path;
 +                              PG(safe_mode) = safe_mode_state;
 +                              PG(open_basedir) = open_basedir;
 +                              fh.type = ZEND_HANDLE_FP;
 +                              fh.handle.fp = NULL;
 +                              efree(php_ini_opened_path);
 +                              fh.filename = php_ini_opened_path = NULL;
-+                      }
-+              }
-               /* Search php-%sapi-module-name%.ini file in search path */
-               if (!fh.handle.fp) {
-                       const char *fmt = "php-%s.ini";
-@@ -474,13 +492,6 @@
-                               fh.filename = php_ini_opened_path;
                        }
                }
--              /* Search php.ini file in search path */
--              if (!fh.handle.fp) {
--                      fh.handle.fp = php_fopen_with_path("php.ini", "r", php_ini_search_path, &php_ini_opened_path TSRMLS_CC);
--                      if (fh.handle.fp) {
--                              fh.filename = php_ini_opened_path;
--                      }
--              }
-       }
  
-       if (free_ini_search_path) {
-@@ -513,9 +524,13 @@
-        * parse any .ini files found in this directory. */
-       if (!sapi_module.php_ini_ignore && strlen(PHP_CONFIG_FILE_SCAN_DIR)) {
+-              /* If still no ini file found, search for php.ini file in search path */
++              /* Otherwise search for php-%sapi-module-name%.ini file in search path */
+               if (!fh.handle.fp) {
+-                      fh.handle.fp = php_fopen_with_path("php.ini", "r", php_ini_search_path, &php_ini_opened_path TSRMLS_CC);
++                      const char *fmt = "php-%s.ini";
++                      char *ini_fname;
++                      spprintf(&ini_fname, 0, fmt, sapi_module.name);
++                      fh.handle.fp = php_fopen_with_path(ini_fname, "r", php_ini_search_path, &php_ini_opened_path TSRMLS_CC);
++                      efree(ini_fname);
+                       if (fh.handle.fp) {
+                               fh.filename = php_ini_opened_path;
+                       }
+@@ -533,9 +544,13 @@
+       /* Scan and parse any .ini files found in scan path if path not empty. */
+       if (!sapi_module.php_ini_ignore && php_ini_scanned_path_len) {
                struct dirent **namelist;
 -              int ndir, i;
 +              int ndir, i, found = 0;
 +              char *sapi_scan_dir = emalloc(strlen(fmt) + strlen(sapi_module.name));
 +              sprintf(sapi_scan_dir, fmt, sapi_module.name);
  
-               if ((ndir = php_scandir(PHP_CONFIG_FILE_SCAN_DIR, &namelist, 0, php_alphasort)) > 0) {
+               if ((ndir = php_scandir(php_ini_scanned_path, &namelist, 0, php_alphasort)) > 0) {
 +                      found += ndir;
                        for (i = 0; i < ndir; i++) {
                                /* check for a .ini extension */
                                if (!(p = strrchr(namelist[i]->d_name, '.')) || (p && strcmp(p, ".ini"))) {
-@@ -532,6 +547,35 @@
-                                                       /* Here, add it to the list of ini files read */
-                                                       l = strlen(ini_file);
-                                                       total_l += l + 2;
-+                                                      p = estrndup(ini_file, l); 
-+                                                      zend_llist_add_element(&scanned_ini_list, &p);
-+                                              }
-+                                      }
-+                              }
-+                              free(namelist[i]);
-+                      }
-+                      free(namelist);
+@@ -564,6 +579,38 @@
+                               free(namelist[i]);
+                       }
+                       free(namelist);
 +              }
-+
++              
 +              if ((ndir = php_scandir(sapi_scan_dir, &namelist, 0, php_alphasort)) > 0) {
 +                      found += ndir;
-+
 +                      for (i = 0; i < ndir; i++) {
 +                              /* check for a .ini extension */
 +                              if (!(p = strrchr(namelist[i]->d_name, '.')) || (p && strcmp(p, ".ini"))) {
 +                                                      /* Here, add it to the list of ini files read */
 +                                                      l = strlen(ini_file);
 +                                                      total_l += l + 2;
-                                                       p = estrndup(ini_file, l);
-                                                       zend_llist_add_element(&scanned_ini_list, &p);
-                                               }
-@@ -540,8 +584,11 @@
-                               free(namelist[i]);
-                       }
-                       free(namelist);
++                                                      p = estrndup(ini_file, l);
++                                                      zend_llist_add_element(&scanned_ini_list, &p);
++                                              }
++                                      }
++                              }
++                              free(namelist[i]);
++                      }
++                      free(namelist);
 +              }
 +              efree(sapi_scan_dir);
--                      /*
++
 +              if (found) {
-+                      /* 
+                       /*
                         * Don't need an extra byte for the \0 in this malloc as the last
-                        * element will not get a trailing , which gives us the byte for the \0
-                        */
This page took 0.074665 seconds and 4 git commands to generate.