]> git.pld-linux.org Git - packages/php4-pecl-runkit.git/blob - php4-pecl-runkit.spec
d0d2333e7388417152b99d81c28c7c69f18a3463
[packages/php4-pecl-runkit.git] / php4-pecl-runkit.spec
1 %define         _modname        runkit
2 %define         _status         beta
3 %define         _sysconfdir     /etc/php4
4 %define         extensionsdir   %{_libdir}/php4
5
6 Summary:        %{_modname} - mangle with user defined functions and classes
7 Summary(pl):    %{_modname} - obróbka zdefiniowanych przez u¿ytkownika funkcji i klas
8 Name:           php4-pecl-%{_modname}
9 Version:        0.4
10 Release:        2
11 License:        PHP
12 Group:          Development/Languages/PHP
13 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
14 # Source0-md5:  05a690f04b7d2c42193f3e0c1bb99a19
15 URL:            http://pecl.php.net/package/runkit/
16 BuildRequires:  php4-devel >= 3:4.3.0
17 BuildRequires:  rpmbuild(macros) >= 1.238
18 %{?requires_php_extension}
19 Requires:       %{_sysconfdir}/conf.d
20 Obsoletes:      php-pear-%{_modname}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Replace, rename, and remove user defined functions and classes. Define
25 customized superglobal variables for general purpose use. Execute code
26 in restricted environment (sandboxing).
27
28 In PECL status of this extension is: %{_status}.
29
30 %description -l pl
31 Zastêpowanie, zmiana nazwy lub usuwanie zdefiniowanych przez
32 u¿ytkownika funkcji i klas. Definiowanie zmiennych superglobalnych do
33 ogólnego u¿ytku. Wykonywanie danego kodu w ograniczonym ¶rodowisku
34 (sandbox).
35
36 To rozszerzenie ma w PECL status: %{_status}.
37
38 %prep
39 %setup -q -c
40
41 %build
42 cd %{_modname}-%{version}
43 phpize
44 %configure
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
50
51 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
52 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
53 ; Enable %{_modname} extension module
54 extension=%{_modname}.so
55 EOF
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
62 [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
63
64 %postun
65 if [ "$1" = 0 ]; then
66         [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
67         [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
68 fi
69
70 %files
71 %defattr(644,root,root,755)
72 %doc %{_modname}-%{version}/README
73 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
74 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.099132 seconds and 2 git commands to generate.