]> git.pld-linux.org Git - packages/php4-pecl-intercept.git/blob - php4-pecl-intercept.spec
ceb228033a496104571bca63eb9a3f5e67db9be9
[packages/php4-pecl-intercept.git] / php4-pecl-intercept.spec
1 %define         _modname        intercept
2 %define         _status         alpha
3 %define         _sysconfdir     /etc/php4
4 %define         extensionsdir   %{_libdir}/php4
5
6 Summary:        %{_modname} - intercept function/method calls
7 Summary(pl.UTF-8):      %{_modname} - przechwytywanie wywołań funkcji/metod
8 Name:           php4-pecl-%{_modname}
9 Version:        0.3.0
10 Release:        0.1
11 License:        PHP
12 Group:          Development/Languages/PHP
13 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
14 # Source0-md5:  442121f4043984cdde213918266a925c
15 URL:            http://pecl.php.net/package/intercept/
16 BuildRequires:  php4-devel >= 4.0.0
17 BuildRequires:  rpmbuild(macros) >= 1.322
18 %{?requires_php_extension}
19 Requires:       %{_sysconfdir}/conf.d
20 Obsoletes:      php-pear-%{_modname}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Allows the user to have a user-space function called when the
25 specified function is called. Support for class/object methods will be
26 added later.
27
28 In PECL status of this extension is: %{_status}.
29
30 %description -l pl.UTF-8
31 Pozwala użytkownikowi na określenie funkcji w przestrzeni użytkownika
32 wywoływanej, gdy określona funkcja jest wywołana. Wsparcie dla metod
33 klas/obiektów zostanie dodane w późniejszych wersjach.
34
35 To rozszerzenie ma w PECL status: %{_status}.
36
37 %prep
38 %setup -q -c
39
40 %build
41 cd %{_modname}-%{version}
42 phpize
43 %configure
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
49
50 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
51 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
52 ; Enable %{_modname} extension module
53 extension=%{_modname}.so
54 EOF
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
61 [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
62
63 %postun
64 if [ "$1" = 0 ]; then
65         [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
66         [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
72 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
73 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.098345 seconds and 2 git commands to generate.