]> git.pld-linux.org Git - packages/php.git/commitdiff
- fix building with mysql 5.7 (ER macro uses unexported array) auto/th/php54-5.4.45-19
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 20 Mar 2018 20:21:08 +0000 (21:21 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 20 Mar 2018 20:21:08 +0000 (21:21 +0100)
- rel 19

mysqli-err.patch [new file with mode: 0644]
php.spec

diff --git a/mysqli-err.patch b/mysqli-err.patch
new file mode 100644 (file)
index 0000000..99e5eac
--- /dev/null
@@ -0,0 +1,29 @@
+--- php-5.4.45/ext/mysqli/mysqli.c.orig        2018-03-20 20:56:38.000000000 +0100
++++ php-5.4.45/ext/mysqli/mysqli.c     2018-03-20 21:15:42.030265770 +0100
+@@ -1376,7 +1376,7 @@
+       }
+       if (!(mysql = (MY_MYSQL *)userdata)) {
+-              LOCAL_INFILE_ERROR_MSG(data->error_msg, ER(CR_UNKNOWN_ERROR));
++              LOCAL_INFILE_ERROR_MSG(data->error_msg, "Unknown MySQL error");
+               return 1;
+       }
+@@ -1423,7 +1423,7 @@
+               int count = (int)php_stream_read(mysql->li_stream, buf, buf_len);
+               if (count < 0) {
+-                      LOCAL_INFILE_ERROR_MSG(data->error_msg, ER(2));
++                      LOCAL_INFILE_ERROR_MSG(data->error_msg, "Can't connect to local MySQL server");
+               }
+               return count;
+@@ -1499,7 +1499,7 @@
+               strlcpy(error_msg, data->error_msg, error_msg_len);
+               return 2000;
+       }
+-      strlcpy(error_msg, ER(CR_OUT_OF_MEMORY), error_msg_len);
++      strlcpy(error_msg, "MySQL client ran out of memory", error_msg_len);
+       return CR_OUT_OF_MEMORY;
+ }
+ /* }}} */
index f79c8a01514166cb66021c1416927a383922b6ba..cf5fff1f63b7c20dd7d8906a868f4706f0f0755e 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -138,7 +138,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     18
+%define                rel     19
 %define                orgname php
 %define                ver_suffix 54
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -232,6 +232,7 @@ Patch67:    mysql-lib-ver-mismatch.patch
 Patch68:       x32.patch
 Patch70:       libvpx2.patch
 Patch71:       zend_operators_from_5.5.patch
+Patch72:       mysqli-err.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -1974,6 +1975,7 @@ cp -p php.ini-production php.ini
 # asm part of zend_operators.h of php-5.5
 %patch71 -p1
 %endif
+%patch72 -p1
 
 %{__sed} -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
 
This page took 0.06269 seconds and 4 git commands to generate.