]> git.pld-linux.org Git - packages/php.git/commitdiff
- removed obsolete no_php_pcre_in_SAPI_c patch and gmp change from link-libs p.
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 7 Sep 2002 19:57:30 +0000 (19:57 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fixed mcal patch
- added xmlrpc-fix patch (argh, they always must break something!)
- prepared for building with java in /usr/lib/java
- allow building with pcntl module (CGI-only; bcond - doesn't work correctly)
- more bconds (from Przemek Piotrowski)
- build cpdf and sybase_ct (using freetds) extensions by default
- seems work, but better /test first...

Changed files:
    php-link-libs.patch -> 1.7
    php-mcal-shared-lib.patch -> 1.4
    php-xmlrpc-fix.patch -> 1.1
    php.spec -> 1.205

php-link-libs.patch
php-mcal-shared-lib.patch
php-xmlrpc-fix.patch [new file with mode: 0644]
php.spec

index 785e01cba2988aee5736836287972f7f89653194..0d0c762529dc9b48322a8f3b664364341d25c594 100644 (file)
@@ -1,10 +1,3 @@
---- ./ext/gmp/config.m4.org    Mon Jun 24 09:55:32 2002
-+++ ./ext/gmp/config.m4        Sat Sep  7 11:02:51 2002
-@@ -23,3 +23,4 @@
-   PHP_SUBST(GMP_SHARED_LIBADD)
-   PHP_ADD_LIBRARY_WITH_PATH(gmp, $GMP_DIR/lib, GMP_SHARED_LIBADD)
- fi
-+PHP_SUBST(GMP_SHARED_LIBADD)
 --- ./ext/xslt/config.m4.org   Thu May  2 12:24:03 2002
 +++ ./ext/xslt/config.m4       Sat Sep  7 11:03:45 2002
 @@ -81,7 +81,7 @@
index c32cc8ab0ec9689d77dcbb504677c6a6a3b88253..a39ae73a7cae2001bbb65c0096ba94285283d104 100644 (file)
@@ -9,20 +9,14 @@
        MCAL_LIBRARY=$i
      fi
    done
-@@ -37,13 +37,14 @@
+@@ -37,8 +37,8 @@
      AC_MSG_ERROR(Unable to locate your libmcal header files - icalroutines.h should be in the directory you specify or in the include/ subdirectory below it - default search location is $MCAL_DEFAULT_SEARCH)
    fi
  
 -  if test ! -f "$MCAL_LIBRARY/libmcal.a"; then
 -    AC_MSG_ERROR(Unable to locate your libmcal library files - libmcal.a should be in the directory you specify or in the lib/ subdirectory below it - default search location is $MCAL_DEFAULT_SEARCH)
-+  if test ! -f "$MCAL_LIBRARY"; then
++  if test ! -f "$MCAL_LIBRARY/libmcal.a" -a ! -f "$MCAL_LIBRARY/libmcal.so"; then
 +    AC_MSG_ERROR(Unable to locate your libmcal library files - libmcal.* should be in the directory you specify or in the lib/ subdirectory below it - default search location is $MCAL_DEFAULT_SEARCH)
    fi
  
    PHP_ADD_INCLUDE($MCAL_INCLUDE)
-   PHP_ADD_LIBPATH($MCAL_LIBRARY,MCAL_SHARED_LIBADD)
-   PHP_ADD_LIBRARY_DEFER(mcal,[],MCAL_SHARED_LIBADD)
-+  PHP_ADD_LIBRARY_WITH_PATH(mcal, $MCAL_LIBRARY, MCAL_SHARED_LIBADD)
-   PHP_SUBST(MCAL_SHARED_LIBADD)
-   AC_DEFINE(HAVE_MCAL,1,[ ])
-   PHP_EXTENSION(mcal,$ext_shared)
diff --git a/php-xmlrpc-fix.patch b/php-xmlrpc-fix.patch
new file mode 100644 (file)
index 0000000..e3f85bf
--- /dev/null
@@ -0,0 +1,21 @@
+--- php-4.2.3/ext/xmlrpc/config.m4.orig        Sat Sep  7 20:49:15 2002
++++ php-4.2.3/ext/xmlrpc/config.m4     Sat Sep  7 21:05:25 2002
+@@ -29,6 +29,7 @@
+   for i in /usr /usr/local $PHP_EXPAT_DIR $XMLRPC_DIR; do
+     if test -f $i/lib/libexpat.a -o -f $i/lib/libexpat.$SHLIB_SUFFIX_NAME; then
+       AC_DEFINE(HAVE_LIBEXPAT2,1,[ ])
++      ext_shared=$xmlrpc_ext_shared
+       PHP_ADD_LIBRARY_WITH_PATH(expat, $i/lib, XMLRPC_SHARED_LIBADD)
+       PHP_ADD_INCLUDE($i/include)
+       testval=yes
+@@ -87,8 +87,9 @@
+     AC_MSG_ERROR(Please reinstall the XMLRPC-EPI distribution)
+   fi
++  ext_shared=$xmlrpc_ext_shared
+   PHP_ADD_INCLUDE($XMLRPC_DIR)
+-  PHP_ADD_LIBRARY_WITH_PATH(xmlrpc, $XMLRPC_DIR/lib, XMLRPC_SHARED_LIBADD)
++  PHP_ADD_LIBRARY_WITH_PATH(xmlrpc, $PHP_XMLRPC/lib, XMLRPC_SHARED_LIBADD)
+   
+ fi
index 216d29321eb18687f4d4d4c42f8bb6006b4eff81..90ca3a0eeb6b6cb3800b8d2c081c10d2a9c92eec 100644 (file)
--- a/php.spec
+++ b/php.spec
 %endif
 
 # Conditional build:
-# _with_cpdf           - with cpdf extension module
-# _with_interbase      - with InterBase extension module
-# _with_java           - with Java extension module
-# _with_oci8           - with Oracle oci8 extension module
-# _with_oracle         - with oracle extension module
-# _with_sybase_ct      - with Sybase-CT extension module
+# _with_interbase      - with InterBase extension module       (BR: proprietary libs)
+# _with_java           - with Java extension module            (BR: jdk)
+# _with_oci8           - with Oracle oci8 extension module     (BR: proprietary libs)
+# _with_oracle         - with oracle extension module          (BR: proprietary libs)
+# _with_pcntl          - with pcntl extension module           (problems: SEGV on exit)
+# _without_cpdf                - without cpdf extension module
 # _without_domxslt     - without DOM XSLT/EXSLT support in DOM XML extension module
+# _without_gif         - build GD extension module with gd library without GIF support
 # _without_imap                - without IMAP extension module
 # _without_ldap                - without LDAP extension module
 # _without_mm          - without mm support for session storage
 # _without_msession    - without msession extension module
 # _without_odbc                - without ODBC extension module
 # _without_openssl     - without OpenSSL support and OpenSSL extension module
+# _without_pcre                - without PCRE extension module
 # _without_pdf         - without PDF extension module
 # _without_snmp                - without SNMP extension module
 # _without_recode      - without recode extension module
+# _without_sybase_ct   - without Sybase-CT extension module
 # _without_wddx                - without WDDX extension module
+# _without_xml         - without XML extension module
+# _without_xmlrpc      - without XML-RPC extension module
 # _without_xslt                - without XSLT extension module
 Summary:       The PHP HTML-embedded scripting language for use with Apache
 Summary(fr):   Le langage de script embarque-HTML PHP pour Apache
@@ -41,7 +46,7 @@ Summary(ru):  PHP 
 Summary(uk):   PHP ÷ÅÒÓ¦§ 4 -- ÍÏ×Á ÐÒÅÐÒÏÃÅÓÕ×ÁÎÎÑ HTML-ÆÁÊ̦×, ×ÉËÏÎÕ×ÁÎÁ ÎÁ ÓÅÒ×ÅÒ¦
 Name:          php
 Version:       4.2.3
-Release:       0.1
+Release:       1
 Epoch:         3
 Group:         Libraries
 License:       PHP
@@ -59,7 +64,7 @@ Patch2:               %{name}-mysql-socket.patch
 Patch3:                %{name}-mail.patch
 Patch4:                %{name}-link-libs.patch
 Patch5:                %{name}-fastcgi.patch
-Patch6:                %{name}-no_php_pcre_in_SAPI_c.patch
+#Patch6:               %{name}-no_php_pcre_in_SAPI_c.patch
 Patch7:                %{name}-libpq_fs_h_path.patch
 Patch8:                %{name}-wddx-fix.patch
 Patch9:                %{name}-cpdf-fix.patch
@@ -76,11 +81,11 @@ Patch19:    %{name}-pear-cosmetic.patch
 Patch20:       %{name}-mnogosearch.patch
 Patch21:       %{name}-ini.patch
 Patch22:       %{name}-acam.patch
+Patch23:       %{name}-xmlrpc-fix.patch
 Icon:          php4.gif
 URL:           http://www.php.net/
 BuildRequires: apache-devel
-BuildRequires: autoconf >= 2.52
-%{?_with_sybase_ct:BuildRequires:      autoconf >= 2.53}
+BuildRequires: autoconf >= 2.53
 BuildRequires: automake >= 1.4d
 BuildRequires: bison
 BuildRequires: bzip2-devel
@@ -88,16 +93,19 @@ BuildRequires:      cracklib-devel >= 2.7-15
 BuildRequires: curl-devel
 BuildRequires: cyrus-sasl-devel
 BuildRequires: db3-devel >= 3.1.17
+%if %(expr %{?_without_xml:0}%{!?_without_xml:1} + %{?_without_xmlrpc:0}%{!?_without_xmlrpc:1})
 BuildRequires: expat-devel
+%endif
 BuildRequires: flex
-%{?_with_sybase_ct:BuildRequires:      freetds-devel}
+%{!?_without_sybase_ct:BuildRequires:  freetds-devel}
 BuildRequires: freetype-devel >= 2.0
 BuildRequires: gd-devel >= 2.0.1
+%{!?_without_gif:BuildRequires:        gd-devel(gif)}
 BuildRequires: gdbm-devel
 BuildRequires: gmp-devel
 %{!?_without_imap:BuildRequires: imap-devel >= 1:2001-0.BETA.200107022325.2 }
 %{?_with_java:BuildRequires:   jdk >= 1.1}
-%{?_with_cpdf:BuildRequires:   libcpdf-devel >= 2.02r1-2}
+%{!?_without_cpdf:BuildRequires:       libcpdf-devel >= 2.02r1-2}
 BuildRequires: libjpeg-devel
 BuildRequires: libltdl-devel >= 1.4
 BuildRequires: libmcal-devel
@@ -105,7 +113,7 @@ BuildRequires:      libmcrypt-devel >= 2.4.4
 BuildRequires: libpng >= 1.0.8
 BuildRequires: libtiff-devel
 BuildRequires: libtool >= 0:1.4.2-9
-BuildRequires: libxml2-devel >= 2.2.7
+%{!?_without_xml:BuildRequires:        libxml2-devel >= 2.2.7}
 %{!?_without_domxslt:BuildRequires:    libxslt-devel >= 1.0.3}
 BuildRequires: mhash-devel
 BuildRequires: ming-devel >= 0.1.0
@@ -129,7 +137,7 @@ BuildRequires:      rpm-php-pearprov >= 4.0.2-80
 BuildRequires: t1lib-devel
 %{!?_without_snmp:BuildRequires: ucd-snmp-devel >= 4.2.3}
 %{!?_without_odbc:BuildRequires: unixODBC-devel}
-BuildRequires: xmlrpc-epi-devel
+%{!?_without_xmlrpc:BuildRequires:     xmlrpc-epi-devel}
 BuildRequires: yaz-devel
 BuildRequires: zip
 BuildRequires: zlib-devel >= 1.0.9
@@ -528,6 +536,7 @@ Summary:    GD extension module for PHP
 Summary:       Modu³ GD dla PHP
 Group:         Libraries
 PreReq:                %{name}-common = %{version}
+%{!?_without_gif:Provides:     %{name}-gd(gif) = %{epoch}:%{version}}
 
 %description gd
 This is a dynamic shared object (DSO) for Apache that will add GD
@@ -858,7 +867,7 @@ Uwaga: to jest modu
 Summary:       Process Control extension module for PHP
 Summary(pl):   Modu³ Process Control dla PHP
 Group:         Libraries
-PreReq:                %{name}-common = %{version}
+PreReq:                %{name}-cgi = %{version}
 
 %description pcntl
 This is a dynamic shared object (DSO) for Apache that will add process
@@ -1238,7 +1247,7 @@ Repozytorium Aplikacji. Ten pakiet zawiera aplikacje potrzebne do
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
+#%patch6 -p1
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
@@ -1258,6 +1267,7 @@ cp php.ini-dist php.ini
 # for ac2.53b/am1.6b - AC_LANG_CXX has AM_CONDITIONAL, so cannot be invoked
 # conditionally...
 %patch22 -p1
+%patch23 -p1
 
 install -d manual
 bzip2 -dc %{SOURCE3} | tar -xf - -C manual
@@ -1296,7 +1306,7 @@ for i in cgi apxs ; do
        --enable-magic-quotes \
        --enable-mbstring=shared --disable-mbstr-enc-trans --enable-mbregex \
        --enable-overload=shared \
-       --disable-pcntl \
+       %{?_with_pcntl:--enable-pcntl=shared}%{!?_with_pcntl:--disable-pcntl} \
        --enable-posix=shared \
        --enable-session \
        --enable-shared \
@@ -1309,11 +1319,11 @@ for i in cgi apxs ; do
        --enable-sockets=shared \
        --enable-ucd-snmp-hack \
        %{!?_without_wddx:--enable-wddx=shared} \
-       --enable-xml=shared \
+       %{?_without_xml:--disable-xml}%{!?_without_xml:--enable-xml=shared} \
        %{!?_without_xslt:--enable-xslt=shared} \
        --enable-yp=shared \
        --with-bz2=shared \
-       %{?_with_cpdf:--with-cpdflib=shared} \
+       %{!?_without_cpdf:--with-cpdflib=shared} \
        --with-crack=shared \
        --with-curl=shared \
        --without-db2 \
@@ -1321,7 +1331,11 @@ for i in cgi apxs ; do
        --with-dbase=shared \
        --with-dom=shared \
        %{!?_without_domxslt:--with-dom-xslt=shared --with-dom-exslt=shared} \
+%if %(expr %{?_without_xml:0}%{!?_without_xml:1} + %{?_without_xmlrpc:0}%{!?_without_xmlrpc:1})
        --with-expat-dir=shared,/usr \
+%else
+       --without-expat-dir \
+%endif
        --with-iconv=shared \
        --with-filepro=shared \
        --with-freetype-dir=shared \
@@ -1332,7 +1346,7 @@ for i in cgi apxs ; do
        --with-hyperwave=shared \
        %{!?_without_imap:--with-imap=shared --with-imap-ssl} \
        %{?_with_interbase:--with-interbase=shared} \
-       %{?_with_java:--with-java} \
+       %{?_with_java:--with-java=/usr/lib/java} \
        --with-jpeg-dir=shared,/usr \
        %{!?_without_ldap:--with-ldap=shared} \
        --with-mcal=shared,/usr \
@@ -1347,7 +1361,7 @@ for i in cgi apxs ; do
        %{?_with_oci8:--with-oci8=shared} \
        %{!?_without_openssl:--with-openssl=shared} \
        %{?_with_oracle:--with-oracle=shared} \
-       --with-pcre-regex=shared \
+       %{?_without_pcre:--without-pcre-regex}%{!?_without_pcre:--with-pcre-regex=shared} \
        %{!?_without_pdf:--with-pdflib=shared} \
        --with-pear=%{php_pear_dir} \
        --with-pgsql=shared,/usr \
@@ -1357,11 +1371,11 @@ for i in cgi apxs ; do
        --with-regex=php \
        --with-sablot-js=shared,no \
        %{!?_without_snmp:--with-snmp=shared} \
-       %{?_with_sybase_ct:--with-sybase-ct=shared,/usr} \
+       %{!?_without_sybase_ct:--with-sybase-ct=shared,/usr} \
        --with-t1lib=shared \
        --with-tiff-dir=shared,/usr \
        %{!?_without_odbc:--with-unixODBC=shared} \
-       --with-xmlrpc=shared,/usr \
+       %{?_without_xmlrpc:--without-xmlrpc}%{!?_without_xmlrpc:--with-xmlrpc=shared,/usr} \
        %{!?_without_xslt:--with-xslt-sablot=shared} \
        --with-yaz=shared \
        --with-zip=shared \
@@ -1373,7 +1387,7 @@ done
 # --enable-session=shared
 # %{?_without_mm:--with-mm=shared,no}%{!?_without_mm:--with-mm=shared}
 
-# TODO --with-pspell=/usr,shared (pspell missing)
+# TODO:
 #      --with-qtdom=shared
 
 %{__make}
@@ -1748,11 +1762,11 @@ if [ "$1" = "0" ]; then
 fi
 
 %post pcntl
-%{_sbindir}/php-module-install install pcntl %{_sysconfdir}/php.ini
+%{_sbindir}/php-module-install install pcntl %{_sysconfdir}/php-cgi.ini
 
 %preun pcntl
 if [ "$1" = "0" ]; then
-       %{_sbindir}/php-module-install remove pcntl %{_sysconfdir}/php.ini
+       %{_sbindir}/php-module-install remove pcntl %{_sysconfdir}/php-cgi.ini
 fi
 
 %post pcre
@@ -1976,7 +1990,7 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{extensionsdir}/calendar.so
 
-%if %{?_with_cpdf:1}%{!?_with_cpdf:0}
+%if %{?_without_cpdf:0}%{!?_without_cpdf:1}
 %files cpdf
 %defattr(644,root,root,755)
 %attr(755,root,root) %{extensionsdir}/cpdf.so
@@ -2133,14 +2147,17 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{extensionsdir}/overload.so
 
-# disabled in 4.2.0 - it segfaults
-#%files pcntl
-#%defattr(644,root,root,755)
-#%attr(755,root,root) %{extensionsdir}/pcntl.so
+%if %{?_with_pcntl:1}%{!?_with_pcntl:0}
+%files pcntl
+%defattr(644,root,root,755)
+%attr(755,root,root) %{extensionsdir}/pcntl.so
+%endif
 
+%if %{?_without_pcre:0}%{!?_without_pcre:1}
 %files pcre
 %defattr(644,root,root,755)
 %attr(755,root,root) %{extensionsdir}/pcre.so
+%endif
 
 %if %{?_without_pdf:0}%{!?_without_pdf:1}
 %files pdf
@@ -2185,7 +2202,7 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{extensionsdir}/sockets.so
 
-%if %{?_with_sybase_ct:1}%{!?_with_sybase_ct:0}
+%if %{?_without_sybase_ct:0}%{!?_without_sybase_ct:1}
 %files sybase-ct
 %defattr(644,root,root,755)
 %attr(755,root,root) %{extensionsdir}/sybase_ct.so
@@ -2205,13 +2222,17 @@ fi
 %attr(755,root,root) %{extensionsdir}/wddx.so
 %endif
 
+%if %{?_without_xml:0}%{!?_without_xml:1}
 %files xml
 %defattr(644,root,root,755)
 %attr(755,root,root) %{extensionsdir}/xml.so
+%endif
 
+%if %{?_without_xmlrpc:0}%{!?_without_xmlrpc:1}
 %files xmlrpc
 %defattr(644,root,root,755)
 %attr(755,root,root) %{extensionsdir}/xmlrpc.so
+%endif
 
 %if %{?_without_xslt:0}%{!?_without_xslt:1}
 %files xslt
This page took 0.082619 seconds and 4 git commands to generate.