]> git.pld-linux.org Git - packages/php.git/commitdiff
patch for x32 with suhosin enabled as well
authorElan Ruusamäe <glen@delfi.ee>
Fri, 20 Mar 2015 14:48:32 +0000 (14:48 +0000)
committerElan Ruusamäe <glen@delfi.ee>
Fri, 20 Mar 2015 14:48:32 +0000 (14:48 +0000)
php.spec
x32.patch

index 0edd0f96ac1f182f18070064488823c628f6c29b..4b5abe9439c2d90af259a824d82f75931d31d2ff 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2052,10 +2052,10 @@ cp -p php.ini-production php.ini
 %patch44 -p1
 %patch45 -p1
 %patch46 -p1
-%patch68 -p1
 %if %{with suhosin}
 %patch47 -p1
 %endif
+%patch68 -p1
 %patch48 -p1
 %patch49 -p1
 %patch50 -p1
index 5e4a89aa4d49e37af3cee93845d3963ec5cf371a..469c7ca6f7ecd072cc9a4acd5ce9b280630d3596 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -52,6 +52,56 @@ Fix bug #64729: compilation failure on x32
                 "rm"(size),
                 "rm"(offset));
  
++#undef LP_SUFF
++
+         if (UNEXPECTED(overflow)) {
+                 zend_error_noreturn(E_ERROR, "Possible integer overflow in memory allocation (%zu * %zu + %zu)", nmemb, size, offset);
+                 return 0;
+--- a/Zend/zend_alloc_canary.c
++++ b/Zend/zend_alloc_canary.c
+@@ -720,7 +720,7 @@ static inline unsigned int zend_mm_high_bit(size_t _size)
+ #elif defined(__GNUC__) && defined(__x86_64__)
+       unsigned long n;
+-        __asm__("bsrq %1,%0\n\t" : "=r" (n) : "rm"  (_size));
++        __asm__("bsr %1,%0\n\t" : "=r" (n) : "rm"  (_size));
+         return (unsigned int)n;
+ #elif defined(_MSC_VER) && defined(_M_IX86)
+       __asm {
+@@ -746,12 +746,12 @@ static inline unsigned int zend_mm_low_bit(size_t _size)
+ #elif defined(__GNUC__) && defined(__x86_64__)
+         unsigned long n;
+-        __asm__("bsfq %1,%0\n\t" : "=r" (n) : "rm"  (_size));
++        __asm__("bsf %1,%0\n\t" : "=r" (n) : "rm"  (_size));
+         return (unsigned int)n;
+ #elif defined(_MSC_VER) && defined(_M_IX86)
+       __asm {
+               bsf eax, _size
+-   }
++      }
+ #else
+       static const int offset[16] = {4,0,1,0,2,0,1,0,3,0,1,0,2,0,1,0};
+       unsigned int n;
+@@ -2481,12 +2481,22 @@ static inline size_t safe_address(size_t nmemb, size_t size, size_t offset)
+         size_t res = nmemb;
+         unsigned long overflow = 0;
+-        __asm__ ("mulq %3\n\taddq %4,%0\n\tadcq %1,%1"
++#ifdef __ILP32__ /* x32 */
++# define LP_SUFF "l"
++#else /* amd64 */
++# define LP_SUFF "q"
++#endif
++
++        __asm__ ("mul" LP_SUFF  " %3\n\t"
++                 "add %4,%0\n\t"
++                 "adc %1,%1"
+              : "=&a"(res), "=&d" (overflow)
+              : "%0"(res),
+                "rm"(size),
+                "rm"(offset));
 +#undef LP_SUFF
 +
          if (UNEXPECTED(overflow)) {
This page took 0.055934 seconds and 4 git commands to generate.