]> git.pld-linux.org Git - packages/php.git/commitdiff
- fix building with icu 69
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 27 Aug 2021 21:13:44 +0000 (23:13 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 27 Aug 2021 21:13:44 +0000 (23:13 +0200)
icu69.patch [new file with mode: 0644]
php.spec

diff --git a/icu69.patch b/icu69.patch
new file mode 100644 (file)
index 0000000..d3c14a6
--- /dev/null
@@ -0,0 +1,84 @@
+--- php-7.2.34/ext/intl/collator/collator_sort.c~      2020-09-30 07:15:54.000000000 +0200
++++ php-7.2.34/ext/intl/collator/collator_sort.c       2021-08-27 22:44:44.636032116 +0200
+@@ -30,6 +30,11 @@
+ typedef zend_long ptrdiff_t;
+ #endif
++#if !defined(FALSE)
++#define FALSE 0
++#define TRUE 1
++#endif
++
+ /**
+  * Declare 'index' which will point to sort key in sort key
+  * buffer.
+--- php-7.2.34/ext/intl/normalizer/normalizer_normalize.c~     2020-09-30 07:15:54.000000000 +0200
++++ php-7.2.34/ext/intl/normalizer/normalizer_normalize.c      2021-08-27 22:50:28.139941746 +0200
+@@ -25,6 +25,11 @@
+ #include "normalizer_normalize.h"
+ #include "intl_convert.h"
++#if !defined(FALSE)
++#define FALSE 0
++#define TRUE 1
++#endif
++
+ /* {{{ proto string Normalizer::normalize( string $input [, string $form = FORM_C] )
+  * Normalize a string. }}} */
+ /* {{{ proto string normalizer_normalize( string $input [, string $form = FORM_C] )
+--- php-7.2.34/ext/intl/dateformat/dateformat_attr.c~  2020-09-30 07:15:54.000000000 +0200
++++ php-7.2.34/ext/intl/dateformat/dateformat_attr.c   2021-08-27 22:52:05.242621694 +0200
+@@ -26,6 +26,11 @@
+ #include <unicode/ustring.h>
+ #include <unicode/udat.h>
++#if !defined(FALSE)
++#define FALSE 0
++#define TRUE 1
++#endif
++
+ /* {{{ proto unicode IntlDateFormatter::getDateType( )
+  * Get formatter datetype. }}} */
+ /* {{{ proto string datefmt_get_datetype( IntlDateFormatter $mf )
+--- php-7.2.34/ext/intl/timezone/timezone_class.cpp~   2020-09-30 07:15:54.000000000 +0200
++++ php-7.2.34/ext/intl/timezone/timezone_class.cpp    2021-08-27 22:52:48.582342940 +0200
+@@ -37,6 +37,11 @@
+ #include <ext/date/php_date.h>
+ }
++#if !defined(FALSE)
++#define FALSE 0
++#define TRUE 1
++#endif
++
+ using icu::Calendar;
+ /* {{{ Global variables */
+--- php-7.2.34/ext/intl/timezone/timezone_methods.cpp~ 2020-09-30 07:15:54.000000000 +0200
++++ php-7.2.34/ext/intl/timezone/timezone_methods.cpp  2021-08-27 22:53:23.048792982 +0200
+@@ -37,6 +37,11 @@
+ }
+ #include "common/common_enum.h"
++#if !defined(FALSE)
++#define FALSE 0
++#define TRUE 1
++#endif
++
+ using icu::Locale;
+ using icu::Calendar;
+--- php-7.2.34/ext/intl/breakiterator/codepointiterator_internal.cpp~  2020-09-30 07:15:54.000000000 +0200
++++ php-7.2.34/ext/intl/breakiterator/codepointiterator_internal.cpp   2021-08-27 22:54:10.761833238 +0200
+@@ -20,6 +20,11 @@
+ #include "php.h"
++#if !defined(FALSE)
++#define FALSE 0
++#define TRUE 1
++#endif
++
+ //copied from cmemory.h, which is not public
+ typedef union {
+     zend_long    t1;
index 2915effc354c1ab7d6352a79638bab614ffd9e8a..15016cc6b7a2d02a8f376438ba6d71f69559b843 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -218,6 +218,7 @@ Patch71:    libdb-info.patch
 Patch72:       phar-hash-shared.patch
 Patch73:       php-icu64.patch
 Patch74:       php-CVE-2019-11043.patch
+Patch75:       icu69.patch
 URL:           http://php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -2023,6 +2024,7 @@ cp -p php.ini-production php.ini
 %patch72 -p1
 %patch73 -p1
 %patch74 -p1
+%patch75 -p1
 
 sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{__bindir}\1,' \
       run-tests.php
This page took 0.439466 seconds and 4 git commands to generate.