]> git.pld-linux.org Git - packages/php.git/commitdiff
- 4.0.1pl2
authorArtur Frysiak <artur@frysiak.net>
Sat, 1 Jul 2000 07:01:14 +0000 (07:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added shared imap module

Changed files:
    php.spec -> 1.34

php.spec

index 9c56d59df765f529ebb481b73fc26b38aee8e844..1d037b6b9aa01fdba46e3d010b551ca524767083 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2,7 +2,7 @@ Summary:        The PHP HTML-embedded scripting language for use with Apache.
 Summary(fr):   Le langage de script embarque-HTML PHP pour Apache.
 Summary(pl):   Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache.
 Name:          php
-Version:       4.0.1
+Version:       4.0.1pl2
 Release:       1
 Group:         Libraries
 Group(fr):     Librairies
@@ -413,6 +413,20 @@ snmp support to PHP4.
 
 #%description snmp -l pl
 
+%package imap
+Summary:       imapextension module for PHP4
+Summary(pl):   Modu³ imap dla PHP4
+Group:         Libraries
+Group(fr):     Librairies
+Group(pl):     Biblioteki
+Requires:      %{name} = %{version}
+
+%description imap
+This is a dynamic shared object (DSO) for Apache that will add
+imap support to PHP4.
+
+#%description imap -l pl
+
 
 %package doc
 Summary:       Online manual for PHP4
@@ -994,9 +1008,25 @@ if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 fi
 
+%post imap
+if [ -f %{_sysconfdir}/httpd/php.ini ]; then
+       echo "activating module 'imap.so' in /etc/httpd/php.ini" 1>&2
+       perl -pi -e 's|^;extension=imap.so|extension=imap.so|g' \
+       %{_sysconfdir}/httpd/php.ini
+fi
+if [ -f /var/lock/subsys/httpd ]; then
+       /etc/rc.d/init.d/httpd restart 1>&2
+fi
 
-
-
+%preun imap
+if [ -f %{_sysconfdir}/httpd/php.ini ]; then
+       echo "deactivating module 'imap.so' in /etc/httpd/php.ini" 1>&2
+       perl -pi -e 's|^extension=imap.so|;extension=imap.so|g' \
+       %{_sysconfdir}/httpd/php.ini
+fi
+if [ -f /var/lock/subsys/httpd ]; then
+       /etc/rc.d/init.d/httpd restart 1>&2
+fi
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -1095,6 +1125,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_pkglibdir}/php/gettext.so
 
+%files imap
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_pkglibdir}/php/imap.so
+
 %files snmp
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_pkglibdir}/php/snmp.so
This page took 0.989048 seconds and 4 git commands to generate.