]> git.pld-linux.org Git - packages/php.git/commitdiff
- rel 2; fix bug 60598 auto/th/php54-5.4.18-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 29 Aug 2013 14:01:16 +0000 (16:01 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 29 Aug 2013 14:01:16 +0000 (16:01 +0200)
php-bug-60598.patch [new file with mode: 0644]
php.spec

diff --git a/php-bug-60598.patch b/php-bug-60598.patch
new file mode 100644 (file)
index 0000000..613889f
--- /dev/null
@@ -0,0 +1,16 @@
+diff --git a/Zend/zend_objects_API.c b/Zend/zend_objects_API.c
+index 1fe5d0c..b5dd48f 100644
+--- a/Zend/zend_objects_API.c
++++ b/Zend/zend_objects_API.c
+@@ -57,6 +57,11 @@ ZEND_API void zend_objects_store_call_destructors(zend_objects_store *objects TS
+                                       obj->dtor(obj->object, i TSRMLS_CC);
+                                       obj = &objects->object_buckets[i].bucket.obj;
+                                       obj->refcount--;
++
++                                      if (obj->refcount == 0) {
++                                              /* in case gc_collect_cycle is triggered before free_storage */
++                                              GC_REMOVE_ZOBJ_FROM_BUFFER(obj);
++                                      }
+                               }
+                       }
+               }
index 1693960fad5125b23cef7e66632e5c92a5e67062..c38b66458a1bf1da9cd465d8f88279c4a3359c06 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -124,7 +124,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     1
+%define                rel     2
 %define                orgname php
 %define                ver_suffix 54
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -212,6 +212,7 @@ Patch63:    %{orgname}-mysql-nowarning.patch
 #Patch64:      %{orgname}-m4.patch # not needed on 5.4 branch
 Patch65:       system-libzip.patch
 Patch66:       php-db.patch
+Patch67:       php-bug-60598.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -1927,6 +1928,7 @@ cp -p php.ini-production php.ini
 %patch63 -p1
 %{?with_system_libzip:%patch65 -p1}
 %patch66 -p1
+%patch67 -p1
 
 sed -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
 
This page took 0.053768 seconds and 4 git commands to generate.