]> git.pld-linux.org Git - packages/php.git/commitdiff
- updated to 8.1.0
authorAdam Gołębiowski <adamg@pld-linux.org>
Thu, 25 Nov 2021 17:35:56 +0000 (18:35 +0100)
committerAdam Gołębiowski <adamg@pld-linux.org>
Thu, 25 Nov 2021 17:35:56 +0000 (18:35 +0100)
fix-test-run.patch
libdb-info.patch
libtool-tag.patch [deleted file]
mysql-lib-ver-mismatch.patch
openssl.patch [deleted file]
php-ini.patch
php-systzdata.patch
php.spec
skip-tests.sh

index 50bccd4dee98864baba30fcc80d481dfa87684cb..cde2b04855fbe168e1cc149a7921119d0069950d 100644 (file)
@@ -1,7 +1,7 @@
 --- php-5.4.0alpha2/configure.ac~      2011-08-07 12:43:31.000000000 +0300
 +++ php-5.4.0alpha2/configure.ac       2011-08-07 12:44:11.495394662 +0300
 @@ -1271,6 +1271,9 @@
-   AC_DEFINE_UNQUOTED(ARCHITECTURE,"$PHP_BUILD_ARCH",[build architecture])
+   AC_DEFINE_UNQUOTED(PHP_BUILD_ARCH,"$PHP_BUILD_ARCH",[build architecture])
  fi
  
 +# shift so that extensions like xml are loaded first
index f2fcdfbbeaf0edfdb3a970a83fc8300a7536fb61..0c5a9007901cd31e3a908fed2974ea32fbcf0e16 100644 (file)
@@ -14,7 +14,7 @@
 @@ -545,6 +549,10 @@ PHP_MINFO_FUNCTION(dba)
  
        php_info_print_table_start();
-       php_info_print_table_row(2, "DBA support", "enabled");
+       php_info_print_table_row(2, "DBA support", "enabled");
 +#ifdef DB_VERSION_STRING
 +      php_info_print_table_row(2, "libdb header version", DB_VERSION_STRING);
 +      php_info_print_table_row(2, "libdb library version", db_version(NULL, NULL, NULL));
diff --git a/libtool-tag.patch b/libtool-tag.patch
deleted file mode 100644 (file)
index d7e5400..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- php-5.6.0RC4/configure.ac~ 2014-08-20 16:08:27.000000000 +0300
-+++ php-5.6.0RC4/configure.ac  2014-08-21 20:49:14.693072513 +0300
-@@ -1408,6 +1408,9 @@
- dnl libtool 1.4.3 needs this.
- PHP_SET_LIBTOOL_VARIABLE([--preserve-dup-deps])
-+dnl pass --tag=CC to unconfuse when CC="ccache gcc"
-+PHP_SET_LIBTOOL_VARIABLE([--tag=CC])
-+
- test -z "$PHP_COMPILE" && PHP_COMPILE='$(LIBTOOL) --mode=compile $(COMPILE) -c $<'
- test -z "$CXX_PHP_COMPILE" && CXX_PHP_COMPILE='$(LIBTOOL) --mode=compile $(CXX_COMPILE) -c $<'
- SHARED_LIBTOOL='$(LIBTOOL)'
index 4ebe277fa5f044bd0b26341849669ded8998087a..12b85e5eff211da5c9f53002add39568aa355eb7 100644 (file)
@@ -1,7 +1,7 @@
 --- php-5.3.27/ext/mysqli/mysqli_nonapi.c~     2013-11-20 00:19:11.000000000 +0200
 +++ php-5.3.27/ext/mysqli/mysqli_nonapi.c      2013-11-20 00:19:44.725872552 +0200
 @@ -73,7 +73,7 @@
-       zend_bool                       self_alloced = 0;
+       bool                    self_alloced = 0;
 
 
 -#if !defined(MYSQL_USE_MYSQLND)
diff --git a/openssl.patch b/openssl.patch
deleted file mode 100644 (file)
index a8dabb1..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- php-8.0.8/ext/openssl/openssl.c~   2021-06-29 09:41:19.000000000 +0200
-+++ php-8.0.8/ext/openssl/openssl.c    2021-10-23 20:39:04.743124767 +0200
-@@ -1221,7 +1221,9 @@ PHP_MINIT_FUNCTION(openssl)
-       REGISTER_LONG_CONSTANT("OPENSSL_CMS_NOSIGS", CMS_NOSIGS, CONST_CS|CONST_PERSISTENT);
-       REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_PADDING", RSA_PKCS1_PADDING, CONST_CS|CONST_PERSISTENT);
-+#ifdef RSA_SSLV23_PADDING
-       REGISTER_LONG_CONSTANT("OPENSSL_SSLV23_PADDING", RSA_SSLV23_PADDING, CONST_CS|CONST_PERSISTENT);
-+#endif
-       REGISTER_LONG_CONSTANT("OPENSSL_NO_PADDING", RSA_NO_PADDING, CONST_CS|CONST_PERSISTENT);
-       REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_OAEP_PADDING", RSA_PKCS1_OAEP_PADDING, CONST_CS|CONST_PERSISTENT);
index badcd345bdaa641ea93c75265f772af42141dd7e..db8a3f0d619d99e04d8da1fe60e9f95f06e62f11 100644 (file)
 @@ -225,7 +237,7 @@
  ; Development Value: Off
  ; Production Value: Off
- ; http://php.net/short-open-tag
+ ; https://php.net/short-open-tag
 -short_open_tag = Off
 +short_open_tag = On
  
  ; The number of significant digits displayed in floating point numbers.
- ; http://php.net/precision
+ ; https://php.net/precision
 @@ -360,7 +372,7 @@
  ; threat in any way, but it makes it possible to determine whether you use PHP
  ; on your server or not.
- ; http://php.net/expose-php
+ ; https://php.net/expose-php
 -expose_php = On
 +expose_php = Off
  
@@ -55,7 +55,7 @@
 @@ -744,9 +756,7 @@
  
  ; Directory in which the loadable extensions (modules) reside.
- ; http://php.net/extension-dir
+ ; https://php.net/extension-dir
 -;extension_dir = "./"
 -; On windows:
 -;extension_dir = "ext"
  ; Directory where the temporary files should be placed.
  ; Defaults to the system default (see sys_get_temp_dir)
 @@ -758,64 +768,6 @@
- ; http://php.net/enable-dl
+ ; https://php.net/enable-dl
  enable_dl = Off
  
 -; cgi.force_redirect is necessary to provide security running PHP as a CGI under
 -; most web servers.  Left undefined, PHP turns this on by default.  You can
 -; turn it off here AT YOUR OWN RISK
 -; **You CAN safely turn this off for IIS, in fact, you MUST.**
--; http://php.net/cgi.force-redirect
+-; https://php.net/cgi.force-redirect
 -;cgi.force_redirect = 1
 -
 -; if cgi.nph is enabled it will force cgi to always sent Status: 200 with
@@ -82,7 +82,7 @@
 -; (iPlanet) web servers, you MAY need to set an environment variable name that PHP
 -; will look for to know it is OK to continue execution.  Setting this variable MAY
 -; cause security issues, KNOW WHAT YOU ARE DOING FIRST.
--; http://php.net/cgi.redirect-status-env
+-; https://php.net/cgi.redirect-status-env
 -;cgi.redirect_status_env =
 -
 -; cgi.fix_pathinfo provides *real* PATH_INFO/PATH_TRANSLATED support for CGI.  PHP's
@@ -91,7 +91,7 @@
 -; this to 1 will cause PHP CGI to fix its paths to conform to the spec.  A setting
 -; of zero causes PHP to behave as before.  Default is 1.  You should fix your scripts
 -; to use SCRIPT_FILENAME rather than PATH_TRANSLATED.
--; http://php.net/cgi.fix-pathinfo
+-; https://php.net/cgi.fix-pathinfo
 -;cgi.fix_pathinfo=1
 -
 -; if cgi.discard_path is enabled, the PHP CGI binary can safely be placed outside
 -; security context that the request runs under.  mod_fastcgi under Apache
 -; does not currently support this feature (03/17/2002)
 -; Set to 1 if running under IIS.  Default is zero.
--; http://php.net/fastcgi.impersonate
+-; https://php.net/fastcgi.impersonate
 -;fastcgi.impersonate = 1
 -
 -; Disable logging through FastCGI connection. PHP's default behavior is to enable
 -; is supported by Apache. When this option is set to 1, PHP will send
 -; RFC2616 compliant header.
 -; Default is zero.
--; http://php.net/cgi.rfc2616-headers
+-; https://php.net/cgi.rfc2616-headers
 -;cgi.rfc2616_headers = 0
 -
 -; cgi.check_shebang_line controls whether CGI PHP checks for line starting with #!
 -; (shebang) at the top of the running script. This line might be needed if the
 -; script support running both as stand-alone script and via PHP CGI<. PHP in CGI
 -; mode skips this line and ignores its content if this directive is turned on.
--; http://php.net/cgi.check-shebang-line
+-; https://php.net/cgi.check-shebang-line
 -;cgi.check_shebang_line=1
 -
  ;;;;;;;;;;;;;;;;
 -;extension=shmop
 -
 -; The MIBS data available in the PHP distribution must be installed.
--; See http://www.php.net/manual/en/snmp.installation.php
+-; See https://www.php.net/manual/en/snmp.installation.php
 -;extension=snmp
 -
 -;extension=soap
  
  [Date]
  ; Defines the default timezone used by the date functions
--; http://php.net/date.timezone
+-; https://php.net/date.timezone
 -;date.timezone =
-+; http://php.net/date.timezone.
++; https://php.net/date.timezone
 +;
 +; NOTE: In PLD Linux the /etc/php/conf.d/timezone.ini is used to set timezone
  
- ; http://php.net/date.default-latitude
+ ; https://php.net/date.default-latitude
  ;date.default_latitude = 31.7667
 @@ -970,19 +884,19 @@
  ; Use of this INI entry is deprecated, use global input_encoding instead.
 @@ -1360,7 +1274,7 @@
  
  [browscap]
- ; http://php.net/browscap
+ ; https://php.net/browscap
 -;browscap = extra/browscap.ini
 +;browscap = /usr/share/browscap/php_browscap.ini
  
 @@ -1747,7 +1661,7 @@
  
  ; Sets the directory name where SOAP extension will put cache files.
- ; http://php.net/soap.wsdl-cache-dir
+ ; https://php.net/soap.wsdl-cache-dir
 -soap.wsdl_cache_dir="/tmp"
 +soap.wsdl_cache_dir="/var/cache/php"
  
 -
 -; Specifies a PHP script that is going to be compiled and executed at server
 -; start-up.
--; http://php.net/opcache.preload
+-; https://php.net/opcache.preload
 -;opcache.preload=
 -
 -; Preloading code as root is not allowed for security reasons. This directive
 -; facilitates to let the preloading to be run as another user.
--; http://php.net/opcache.preload_user
+-; https://php.net/opcache.preload_user
 -;opcache.preload_user=
 -
 -; Prevents caching files that are less than this number of seconds old. It
index 5b0d84b7d9f31d31a603a2060c53dbef07d78305..5de8e0d0bb1cb3a9892d1c88ab021c3c9e9e4e61 100644 (file)
@@ -51,13 +51,13 @@ diff -up ./ext/date/config0.m4.systzdata ./ext/date/config0.m4
 +   fi
 +fi
 +
- PHP_DATE_CFLAGS="-I@ext_builddir@/lib -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -DHAVE_TIMELIB_CONFIG_H=1"
- timelib_sources="lib/astro.c lib/dow.c lib/parse_date.c lib/parse_tz.c
+ PHP_DATE_CFLAGS="-Wno-implicit-fallthrough -I@ext_builddir@/lib -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -DHAVE_TIMELIB_CONFIG_H=1"
+ timelib_sources="lib/astro.c lib/dow.c lib/parse_date.c lib/parse_tz.c lib/parse_posix.c
                   lib/timelib.c lib/tm2unixtime.c lib/unixtime2tm.c lib/parse_iso_intervals.c lib/interval.c"
 diff -up ./ext/date/lib/parse_tz.c.systzdata ./ext/date/lib/parse_tz.c
 --- ./ext/date/lib/parse_tz.c.systzdata        2021-08-10 11:35:28.000000000 +0200
 +++ ./ext/date/lib/parse_tz.c  2021-08-10 12:12:13.191605207 +0200
-@@ -26,8 +26,21 @@
+@@ -26,9 +26,22 @@
  #include "timelib.h"
  #include "timelib_private.h"
  
@@ -72,6 +72,7 @@ diff -up ./ext/date/lib/parse_tz.c.systzdata ./ext/date/lib/parse_tz.c
 +
 +#else
  #define TIMELIB_SUPPORTS_V2DATA
+ #define TIMELIB_SUPPORT_SLIM_FILE
  #include "timezonedb.h"
 +#endif
 +
@@ -622,8 +623,8 @@ diff -up ./ext/date/lib/parse_tz.c.systzdata ./ext/date/lib/parse_tz.c
  
                version = read_preamble(&tzf, tmp, &type);
 @@ -563,11 +1067,36 @@ timelib_tzinfo *timelib_parse_tzfile(con
+                       return NULL;
                }
-               skip_posix_string(&tzf, tmp);
  
 +#ifdef HAVE_SYSTEM_TZDATA
 +              if (memmap) {
index 074eb834e29913f57eada5509f0f43f2c8162f47..6b93d5606dae189d370ac381f624653a361f80a3 100644 (file)
--- a/php.spec
+++ b/php.spec
 %endif
 
 %define                orgname php
-%define                ver_suffix 80
+%define                ver_suffix 81
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
@@ -147,7 +147,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       8.0.12
+Version:       8.1.0
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -156,7 +156,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 2c42ee6263c9fe01463924a063b0934f
+# Source0-md5: 552bc63901c6a1bad195e6a47be3c341
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -174,7 +174,6 @@ Patch2:             %{orgname}-mail.patch
 Patch3:                %{orgname}-link-libs.patch
 Patch4:                intl-stdc++.patch
 Patch7:                %{orgname}-sapi-ini-file.patch
-Patch9:                libtool-tag.patch
 Patch10:       %{orgname}-ini.patch
 Patch11:       embed.patch
 Patch14:       %{orgname}-no_pear_install.patch
@@ -200,7 +199,6 @@ Patch67:    mysql-lib-ver-mismatch.patch
 # https://bugs.php.net/bug.php?id=68344
 Patch68:       php-mysql-ssl-context.patch
 Patch71:       libdb-info.patch
-Patch72:       openssl.patch
 URL:           http://php.net/
 %{?with_pdo_firebird:%{!?with_interbase_inst:BuildRequires:    Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -281,7 +279,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir                     %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20200930
+%define                php_api_version         20210902
 %define                zend_module_api         %{php_api_version}
 %define                zend_extension_api      4%{zend_module_api}
 %define                php_pdo_api_version     20170320
@@ -295,7 +293,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jsonver         %{version}
 %define                pharver         %{version}
 %define                sqlite3ver      %{version}
-%define                zipver          1.19.4
+%define                zipver          1.19.5
 %define                phpdbgver       %{version}
 %define                sodiumver       %{version}
 
@@ -1865,7 +1863,6 @@ cp -p php.ini-production php.ini
 %patch4 -p1
 
 %patch7 -p1 -b .sapi-ini-file
-%patch9 -p1
 %patch10 -p1 -b .ini
 %patch14 -p1
 %patch18 -p1
@@ -1891,7 +1888,6 @@ cp -p php.ini-production php.ini
 %patch67 -p1 -b .mysql-lib-ver-mismatch
 #%patch68 -p1 DROP or update to 7.0 APIs
 %patch71 -p1 -b .libdb-info
-%patch72 -p1
 
 sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{__bindir}\1,' \
       ext/ext_skel.php \
@@ -3242,7 +3238,6 @@ fi
 %{php_data_dir}/tests/php/run-test
 %{php_data_dir}/tests/php/security
 %{php_data_dir}/tests/php/strings
-%{php_data_dir}/tests/php/quicktester.inc
 %attr(755,root,root) %{php_data_dir}/tests/php/run-tests.php
 
 %if %{with tidy}
index d378d7225a3db96f61a7d95ea1c745b706fe7e28..dbe7d39e9ac5da1839e9b66968dda3655e034637 100644 (file)
@@ -17,8 +17,6 @@ mv ext/filter/tests/bug52209.phpt{,.skip}
 mv ext/gd/tests/bug43073.phpt{,.skip}
 # Bug #48801 (Problem with imagettfbbox)
 mv ext/gd/tests/bug48801.phpt{,.skip}
-# PDO Common: PDORow + get_parent_class()
-$x8664 mv ext/pdo/tests/pdo_035.phpt{,.skip}
 # Bug #47415 PDO_Firebird segfaults when passing lowercased column name to bindColumn()
 mv ext/pdo_firebird/tests/bug_47415.phpt{,.skip}
 # PDO_Firebird: bug 48877 The "bindValue" and "bindParam" do not work for PDO Firebird if we use named parameters (:parameter).
This page took 0.083676 seconds and 4 git commands to generate.