]> git.pld-linux.org Git - packages/php.git/commitdiff
fix fpm logs. no longer conflict with 5.3 and use existing paths
authorElan Ruusamäe <glen@delfi.ee>
Mon, 8 Oct 2012 08:07:26 +0000 (11:07 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 8 Oct 2012 08:07:26 +0000 (11:07 +0300)
php-fpm-config.patch
php-fpm.logrotate
php.spec

index bf13cc4ebb1faf5be915eec454c350dde83a53ab..779e8cd6cd27f0dff352799d01adabf5aacd894d 100644 (file)
@@ -1,6 +1,6 @@
---- php-5.3.6/sapi/fpm/php-fpm.conf.in 2011-04-22 15:16:07.304822817 +0300
-+++ php-5.3.6/sapi/fpm/php-fpm.conf.in 2011-04-22 15:19:46.991588712 +0300
-@@ -22,7 +22,7 @@
+--- php-5.4.7/sapi/fpm/php-fpm.conf.in~        2012-10-05 22:15:59.000000000 +0300
++++ php-5.4.7/sapi/fpm/php-fpm.conf.in 2012-10-05 22:16:44.895998479 +0300
+@@ -22,14 +22,14 @@
  ; Pid file
  ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
  ; Default Value: none
@@ -8,7 +8,15 @@
 +pid = /var/run/php/@processname@.pid
  
  ; Error log file
+ ; If it's set to "syslog", log is sent to syslogd instead of being written
+ ; in a local file.
  ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
+ ; Default Value: log/php-fpm.log
+-;error_log = log/php-fpm.log
++error_log = log/@processname@.log
+ ; syslog_facility is used to specify what type of program is logging the
+ ; message. This lets syslogd specify that messages from different facilities
 @@ -93,7 +93,7 @@
  ;                            specific port;
  ;   '/path/to/unix/socket' - to listen on a unix socket.
index 3bec7c1a11e7ba613b5ee84c267fc667c5a03dc8..694b2312606e0056fdc7b6b7ece568f88d6069f1 100644 (file)
@@ -1,11 +1,10 @@
-/var/log/fpm.log
-/var/log/fpm-slow.log
+/var/log/@processname@.log
 {
        notifempty
        missingok
        create 600 root root
        sharedscripts
        postrotate
-               /sbin/service php-fpm flush-logs > /dev/null
+               /sbin/service @processname@ flush-logs > /dev/null
        endscript
 }
index bbf86d61ba16313ac036b699930a2ba506ac034a..d952e43b7ed33839fa56e2100e1b66674f35ef0b 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -126,7 +126,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %define                orgname php
 %define                php_suffix 54
 
-%define                rel     0.19
+%define                rel     0.20
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -2424,13 +2424,14 @@ cp -p sapi/fpm/php-fpm.8 $RPM_BUILD_ROOT%{_mandir}/man8/%{name}-fpm.8
 cp -p sapi/fpm/php-fpm.conf $RPM_BUILD_ROOT%{_sysconfdir}
 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-fpm
+install -d $RPM_BUILD_ROOT/etc/logrotate.d
+cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-fpm
+
 %{__sed} -i -e '
        s#/usr/lib/php#%{php_extensiondir}#
        s#/etc/php#%{_sysconfdir}#
        s#@processname@#%{name}-fpm#g
-' $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-fpm $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.conf
-install -d $RPM_BUILD_ROOT/etc/logrotate.d
-cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-fpm
+' $RPM_BUILD_ROOT{/etc/{rc.d/init.d/%{name}-fpm,logrotate.d/%{name}-fpm},%{_sysconfdir}/php-fpm.conf}
 %endif
 
 # install Embedded API
This page took 0.060362 seconds and 4 git commands to generate.