]> git.pld-linux.org Git - packages/php.git/commitdiff
- fix "invalid operands to binary -" error caused by missing stpcpy prototype
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 10 Oct 2011 21:00:59 +0000 (21:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  on ac in some form of build configuration (not clear how it managed to
  compile before)

Changed files:
    php-svn-281516.patch -> 1.1.2.1
    php.spec -> 1.805.2.92

php-svn-281516.patch [new file with mode: 0644]
php.spec

diff --git a/php-svn-281516.patch b/php-svn-281516.patch
new file mode 100644 (file)
index 0000000..09deed5
--- /dev/null
@@ -0,0 +1,32 @@
+fix "invalid operands to binary -" error caused by missing stpcpy prototype:
+
+php-5.2.17/Zend/zend_language_parser.c:2581: error: invalid operands to binary -
+php-5.2.17/Zend/zend_language_parser.c: In function `yysyntax_error':
+php-5.2.17/Zend/zend_language_parser.c:2640: warning: assignment makes pointer from integer without a cast
+php-5.2.17/Zend/zend_language_parser.c:2656: warning: assignment makes pointer from integer without a cast
+make: *** [Zend/zend_language_parser.lo] Error 1
+
+http://llvm.org/bugs/show_bug.cgi?id=3443
+http://news.php.net/php.zend-engine.cvs/7639
+http://svn.php.net/viewvc?view=revision&revision=281516
+
+--- php/php-src/branches/PHP_5_3/Zend/zend.h   2009/06/01 17:35:12     281515
++++ php/php-src/branches/PHP_5_3/Zend/zend.h   2009/06/01 17:51:53     281516
+@@ -34,8 +34,6 @@
+ #define END_EXTERN_C()
+ #endif
+-#include <stdio.h>
+-
+ /*
+  * general definitions
+  */
+@@ -66,6 +64,8 @@
+ #endif
+ /* all HAVE_XXX test have to be after the include of zend_config above */
++
++#include <stdio.h>
+ #ifdef HAVE_UNIX_H
+ # include <unix.h>
index faf956729a455c8c50c09d1439096d41583d6019..616bc4952b2ccfcd377b6cd3c0bc9b599d67d7ec 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -190,6 +190,7 @@ Patch54:    fix-test-run.patch
 Patch55:       bug-52078-fileinode.patch
 Patch56:       %{name}-krb5.patch
 Patch57:       php-php_dl.patch
+Patch58:       php-svn-281516.patch
 # http://spot.fedorapeople.org/php-5.3.6-libzip.patch
 Patch65:       system-libzip.patch
 # CENTALT patches
@@ -1933,6 +1934,7 @@ done
 %patch55 -p1
 %patch56 -p1
 %patch57 -p1
+%patch58 -p1
 %patch65 -p1
 
 %patch201 -p1 -b .CVE-2011-2202
This page took 0.056995 seconds and 4 git commands to generate.