]> git.pld-linux.org Git - packages/php.git/commitdiff
Up to 8.1.4; workaround behaviour change in openssl 3 auto/th/php81-8.1.4-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 29 Mar 2022 12:32:56 +0000 (14:32 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 29 Mar 2022 12:32:56 +0000 (14:32 +0200)
openssl.patch [new file with mode: 0644]
php.spec

diff --git a/openssl.patch b/openssl.patch
new file mode 100644 (file)
index 0000000..1256370
--- /dev/null
@@ -0,0 +1,26 @@
+diff --git a/ext/openssl/xp_ssl.c b/ext/openssl/xp_ssl.c
+index 5564bf6f08..423f696c76 100644
+--- a/ext/openssl/xp_ssl.c
++++ b/ext/openssl/xp_ssl.c
+@@ -1286,6 +1286,10 @@ static int php_openssl_set_server_specific_opts(php_stream *stream, SSL_CTX *ctx
+       zval *zv;
+       long ssl_ctx_options = SSL_CTX_get_options(ctx);
++#ifdef SSL_OP_IGNORE_UNEXPECTED_EOF
++      ssl_ctx_options |= SSL_OP_IGNORE_UNEXPECTED_EOF;
++#endif
++
+ #if defined(HAVE_ECDH) && PHP_OPENSSL_API_VERSION < 0x10100
+       if (php_openssl_set_server_ecdh_curve(stream, ctx) == FAILURE) {
+               return FAILURE;
+@@ -1628,6 +1632,10 @@ int php_openssl_setup_crypto(php_stream *stream,
+       ssl_ctx_options = SSL_OP_ALL;
+ #endif
++#ifdef SSL_OP_IGNORE_UNEXPECTED_EOF
++      ssl_ctx_options |= SSL_OP_IGNORE_UNEXPECTED_EOF;
++#endif
++
+       if (sslsock->ctx == NULL) {
+               php_error_docref(NULL, E_WARNING, "SSL context creation failure");
+               return FAILURE;
index 4ec9c3b8d4cc101fe1991afc94a0f584be8ceed6..b440781e08e9ae7d20c746b145ce4eea9df28fcc 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -148,7 +148,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       8.1.3
+Version:       8.1.4
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -157,7 +157,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 495972570d055fef1255e296051a13a5
+# Source0-md5: 6473a944378c59080bcd837552dcaf3f
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -174,6 +174,8 @@ Patch1:             %{orgname}-pldlogo.patch
 Patch2:                %{orgname}-mail.patch
 Patch3:                %{orgname}-link-libs.patch
 Patch4:                intl-stdc++.patch
+# https://bugs.php.net/bug.php?id=79589
+Patch5:                openssl.patch
 Patch7:                %{orgname}-sapi-ini-file.patch
 Patch10:       %{orgname}-ini.patch
 Patch11:       embed.patch
@@ -1865,6 +1867,7 @@ cp -p php.ini-production php.ini
 #%patch2 -p1 -b .mail
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %patch7 -p1 -b .sapi-ini-file
 %patch10 -p1 -b .ini
This page took 0.052526 seconds and 4 git commands to generate.