]> git.pld-linux.org Git - packages/php.git/commitdiff
bc1d2c701085d0e03695d0102a51907d php-install_gd_headers.patch php-4_4_1-1
authorhawk <hawk@pld-linux.org>
Sun, 4 Dec 2005 14:30:16 +0000 (14:30 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
69dba69aeb04e3632583616a223175bc  php-bug-35009.patch
1c697c720124c6fe648ae91d50115ad0  php-bug-35056.patch
31c054311f8211f423d4524183b04743  php-bug-35067.patch

Changed files:
    php-bug-35009.patch -> 1.1.2.1
    php-bug-35056.patch -> 1.1.2.1
    php-bug-35067.patch -> 1.1.2.1
    php-install_gd_headers.patch -> 1.1.4.1

php-bug-35009.patch
php-bug-35056.patch [new file with mode: 0644]
php-bug-35067.patch [new file with mode: 0644]
php-install_gd_headers.patch

index ef08ed8bc1f15b9ab5526345065b4c8afade93b8..c45f1ba63ba9382037f8978b7358d619df658c52 100644 (file)
@@ -1,35 +1,30 @@
-
-===================================================================
-RCS file: /repository/ZendEngine2/zend.c,v
-retrieving revision 1.287.2.12
-retrieving revision 1.287.2.14
-diff -p --unified=3 -r1.287.2.12 -r1.287.2.14
---- ./Zend/zend.c      2005/07/22 07:33:27     1.287.2.12
-+++ ./Zend/zend.c      2005/11/07 12:25:21     1.287.2.14
+--- php-4.4.1/Zend/zend.c      2005-06-09 13:14:25.000000000 +0300
++++ php4-STABLE-200511081543/Zend/zend.c       2005-11-07 16:01:13.000000000 +0200
 @@ -17,7 +17,7 @@
     +----------------------------------------------------------------------+
  */
-
 -/* $Id$ */
 +/* $Id$ */
-
  #include "zend.h"
  #include "zend_extensions.h"
-@@ -693,9 +693,7 @@ void zend_shutdown(TSRMLS_D)
+@@ -564,9 +564,7 @@
  #ifdef ZEND_WIN32
        zend_shutdown_timeout_thread();
  #endif
 -#ifndef ZTS
        zend_destroy_rsrc_list(&EG(persistent_list) TSRMLS_CC);
--#endif
+-#endif        
        zend_hash_graceful_reverse_destroy(&module_registry);
-
-       zend_hash_destroy(GLOBAL_FUNCTION_TABLE);
-@@ -711,7 +709,6 @@ void zend_shutdown(TSRMLS_D)
-       free(GLOBAL_FUNCTION_TABLE);
-       free(GLOBAL_CLASS_TABLE);
+       zend_shutdown_extensions(TSRMLS_C);
+@@ -584,8 +582,6 @@
+       zend_shutdown_constants(TSRMLS_C);
  #ifdef ZTS
 -      zend_destroy_rsrc_list(&EG(persistent_list) TSRMLS_CC);
+-
        zend_hash_destroy(GLOBAL_CONSTANTS_TABLE);
        free(GLOBAL_CONSTANTS_TABLE);
-       GLOBAL_FUNCTION_TABLE = NULL;
diff --git a/php-bug-35056.patch b/php-bug-35056.patch
new file mode 100644 (file)
index 0000000..1f74825
--- /dev/null
@@ -0,0 +1,21 @@
+diff -urNbB php-4.4.1.org/sapi/apache2handler/sapi_apache2.c php-4.4.1/sapi/apache2handler/sapi_apache2.c
+--- php-4.4.1.org/sapi/apache2handler/sapi_apache2.c   2005-10-12 23:41:36.000000000 +0200
++++ php-4.4.1/sapi/apache2handler/sapi_apache2.c       2005-11-02 18:58:52.000000000 +0100
+@@ -18,7 +18,7 @@
+    +----------------------------------------------------------------------+
+  */
+-/* $Id$ */
++/* $Id$ */
+ #include <fcntl.h>
+@@ -535,7 +535,7 @@
+               if (!parent_req) {
+                       parent_req = ctx->r;
+               }
+-              if (parent_req && strcmp(parent_req->handler, PHP_MAGIC_TYPE) && strcmp(parent_req->handler, PHP_SOURCE_MAGIC_TYPE) && strcmp(parent_req->handler, PHP_SCRIPT)) {
++              if (parent_req && parent_req->handler && strcmp(parent_req->handler, PHP_MAGIC_TYPE) && strcmp(parent_req->handler, PHP_SOURCE_MAGIC_TYPE) && strcmp(parent_req->handler, PHP_SCRIPT)) {
+                       if (php_apache_request_ctor(r, ctx TSRMLS_CC)!=SUCCESS) {
+                               zend_bailout();
+                       }
diff --git a/php-bug-35067.patch b/php-bug-35067.patch
new file mode 100644 (file)
index 0000000..4fe299f
--- /dev/null
@@ -0,0 +1,27 @@
+===================================================================
+RCS file: /repository/php-src/ext/standard/basic_functions.c,v
+retrieving revision 1.543.2.51.2.3
+retrieving revision 1.543.2.51.2.4
+diff -p --unified=3 -r1.543.2.51.2.3 -r1.543.2.51.2.4
+--- php-src/ext/standard/basic_functions.c     2005/09/29 16:31:48     1.543.2.51.2.3
++++ php-src/ext/standard/basic_functions.c     2005/11/02 17:58:00     1.543.2.51.2.4
+@@ -17,7 +17,7 @@
+    +----------------------------------------------------------------------+
+  */
+
+-/* $Id$ */
++/* $Id$ */
+
+ #include "php.h"
+ #include "php_streams.h"
+@@ -802,8 +802,8 @@ function_entry basic_functions[] = {
+       PHP_FE(prev,                                    first_arg_force_ref)
+       PHP_FE(next,                                    first_arg_force_ref)
+       PHP_FE(reset,                                   first_arg_force_ref)
+-      PHP_FE(current,                                 NULL)
+-      PHP_FE(key,                                     NULL)
++      PHP_FE(current,                                 first_arg_force_ref)
++      PHP_FE(key,                                     first_arg_force_ref)
+       PHP_FE(min,                                                                                                                             NULL)
+       PHP_FE(max,                                                                                                                             NULL)
+       PHP_FE(in_array,                                                                                                                NULL)
index 47f3c7674aed54ade85ba06a5269aded0fa23571..a0ab1e8c33f440ffe58623b08a1b101c40c170c6 100644 (file)
@@ -1,12 +1,12 @@
-diff -burN php-5.0.3.orig/scripts/Makefile.frag php-5.0.3/scripts/Makefile.frag
---- php-5.0.3.orig/scripts/Makefile.frag       2005-02-10 07:43:48.406281496 +0100
-+++ php-5.0.3/scripts/Makefile.frag    2005-02-10 07:44:19.768513712 +0100
-@@ -30,6 +30,8 @@
+diff -urbB php-4.4.0.org/scripts/Makefile.frag php-4.4.0/scripts/Makefile.frag
+--- php-4.4.0.org/scripts/Makefile.frag        2005-07-11 21:46:28.711768000 +0200
++++ php-4.4.0/scripts/Makefile.frag    2005-07-11 21:47:52.847977560 +0200
+@@ -37,6 +37,8 @@
+       include/ \
        main/ \
-       main/streams/ \
        regex/ \
-+      ext/gd \
++      ext/gd/ \
 +      ext/gd/libgd/ \
        ext/iconv/ \
-       ext/libxml/ \
+       ext/pgsql/ \
        ext/standard/ \
This page took 0.042908 seconds and 4 git commands to generate.