]> git.pld-linux.org Git - packages/php.git/commitdiff
fix fpm files packaging auto/ac/php-5.2.17-15 auto/ac/php52-5.2.17-15
authorElan Ruusamäe <glen@delfi.ee>
Thu, 23 Aug 2012 23:00:42 +0000 (02:00 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 23 Aug 2012 23:00:42 +0000 (02:00 +0300)
php.spec

index 1284de2fb91b8c60c6caf302eb0e06b7ebc4b118..f74afb46144613b486c2e94951a7fb7e431b306e 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2455,16 +2455,15 @@ libtool --silent --mode=install install sapi/fcgi/php-cgi $RPM_BUILD_ROOT%{_bind
 # install FCGI PM
 %if %{with fpm}
 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/fpm.d,%{_sbindir}}
-libtool --mode=install install -p sapi/fpm/php-fpm $RPM_BUILD_ROOT%{_sbindir}/%{name}-fpm
-cp -p sapi/fpm/php-fpm.8 $RPM_BUILD_ROOT%{_mandir}/man8/%{name}-fpm.8
-cp -p sapi/fpm/php-fpm.conf $RPM_BUILD_ROOT%{_sysconfdir}
+libtool --mode=install install -p sapi/fpm/php-cgi $RPM_BUILD_ROOT%{_sbindir}/%{name}-fpm
+cp -p sapi/fpm/fpm/php-fpm.conf $RPM_BUILD_ROOT%{_sysconfdir}/fpm.conf
 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-fpm
 %{__sed} -i -e '
        s#/usr/lib/php#%{php_extensiondir}#
        s#/etc/php#%{_sysconfdir}#
        s#@processname@#%{name}-fpm#g
-' $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-fpm $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.conf
+' $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-fpm $RPM_BUILD_ROOT%{_sysconfdir}/fpm.conf
 install -d $RPM_BUILD_ROOT/etc/logrotate.d
 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-fpm
 %endif
@@ -2530,11 +2529,6 @@ install -d $RPM_BUILD_ROOT%{php_data_dir}/tests/php
 install -p run-tests.php $RPM_BUILD_ROOT%{php_data_dir}/tests/php/run-tests.php
 cp -a tests/* $RPM_BUILD_ROOT%{php_data_dir}/tests/php
 
-%if %{with fpm}
-# /var/run/php is in php-dirs, here conflicts with __spec_install_post_check_tmpfiles macro
-rmdir $RPM_BUILD_ROOT/var/run/php
-%endif
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -2729,7 +2723,6 @@ fi
 %attr(755,root,root) %{_sbindir}/%{name}-fpm
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}-fpm
 %attr(754,root,root) /etc/rc.d/init.d/%{name}-fpm
-%{_mandir}/man8/%{name}-fpm.8
 %endif
 
 %files common
This page took 0.075227 seconds and 4 git commands to generate.