]> git.pld-linux.org Git - packages/php.git/commitdiff
add debug bcond to enable zend debug build, do not enable with rpm debug builds auto/th/php71-7.1.16-1
authorElan Ruusamäe <glen@delfi.ee>
Wed, 21 Mar 2018 21:52:57 +0000 (23:52 +0200)
committerElan Ruusamäe <glen@pld-linux.org>
Wed, 28 Mar 2018 14:06:44 +0000 (17:06 +0300)
php.spec

index 3e25ce1481620d11c8028352c1e50993f7e21c91..80692573fae76b906982fa0b899b2a97f0889904 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -34,6 +34,7 @@
 %bcond_with    systemtap       # systemtap/DTrace support
 %bcond_with    tests           # default off; test process very often hangs on builders, approx run time 45m; perform "make test"
 %bcond_with    zts             # Zend Thread Safety
+%bcond_with    debug           # Zend Debug Build
 # - SAPI
 %bcond_without apache2         # disable building Apache 2.x SAPI
 %bcond_without cgi             # disable CGI/FCGI SAPI
@@ -317,7 +318,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                phpdbgver       0.5.0
 
 %define                _zend_zts               %{!?with_zts:0}%{?with_zts:1}
-%define                php_debug               %{!?debug:0}%{?debug:1}
+%define                php_debug               %{!?with_debug:0}%{?with_debug:1}
 
 %if %{with gcov}
 %undefine      with_ccache
@@ -2300,7 +2301,7 @@ for sapi in $sapis; do
        --with-config-file-path=%{_sysconfdir} \
        --with-config-file-scan-dir=%{_sysconfdir}/conf.d \
        --with-system-tzdata \
-       --%{!?debug:dis}%{?debug:en}able-debug \
+       --%{!?with_debug:dis}%{?with_debug:en}able-debug \
        %{?with_zts:--enable-maintainer-zts} \
        --enable-inline-optimization \
        %{__enable_disable bcmath bcmath shared} \
This page took 0.065112 seconds and 4 git commands to generate.