]> git.pld-linux.org Git - packages/php.git/commitdiff
add debug bcond to enable zend debug build, do not enable with rpm debug builds
authorElan Ruusamäe <glen@delfi.ee>
Wed, 21 Mar 2018 21:52:57 +0000 (23:52 +0200)
committerElan Ruusamäe <glen@pld-linux.org>
Wed, 28 Mar 2018 14:07:44 +0000 (17:07 +0300)
php.spec

index b7f0adbdb4ae95cb8b80324fd0b2e1bbb9862ee3..1f0294817c2c0bf52cfc23c36a9763dd5a7ea480 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -37,6 +37,7 @@
 %bcond_with    systemtap       # systemtap/DTrace support
 %bcond_with    tests           # default off; test process very often hangs on builders, approx run time 45m; perform "make test"
 %bcond_with    zts             # Zend Thread Safety
+%bcond_with    debug           # Zend Debug Build
 # - SAPI
 %bcond_without apache1         # disable building Apache 1.3.x SAPI
 %bcond_without apache2         # disable building Apache 2.x SAPI
@@ -343,7 +344,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                phpdbgver       0.4.0
 
 %define                _zend_zts               %{!?with_zts:0}%{?with_zts:1}
-%define                php_debug               %{!?debug:0}%{?debug:1}
+%define                php_debug               %{!?with_debug:0}%{?with_debug:1}
 
 %if %{with gcov}
 %undefine      with_ccache
@@ -2429,7 +2430,7 @@ for sapi in $sapis; do
        --with-config-file-path=%{_sysconfdir} \
        --with-config-file-scan-dir=%{_sysconfdir}/conf.d \
        --with-system-tzdata \
-       --%{!?debug:dis}%{?debug:en}able-debug \
+       --%{!?with_debug:dis}%{?with_debug:en}able-debug \
        %{?with_zts:--enable-maintainer-zts} \
        --enable-inline-optimization \
        %{__enable_disable bcmath bcmath shared} \
This page took 0.042495 seconds and 4 git commands to generate.