]> git.pld-linux.org Git - packages/php.git/commitdiff
up to 5.6.9 auto/th/php56-5.6.9-1
authorElan Ruusamäe <glen@delfi.ee>
Thu, 21 May 2015 18:34:04 +0000 (21:34 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 21 May 2015 18:36:11 +0000 (21:36 +0300)
- fixes for CVE-2015-4024, CVE-2015-4025, CVE-2015-4022, CVE-2015-4026, CVE-2015-4021
- CVE-2015-2325, CVE-2015-2326 (pcrelib) - does not affect pld as using system pcre
- updated php-systzdata.patch to r12
- zip extension up to 1.12.5

php-systzdata.patch
php.spec

index b262faed85d2e4dbcae2c45368a7bbc18712b4df..aa3277c03fda8786cfa584a6beff65d0faec6987 100644 (file)
@@ -2,11 +2,14 @@ Add support for use of the system timezone database, rather
 than embedding a copy.  Discussed upstream but was not desired.
 
 History:
-r10 : make timezone case insensitive
+r12: adapt for upstream changes for new zic
+r11: use canonical names to avoid more case sensitivity issues
+     round lat/long from zone.tab towards zero per builtin db
+r10: make timezone case insensitive
 r9: fix another compile error without --with-system-tzdata configured (Michael Heimpold)
 r8: fix compile error without --with-system-tzdata configured
 r7: improve check for valid timezone id to exclude directories
-r6: fix fd leak in r5, fix country code/BC flag use in 
+r6: fix fd leak in r5, fix country code/BC flag use in
     timezone_identifiers_list() using system db,
     fix use of PECL timezonedb to override system db,
 r5: reverts addition of "System/Localtime" fake tzname.
@@ -17,8 +20,9 @@ r3: fix a crash if /usr/share/zoneinfo doesn't exist (Raphael Geissert)
 r2: add filesystem trawl to set up name alias index
 r1: initial revision
 
---- a/ext/date/lib/parse_tz.c
-+++ b/ext/date/lib/parse_tz.c
+diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/lib/parse_tz.c
+--- php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata     2015-04-30 00:00:18.000000000 +0200
++++ php-5.6.9RC1/ext/date/lib/parse_tz.c       2015-04-30 06:36:47.019617321 +0200
 @@ -20,6 +20,16 @@
  
  #include "timelib.h"
@@ -49,25 +53,18 @@ r1: initial revision
  
  #if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
  # if defined(__LITTLE_ENDIAN__)
-@@ -51,9 +66,14 @@
- static void read_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
+@@ -53,6 +68,10 @@ static int read_preamble(const unsigned
  {
--      /* skip ID */
--      *tzf += 4;
--      
-+        if (memcmp(tzf, "TZif", 4) == 0) {
-+                *tzf += 20;
-+                return;
-+        }
-+        
-+        /* skip ID */
-+        *tzf += 4;
-+                
-       /* read BC flag */
-       tz->bc = (**tzf == '\1');
-       *tzf += 1;
-@@ -256,7 +276,405 @@
+       uint32_t version;
++      if (memcmp(*tzf, "TZif", 4) == 0) {
++              *tzf += 20;
++              return 0;
++      }
+       /* read ID */
+       version = (*tzf)[3] - '0';
+       *tzf += 4;
+@@ -296,7 +315,418 @@ void timelib_dump_tzinfo(timelib_tzinfo
        }
  }
  
@@ -165,7 +162,7 @@ r1: initial revision
 +    /* Round to five decimal place, not because it's a good idea,
 +     * but, because the builtin data uses rounded data, so, match
 +     * that. */
-+    *result = round(v * sign * 100000.0) / 100000.0;
++    *result = trunc(v * sign * 100000.0) / 100000.0;
 +
 +    return p;
 +}
@@ -293,7 +290,7 @@ r1: initial revision
 +{
 +        const timelib_tzdb_index_entry *alpha = first, *beta = second;
 +
-+        return strcmp(alpha->id, beta->id);
++        return strcasecmp(alpha->id, beta->id);
 +}
 +
 +
@@ -431,6 +428,26 @@ r1: initial revision
 +      return S_ISREG(st->st_mode) && st->st_size > 20;
 +}
 +
++/* To allow timezone names to be used case-insensitively, find the
++ * canonical name for this timezone, if possible. */
++static const char *canonical_tzname(const char *timezone)
++{
++    if (timezonedb_system) {
++        timelib_tzdb_index_entry *ent, lookup;
++        
++        lookup.id = (char *)timezone;
++        
++        ent = bsearch(&lookup, timezonedb_system->index,
++                      timezonedb_system->index_size, sizeof lookup,
++                      sysdbcmp);
++        if (ent) {
++            return ent->id;
++        }
++    }
++
++    return timezone;
++}
++
 +/* Return the mmap()ed tzfile if found, else NULL.  On success, the
 + * length of the mapped data is placed in *length. */
 +static char *map_tzfile(const char *timezone, size_t *length)
@@ -444,14 +461,7 @@ r1: initial revision
 +              return NULL;
 +      }
 +
-+    if (system_location_table) {
-+        const struct location_info *li;
-+        if ((li = find_zone_info(system_location_table, timezone)) != NULL) {
-+            /* Use the stored name to avoid case issue */
-+            timezone = li->name;
-+        }
-+    }
-+      snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", timezone);
++      snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", canonical_tzname(timezone));
 +      
 +      fd = open(fname, O_RDONLY);
 +      if (fd == -1) {
@@ -474,11 +484,11 @@ r1: initial revision
  {
        int left = 0, right = tzdb->index_size - 1;
  #ifdef HAVE_SETLOCALE
-@@ -295,36 +713,135 @@
+@@ -335,21 +765,87 @@ static int seek_to_tz_position(const uns
        return 0;
  }
  
-+static int seek_to_tz_position(const unsigned char **tzf, char *timezone, 
++static int seek_to_tz_position(const unsigned char **tzf, char *timezone,
 +                             char **map, size_t *maplen,
 +                             const timelib_tzdb *tzdb)
 +{
@@ -490,15 +500,14 @@ r1: initial revision
 +              if (orig == NULL) {
 +                      return 0;
 +              }
-+              
++
 +              (*tzf) = (unsigned char *)orig ;
 +              *map = orig;
-+                
-+                return 1;
++              return 1;
 +      }
-+       else
++      else
 +#endif
-+       {
++      {
 +              return inmem_seek_to_tz_position(tzf, timezone, tzdb);
 +      }
 +}
@@ -513,11 +522,10 @@ r1: initial revision
 +              tmp->data = NULL;
 +              create_zone_index(tmp);
 +              system_location_table = create_location_table();
-+                fake_data_segment(tmp, system_location_table);
++              fake_data_segment(tmp, system_location_table);
 +              timezonedb_system = tmp;
 +      }
 +
-+                      
 +      return timezonedb_system;
 +#else
        return &timezonedb_builtin;
@@ -541,45 +549,54 @@ r1: initial revision
 -      return (seek_to_tz_position(&tzf, timezone, tzdb));
 +
 +#ifdef HAVE_SYSTEM_TZDATA
-+        if (tzdb == timezonedb_system) {
-+            char fname[PATH_MAX];
-+            struct stat st;
-+
-+            if (timezone[0] == '\0' || strstr(timezone, "..") != NULL) {
-+                      return 0;
-+            }
-+
-+            if (system_location_table) {
-+                if (find_zone_info(system_location_table, timezone) != NULL) {
-+                    /* found in cache */
-+                    return 1;
-+                }
-+            }
-+            
-+            snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", timezone);
-+            
-+            return stat(fname, &st) == 0 && is_valid_tzfile(&st);
-+        }
-+#endif
++      if (tzdb == timezonedb_system) {
++              char fname[PATH_MAX];
++              struct stat st;
++
++              if (timezone[0] == '\0' || strstr(timezone, "..") != NULL) {
++                      return 0;
++              }
 +
++              if (system_location_table) {
++                      if (find_zone_info(system_location_table, timezone) != NULL) {
++                              /* found in cache */
++                              return 1;
++                      }
++              }
++
++              snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", canonical_tzname(timezone));
++
++              return stat(fname, &st) == 0 && is_valid_tzfile(&st);
++      }
++#endif
 +      return (inmem_seek_to_tz_position(&tzf, timezone, tzdb));
  }
  
+ static void skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
+@@ -374,24 +870,54 @@ static void read_64bit_header(const unsi
  timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb)
  {
        const unsigned char *tzf;
 +      char *memmap = NULL;
 +      size_t maplen;
        timelib_tzinfo *tmp;
+       int version;
  
 -      if (seek_to_tz_position(&tzf, timezone, tzdb)) {
 +      if (seek_to_tz_position(&tzf, timezone, &memmap, &maplen, tzdb)) {
                tmp = timelib_tzinfo_ctor(timezone);
  
-               read_preamble(&tzf, tmp);
+               version = read_preamble(&tzf, tmp);
                read_header(&tzf, tmp);
                read_transistions(&tzf, tmp);
                read_types(&tzf, tmp);
+-              if (version == 2) {
+-                      skip_64bit_preamble(&tzf, tmp);
+-                      read_64bit_header(&tzf, tmp);
+-                      skip_64bit_transistions(&tzf, tmp);
+-                      skip_64bit_types(&tzf, tmp);
+-                      skip_posix_string(&tzf, tmp);
+-              }
 -              read_location(&tzf, tmp);
 +
 +#ifdef HAVE_SYSTEM_TZDATA
@@ -607,14 +624,22 @@ r1: initial revision
 +              } else
 +#endif
 +              {
++                      if (version == 2) {
++                              skip_64bit_preamble(&tzf, tmp);
++                              read_64bit_header(&tzf, tmp);
++                              skip_64bit_transistions(&tzf, tmp);
++                              skip_64bit_types(&tzf, tmp);
++                              skip_posix_string(&tzf, tmp);
++                      }
 +                      /* PHP-style - use the embedded info. */
 +                      read_location(&tzf, tmp);
-+              }
++              }
        } else {
                tmp = NULL;
        }
---- a/ext/date/lib/timelib.m4
-+++ b/ext/date/lib/timelib.m4
+diff -up php-5.6.9RC1/ext/date/lib/timelib.m4.systzdata php-5.6.9RC1/ext/date/lib/timelib.m4
+--- php-5.6.9RC1/ext/date/lib/timelib.m4.systzdata     2015-04-30 00:00:18.000000000 +0200
++++ php-5.6.9RC1/ext/date/lib/timelib.m4       2015-04-30 06:32:08.549500385 +0200
 @@ -78,3 +78,17 @@ stdlib.h
  
  dnl Check for strtoll, atoll
index 18f6a4e50c3665081822c5820910eb06d8c6cc0c..c12b4ec03a8679fc172fa96769e921351e4ebb31 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -145,7 +145,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.6.8
+Version:       5.6.9
 Release:       %{rel}%{?with_type_hints:.th}
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -154,7 +154,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 526a5a7f593de632cd9e8546335de8b7
+# Source0-md5: f6b90cd0503310c38e9573bae1eb38c7
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -319,7 +319,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                opcachever      7.0.4-dev
 %define                pharver         2.0.2
 %define                sqlite3ver      0.7-dev
-%define                zipver          1.12.4
+%define                zipver          1.12.5
 %define                phpdbgver       0.4.0
 
 %define                _zend_zts               %{!?with_zts:0}%{?with_zts:1}
This page took 0.067434 seconds and 4 git commands to generate.