]> git.pld-linux.org Git - packages/php.git/commitdiff
keep backups and original files whenever it's so easy
authorTomasz Pala <gotar@pld-linux.org>
Sun, 31 May 2015 12:23:59 +0000 (14:23 +0200)
committerTomasz Pala <gotar@pld-linux.org>
Sun, 31 May 2015 12:23:59 +0000 (14:23 +0200)
php.spec

index 62ffc7c60a1cb727af61415cb5e4f78585b0ff3e..9a97327d2330cad8608e0e6538dd11d3ab643da0 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2789,7 +2789,7 @@ fi
 %service %{name}-fpm restart
 
 %preun fpm
-if [ "$1" = 0 ]; then
+if [ "$1" = "0" ]; then
        %service %{name}-fpm stop
        /sbin/chkconfig --del %{name}-fpm
 fi
@@ -2839,8 +2839,8 @@ for f in /etc/php/*.ini.rpmsave /etc/php/*.d/*.ini.rpmsave; do
        fn=${fn%.rpmsave}
        nf=%{_sysconfdir}/$dn/$fn
        test -f "$nf" || continue
-       cp -vf $nf{,.rpmnew}
-       mv -vf $f $nf
+       cp -vfb $nf{,.rpmnew}
+       cp -vfb $f $nf
        %{__sed} -i -e '
                s#%{_libdir}/php#%{_libdir}/%{name}#
                s#/etc/php#%{_sysconfdir}#
This page took 0.057293 seconds and 4 git commands to generate.