]> git.pld-linux.org Git - packages/php.git/commitdiff
- fix building with mysql 5.7 (ER macro uses unexported array) auto/th/php53-5.3.29-38
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 20 Mar 2018 20:29:04 +0000 (21:29 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 20 Mar 2018 20:29:04 +0000 (21:29 +0100)
- rel 38

mysqli-err.patch [new file with mode: 0644]
php.spec

diff --git a/mysqli-err.patch b/mysqli-err.patch
new file mode 100644 (file)
index 0000000..99e5eac
--- /dev/null
@@ -0,0 +1,29 @@
+--- php-5.4.45/ext/mysqli/mysqli.c.orig        2018-03-20 20:56:38.000000000 +0100
++++ php-5.4.45/ext/mysqli/mysqli.c     2018-03-20 21:15:42.030265770 +0100
+@@ -1376,7 +1376,7 @@
+       }
+       if (!(mysql = (MY_MYSQL *)userdata)) {
+-              LOCAL_INFILE_ERROR_MSG(data->error_msg, ER(CR_UNKNOWN_ERROR));
++              LOCAL_INFILE_ERROR_MSG(data->error_msg, "Unknown MySQL error");
+               return 1;
+       }
+@@ -1423,7 +1423,7 @@
+               int count = (int)php_stream_read(mysql->li_stream, buf, buf_len);
+               if (count < 0) {
+-                      LOCAL_INFILE_ERROR_MSG(data->error_msg, ER(2));
++                      LOCAL_INFILE_ERROR_MSG(data->error_msg, "Can't connect to local MySQL server");
+               }
+               return count;
+@@ -1499,7 +1499,7 @@
+               strlcpy(error_msg, data->error_msg, error_msg_len);
+               return 2000;
+       }
+-      strlcpy(error_msg, ER(CR_OUT_OF_MEMORY), error_msg_len);
++      strlcpy(error_msg, "MySQL client ran out of memory", error_msg_len);
+       return CR_OUT_OF_MEMORY;
+ }
+ /* }}} */
index 19399fcf32255689d3771101355a07dc912342a5..19a3946c95a1161efc7afc4cc2dcbc5153ad9434 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -142,7 +142,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_alternatives
 %endif
 
-%define                rel     37
+%define                rel     38
 %define                orgname php
 %define                ver_suffix 53
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -246,6 +246,7 @@ Patch71:    php-fileinfo.patch
 # Patch71-md5:  771e4934132c5f5c968248c954d1ef6e
 Patch72:       x32-suhosin.patch
 Patch73:       php-bug-68486.patch
+Patch74:       mysqli-err.patch
 # Fixes for security bugs
 # https://repo.webtatic.com/yum/centos/5/SRPMS/repoview/php.html
 # also from RHEL6/CentOS7
@@ -2138,6 +2139,7 @@ gzip -dc %{SOURCE15} | tar xf - -C sapi/
 %patch70 -p1
 %patch71 -p1
 %patch73 -p1
+%patch74 -p1
 
 %patch220 -p1
 
This page took 0.563274 seconds and 4 git commands to generate.