]> git.pld-linux.org Git - packages/php.git/commitdiff
- fix building with db 5.3
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 6 Sep 2012 09:53:44 +0000 (11:53 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 6 Sep 2012 09:53:44 +0000 (11:53 +0200)
php-db.patch [new file with mode: 0644]
php.spec

diff --git a/php-db.patch b/php-db.patch
new file mode 100644 (file)
index 0000000..07032ec
--- /dev/null
@@ -0,0 +1,26 @@
+--- php-5.3.16/ext/dba/config.m4.orig  2012-09-06 11:15:09.743002303 +0200
++++ php-5.3.16/ext/dba/config.m4       2012-09-06 11:28:12.192974701 +0200
+@@ -287,6 +287,14 @@
+       THIS_PREFIX=$i
+       THIS_INCLUDE=$i/db4/db.h
+       break
++    elif test -f "$i/include/db5.3/db.h"; then
++      THIS_PREFIX=$i
++      THIS_INCLUDE=$i/include/db5.3/db.h
++      break
++    elif test -f "$i/include/db5.2/db.h"; then
++      THIS_PREFIX=$i
++      THIS_INCLUDE=$i/include/db5.2/db.h
++      break
+     elif test -f "$i/include/db5.1/db.h"; then
+       THIS_PREFIX=$i
+       THIS_INCLUDE=$i/include/db5.1/db.h
+@@ -329,7 +337,7 @@
+       break
+     fi
+   done
+-  PHP_DBA_DB_CHECK(4, db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
++  PHP_DBA_DB_CHECK(4, db-5.3 db-5.2 db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
+ fi
+ PHP_DBA_STD_RESULT(db4,Berkeley DB4)
index deda7c8d4d4d10dd3b4504597c3cc02aa394620e..690aac4a9819fff55d5d151184254357a81f4901 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -216,6 +216,7 @@ Patch62:    mcrypt-libs.patch
 Patch63:       %{orgname}-mysql-nowarning.patch
 #Patch64:      %{orgname}-m4.patch # not needed on 5.4 branch
 Patch65:       system-libzip.patch
+Patch66:       php-db.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -1927,6 +1928,7 @@ cp -p php.ini-production php.ini
 %patch62 -p1
 %patch63 -p1
 %{?with_system_libzip:%patch65 -p1}
+%patch66 -p1
 %{__rm} -r sapi/litespeed
 gzip -dc %{SOURCE15} | tar xf - -C sapi/
 
This page took 0.05768 seconds and 4 git commands to generate.