]> git.pld-linux.org Git - packages/php.git/commitdiff
- updated patches for 4.2.3
authorPaweł Gołaszewski <blues@pld-linux.org>
Sat, 7 Sep 2002 09:39:45 +0000 (09:39 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-link-libs.patch -> 1.6
    php-mcal-shared-lib.patch -> 1.3
    php-no_php_pcre_in_SAPI_c.patch -> 1.4

php-link-libs.patch
php-mcal-shared-lib.patch
php-no_php_pcre_in_SAPI_c.patch

index 5315c5c9cb85f11eddf9c74f57e9b0921f33b664..785e01cba2988aee5736836287972f7f89653194 100644 (file)
@@ -1,37 +1,13 @@
-diff -urN php-4.2.1RC2.org/configure.in php-4.2.1RC2/configure.in
---- php-4.2.1RC2.org/configure.in      Sat May 11 20:49:22 2002
-+++ php-4.2.1RC2/configure.in  Sat May 11 21:05:41 2002
-@@ -297,6 +297,7 @@
- if test "$php_no_nsl_checks" != "yes"; then
-+AC_CHECK_FUNC(gethostname,[true], [
- AC_CHECK_LIB(nsl, gethostname, [
-  PHP_ADD_LIBRARY(nsl)
-  AC_DEFINE(HAVE_LIBNSL,1,[ ]) ],[
-@@ -304,6 +305,7 @@
-   PHP_ADD_LIBRARY(nsl)
-   AC_DEFINE(HAVE_LIBNSL,1,[ ]) ], [])
- ])
-+])
- fi
-diff -urN php-4.2.1RC2.org/ext/gmp/config.m4 php-4.2.1RC2/ext/gmp/config.m4
---- php-4.2.1RC2.org/ext/gmp/config.m4 Sat May 11 20:49:22 2002
-+++ php-4.2.1RC2/ext/gmp/config.m4     Sat May 11 21:05:41 2002
-@@ -21,5 +21,6 @@
-   PHP_EXTENSION(gmp, $ext_shared)
-   AC_DEFINE(HAVE_GMP, 1, [ ])
--  PHP_ADD_LIBRARY_WITH_PATH(gmp, $GMP_DIR/lib)
-+  PHP_ADD_LIBRARY_WITH_PATH(gmp, $GMP_DIR/lib, GMP_SHARED_LIBADD)
+--- ./ext/gmp/config.m4.org    Mon Jun 24 09:55:32 2002
++++ ./ext/gmp/config.m4        Sat Sep  7 11:02:51 2002
+@@ -23,3 +23,4 @@
+   PHP_SUBST(GMP_SHARED_LIBADD)
+   PHP_ADD_LIBRARY_WITH_PATH(gmp, $GMP_DIR/lib, GMP_SHARED_LIBADD)
  fi
 +PHP_SUBST(GMP_SHARED_LIBADD)
-diff -urN php-4.2.1RC2.org/ext/xslt/config.m4 php-4.2.1RC2/ext/xslt/config.m4
---- php-4.2.1RC2.org/ext/xslt/config.m4        Sat May 11 20:49:24 2002
-+++ php-4.2.1RC2/ext/xslt/config.m4    Sat May 11 21:09:39 2002
-@@ -81,7 +82,7 @@
+--- ./ext/xslt/config.m4.org   Thu May  2 12:24:03 2002
++++ ./ext/xslt/config.m4       Sat Sep  7 11:03:45 2002
+@@ -81,7 +81,7 @@
        found_js=no
        AC_CHECK_LIB(js, JS_GetRuntime, found_js=yes)
        if test "$found_js" = "yes"; then
@@ -40,9 +16,8 @@ diff -urN php-4.2.1RC2.org/ext/xslt/config.m4 php-4.2.1RC2/ext/xslt/config.m4
        fi
      fi
  
-diff -urN php-4.2.1RC2.org/ext/yp/Makefile.in php-4.2.1RC2/ext/yp/Makefile.in
---- php-4.2.1RC2.org/ext/yp/Makefile.in        Sat May 11 20:49:24 2002
-+++ php-4.2.1RC2/ext/yp/Makefile.in    Sat May 11 21:05:41 2002
+--- ./ext/yp/Makefile.in.org   Tue May  2 03:21:26 2000
++++ ./ext/yp/Makefile.in       Sat Sep  7 11:05:11 2002
 @@ -2,5 +2,6 @@
  LTLIBRARY_NAME    = libyp.la
  LTLIBRARY_SOURCES = yp.c
@@ -50,9 +25,8 @@ diff -urN php-4.2.1RC2.org/ext/yp/Makefile.in php-4.2.1RC2/ext/yp/Makefile.in
 +LTLIBRARY_SHARED_LIBADD = $(NSL_SHARED_LIBADD)
  
  include $(top_srcdir)/build/dynlib.mk
-diff -urN php-4.2.1RC2.org/ext/yp/config.m4 php-4.2.1RC2/ext/yp/config.m4
---- php-4.2.1RC2.org/ext/yp/config.m4  Sat May 11 20:49:24 2002
-+++ php-4.2.1RC2/ext/yp/config.m4      Sat May 11 21:05:41 2002
+--- ./ext/yp/config.m4.org     Fri Nov 30 20:00:10 2001
++++ ./ext/yp/config.m4 Sat Sep  7 11:06:31 2002
 @@ -6,8 +6,11 @@
  [  --enable-yp             Include YP support.])
  
@@ -66,3 +40,21 @@ diff -urN php-4.2.1RC2.org/ext/yp/config.m4 php-4.2.1RC2/ext/yp/config.m4
    case $host_alias in
    *solaris*)
      AC_DEFINE(SOLARIS_YP,1,[ ]) ;;
+--- ./configure.in.org Fri Sep  6 01:20:49 2002
++++ ./configure.in     Sat Sep  7 11:01:54 2002
+@@ -292,6 +292,7 @@
+ if test "$php_no_nsl_checks" != "yes"; then
++AC_CHECK_FUNC(gethostname,[true], [
+ AC_CHECK_LIB(nsl, gethostname, [
+  PHP_ADD_LIBRARY(nsl)
+  AC_DEFINE(HAVE_LIBNSL,1,[ ]) ],[
+@@ -299,6 +300,7 @@
+   PHP_ADD_LIBRARY(nsl)
+   AC_DEFINE(HAVE_LIBNSL,1,[ ]) ], [])
+ ])
++])
+ fi
index 1ea548ea0b319bd2082db62ec2492feedf403879..c32cc8ab0ec9689d77dcbb504677c6a6a3b88253 100644 (file)
@@ -1,5 +1,5 @@
---- php-4.2.1/ext/mcal/config.m4.orig  Thu Apr  4 01:04:44 2002
-+++ php-4.2.1/ext/mcal/config.m4       Tue May 14 00:26:25 2002
+--- ./ext/mcal/config.m4.org   Mon Jun 24 13:37:15 2002
++++ ./ext/mcal/config.m4       Sat Sep  7 11:19:45 2002
 @@ -20,7 +20,7 @@
    done
  
@@ -9,18 +9,19 @@
        MCAL_LIBRARY=$i
      fi
    done
-@@ -37,12 +37,12 @@
+@@ -37,13 +37,14 @@
      AC_MSG_ERROR(Unable to locate your libmcal header files - icalroutines.h should be in the directory you specify or in the include/ subdirectory below it - default search location is $MCAL_DEFAULT_SEARCH)
    fi
  
 -  if test ! -f "$MCAL_LIBRARY/libmcal.a"; then
 -    AC_MSG_ERROR(Unable to locate your libmcal library files - libmcal.a should be in the directory you specify or in the lib/ subdirectory below it - default search location is $MCAL_DEFAULT_SEARCH)
-+  if test -z "$MCAL_LIBRARY"; then
++  if test ! -f "$MCAL_LIBRARY"; then
 +    AC_MSG_ERROR(Unable to locate your libmcal library files - libmcal.* should be in the directory you specify or in the lib/ subdirectory below it - default search location is $MCAL_DEFAULT_SEARCH)
    fi
  
    PHP_ADD_INCLUDE($MCAL_INCLUDE)
--  PHP_ADD_LIBRARY_DEFER_WITH_PATH(mcal, $MCAL_LIBRARY, MCAL_SHARED_LIBADD)
+   PHP_ADD_LIBPATH($MCAL_LIBRARY,MCAL_SHARED_LIBADD)
+   PHP_ADD_LIBRARY_DEFER(mcal,[],MCAL_SHARED_LIBADD)
 +  PHP_ADD_LIBRARY_WITH_PATH(mcal, $MCAL_LIBRARY, MCAL_SHARED_LIBADD)
    PHP_SUBST(MCAL_SHARED_LIBADD)
    AC_DEFINE(HAVE_MCAL,1,[ ])
index 2c808d33d58ca65cb2453060658b2a857a560ebd..ecf8072da76885d50553c0796cf91f71de811e16 100644 (file)
@@ -1,29 +1,25 @@
-diff -urN php-4_2_0RC3.org/main/SAPI.c php-4_2_0RC3/main/SAPI.c
---- php-4_2_0RC3.org/main/SAPI.c       Sat Apr 13 01:18:30 2002
-+++ php-4_2_0RC3/main/SAPI.c   Sat Apr 13 01:38:42 2002
+--- ./main/SAPI.c.org  Sat Jul 27 15:15:42 2002
++++ ./main/SAPI.c      Sat Sep  7 11:13:49 2002
 @@ -27,9 +27,6 @@
  #include "SAPI.h"
  #include "ext/standard/php_string.h"
  #include "ext/standard/pageinfo.h"
--#if HAVE_PCRE || HAVE_BUNDLED_PCRE
+-#if (HAVE_PCRE || HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
 -#include "ext/pcre/php_pcre.h"
 -#endif
  #ifdef ZTS
  #include "TSRM.h"
  #endif
-@@ -465,65 +462,8 @@
-                       } else if (!STRCASECMP(header_line, "WWW-Authenticate")) { /* HTTP Authentication */
-                               int newlen;
-                               char *result, *newheader;
--#if HAVE_PCRE || HAVE_BUNDLED_PCRE
--                              zval *repl_temp;
--                              char *ptr = colon_offset+1;
--                              int ptr_len=0, result_len = 0;
--#endif
+@@ -480,62 +477,6 @@
                                SG(sapi_headers).http_response_code = 401; /* authentication-required */
--#if HAVE_PCRE || HAVE_BUNDLED_PCRE
--                              if(PG(safe_mode)) {
+                               if(PG(safe_mode)) 
+-#if (HAVE_PCRE || HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
+-                              {
+-                                      zval *repl_temp;
+-                                      char *ptr = colon_offset+1;
+-                                      int ptr_len=0, result_len = 0;
+-
 -                                      myuid = php_getuid();
 -
 -                                      ptr_len = strlen(ptr);
@@ -74,10 +70,10 @@ diff -urN php-4_2_0RC3.org/main/SAPI.c php-4_2_0RC3/main/SAPI.c
 -                                      efree(repl_temp);
 -                              } 
 -#else
-                               if(PG(safe_mode)) {
+                               {
                                        myuid = php_getuid();
                                        result = emalloc(32);
-@@ -534,7 +474,6 @@
+@@ -546,7 +487,6 @@
                                        sapi_header.header_len = newlen;
                                        efree(result);
                                } 
This page took 0.475805 seconds and 4 git commands to generate.