]> git.pld-linux.org Git - packages/php.git/commitdiff
up to 7.3.0beta3
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 5 Sep 2018 15:38:34 +0000 (18:38 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Wed, 5 Sep 2018 16:32:43 +0000 (19:32 +0300)
php-link-libs.patch
php-pear.patch
php.spec
spl-shared.patch

index c20149ebbfcea3f0cb8070170f69df9b7f3c4241..9a37701f90787b252412b43464ffe3c24a9b90ab 100644 (file)
@@ -8,16 +8,16 @@
  
  PHP_CHECK_FUNC(dlopen, dl)
  if test "$ac_cv_func_dlopen" = "yes"; then
---- php-5.2.0/acinclude.m4.orig        2006-12-22 21:52:13.766461055 +0100
-+++ php-5.2.0/acinclude.m4     2006-12-22 21:52:37.159794165 +0100
-@@ -1740,18 +1740,18 @@
+--- php-7.3.0beta3/acinclude.m4~       2018-08-28 13:26:36.000000000 +0300
++++ php-7.3.0beta3/acinclude.m4        2018-09-05 18:56:49.744106256 +0300
+@@ -1829,18 +1829,18 @@
  dnl Wrapper for AC_CHECK_LIB
  dnl
  AC_DEFUN([PHP_CHECK_LIBRARY], [
 -  save_old_LDFLAGS=$LDFLAGS
 +  save_old_LIBS=$LIBS
    ac_stuff="$5"
-   
    save_ext_shared=$ext_shared
    ext_shared=yes
 -  PHP_EVAL_LIBLINE([$]ac_stuff, LDFLAGS)
index 74a03d64e51f65c26745b302985fdfd6a5c3d8d7..2772cd11b7730b001c2764a1b8186514e87eae2f 100644 (file)
@@ -1,5 +1,5 @@
---- php-5.3.1/configure.ac~    2010-02-19 23:26:13.000000000 +0200
-+++ php-5.3.1/configure.ac     2010-02-19 23:27:58.273207305 +0200
+--- php-7.3.0beta3/configure.ac~       2018-09-05 19:02:49.000000000 +0300
++++ php-7.3.0beta3/configure.ac        2018-09-05 19:04:13.237533903 +0300
 @@ -934,11 +934,6 @@
    with_pear=no
  fi
  PHP_ARG_WITH(pear, [whether to install PEAR],
  [  --with-pear=DIR         Install PEAR in DIR [PREFIX/lib/php]
    --without-pear          Do not install PEAR], DEFAULT, yes)
-@@ -1023,11 +1023,11 @@
-   dnl
-   dnl PEAR dependancies
-   dnl
+@@ -1137,19 +1137,6 @@
+   --without-pear          Do not install PEAR], DEFAULT, yes)
+ if test "$PHP_PEAR" != "no"; then
+-
+-  dnl
+-  dnl PEAR dependencies
+-  dnl
 -  if test "$PHP_XML" = "no"; then
--    pear_error_msg="$pear_error_msg 
+-    pear_error_msg="$pear_error_msg
 -                    PEAR requires XML to be enabled.     Add --enable-xml to the configure line. (or --without-pear)"
 -  fi
 -
-+dnl  if test "$PHP_XML" = "no"; then
-+dnl    pear_error_msg="$pear_error_msg 
-+dnl                    PEAR requires XML to be enabled.     Add --enable-xml to the configure line. (or --without-pear)"
-+dnl  fi
-+dnl
- dnl
- dnl  if test "$PHP_XMLRPC" = "no"; then
- dnl    pear_error_msg="$pear_error_msg 
+-  if test "$pear_error_msg"; then
+-    AC_MSG_ERROR([$pear_error_msg])
+-  fi
+-
+   install_pear="install-pear"
+   PEAR_INSTALLDIR=$PHP_PEAR
 --- php-5.2.6/sapi/cli/config.m4~      2008-11-16 18:35:31.000000000 +0200
 +++ php-5.2.6/sapi/cli/config.m4       2008-11-20 19:04:12.585061299 +0200
 @@ -4,7 +4,7 @@
index 8c61f612c9218de60143d8ed7cdcab090904f34c..01d698d6fb1849467c59fbba4e1a45a48ad61206 100644 (file)
--- a/php.spec
+++ b/php.spec
 %undefine      with_filter
 %endif
 
-%define                subver alpha3
+%define                subver beta3
 %define                orgname php
 %define                ver_suffix 73
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -164,8 +164,8 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 #Source0:      https://php.net/distributions/%{orgname}-%{version}.tar.xz
-Source0:       https://downloads.php.net/~cmb/php-%{version}alpha3.tar.xz
-# Source0-md5: 7abe998a27daf8507b79086b542317f0
+Source0:       https://downloads.php.net/~cmb/php-%{version}%{subver}.tar.xz
+# Source0-md5: fe3e3ac34ba995c56b9f71b458abe248
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -307,9 +307,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir                     %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20180606
-%define                zend_module_api         20180606
-%define                zend_extension_api      320180606
+%define                php_api_version         20180731
+%define                zend_module_api         20180731
+%define                zend_extension_api      320180731
 %define                php_pdo_api_version     20170320
 
 # Extension versions
@@ -3523,8 +3523,7 @@ fi
 
 %files xmlwriter
 %defattr(644,root,root,755)
-%doc ext/xmlwriter/{CREDITS,TODO}
-%doc ext/xmlwriter/examples
+%doc ext/xmlwriter/CREDITS
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/xmlwriter.ini
 %attr(755,root,root) %{php_extensiondir}/xmlwriter.so
 
index a928d0cad36a22d788a1661cc49e6d03f1aa2693..d51ca9bf85b39d224478ff6748cf98c44d13b9a2 100644 (file)
@@ -1,9 +1,9 @@
---- php-7.0/ext/spl/config.m4~ 2015-05-21 17:57:06.000000000 +0300
-+++ php-7.0/ext/spl/config.m4  2015-05-23 11:25:19.609715006 +0300
-@@ -22,6 +22,6 @@
-   CPPFLAGS=$old_CPPFLAGS
-   AC_DEFINE_UNQUOTED(HAVE_PACKED_OBJECT_VALUE, $ac_result, [Whether struct _zend_object_value is packed])
-   AC_DEFINE(HAVE_SPL, 1, [Whether you want SPL (Standard PHP Library) support]) 
+--- php-7.3.0beta3/ext/spl/config.m4~  2018-08-28 13:26:31.000000000 +0300
++++ php-7.3.0beta3/ext/spl/config.m4   2018-09-05 19:06:13.737232662 +0300
+@@ -1,6 +1,6 @@
+ dnl config.m4 for extension SPL
+   AC_DEFINE(HAVE_SPL, 1, [Whether you want SPL (Standard PHP Library) support])
 -  PHP_NEW_EXTENSION(spl, php_spl.c spl_functions.c spl_engine.c spl_iterators.c spl_array.c spl_directory.c spl_exceptions.c spl_observer.c spl_dllist.c spl_heap.c spl_fixedarray.c, no,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
 +  PHP_NEW_EXTENSION(spl, php_spl.c spl_functions.c spl_engine.c spl_iterators.c spl_array.c spl_directory.c spl_exceptions.c spl_observer.c spl_dllist.c spl_heap.c spl_fixedarray.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
    PHP_INSTALL_HEADERS([ext/spl], [php_spl.h spl_array.h spl_directory.h spl_engine.h spl_exceptions.h spl_functions.h spl_iterators.h spl_observer.h spl_dllist.h spl_heap.h spl_fixedarray.h])
This page took 0.818889 seconds and 4 git commands to generate.