]> git.pld-linux.org Git - packages/php.git/commitdiff
php-7.1.0alpha2 (27 Jun 2016)
authorElan Ruusamäe <glen@delfi.ee>
Mon, 4 Jul 2016 11:49:46 +0000 (14:49 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 4 Jul 2016 12:00:03 +0000 (15:00 +0300)
php-fcgi-graceful.patch
php-ini.patch
php.spec

index 505462fa8eefb3452220554a982339631a0a1fff..2540bc3cb044f71057a75ef2fe597bdcf21700a9 100644 (file)
@@ -18,8 +18,8 @@ while ($i < 35) {
 echo "end!<br>\n";
 ?>
 
---- php-7.0.0beta1/sapi/cgi/cgi_main.c~        2015-07-13 16:14:53.000000000 +0300
-+++ php-7.0.0beta1/sapi/cgi/cgi_main.c 2015-07-15 13:51:32.072326529 +0300
+--- php-7.1.0alpha2/sapi/cgi/cgi_main.c~       2016-07-04 14:56:49.000000000 +0300
++++ php-7.1.0alpha2/sapi/cgi/cgi_main.c        2016-07-04 14:58:17.522958766 +0300
 @@ -101,6 +101,9 @@
   */
  static int parent = 1;
@@ -60,11 +60,10 @@ echo "end!<br>\n";
        fcgi_request *request = NULL;
        int repeats = 1;
        int benchmark = 0;
-@@ -2050,10 +2050,13 @@
-                                                */
+@@ -2080,9 +2080,14 @@
                                                parent = 0;
  
--                                              /* don't catch our signals */
+                                               /* don't catch our signals */
 -                                              sigaction(SIGTERM, &old_term, 0);
                                                sigaction(SIGQUIT, &old_quit, 0);
                                                sigaction(SIGINT,  &old_int,  0);
@@ -73,6 +72,7 @@ echo "end!<br>\n";
 +                                              act.sa_flags = 0;
 +                                              act.sa_handler = fastcgi_graceful_shutdown;
 +                                              sigaction(SIGTERM, &act, &old_term);
++
+                                               zend_signal_init();
                                                break;
                                        case -1:
-                                               perror("php (pre-forking)");
index 51709d2be08169935f9b706ba73538d465103ed7..509448ace92a4ca95ebfb6e395dc22adde5b0d8e 100644 (file)
@@ -1,5 +1,5 @@
---- php-7.0.0RC3/php.ini~      2015-09-20 21:20:29.000000000 +0300
-+++ php-7.0.0RC3/php.ini       2015-09-20 21:25:50.349958427 +0300
+--- php-7.1.0alpha2/php.ini~   2016-07-04 14:50:51.000000000 +0300
++++ php-7.1.0alpha2/php.ini    2016-07-04 14:55:32.781046036 +0300
 @@ -82,6 +82,20 @@
  ; much more verbose when it comes to errors. We recommending using the
  ; development version only in development environments as errors shown to
  ;;;;;;;;;;;;;;;;
  ; File Uploads ;
  ;;;;;;;;;;;;;;;;
-@@ -825,46 +825,8 @@
+@@ -824,47 +824,8 @@
  ; If you only provide the name of the extension, PHP will look for it in its
  ; default extension directory.
  ;
 -;extension=php_bz2.dll
 -;extension=php_curl.dll
 -;extension=php_fileinfo.dll
+-;extension=php_ftp.dll
 -;extension=php_gd2.dll
 -;extension=php_gettext.dll
 -;extension=php_gmp.dll
 -;extension=php_tidy.dll
 -;extension=php_xmlrpc.dll
 -;extension=php_xsl.dll
-+; Ideally in PLD Linux you should install appropriate php70-<extension> or
-+; php70-pecl-<extension> package.
++; Ideally in PLD Linux you should install appropriate php71-<extension> or
++; php71-pecl-<extension> package.
  
  ;;;;;;;;;;;;;;;;;;;
  ; Module Settings ;
index 0da53b75c853e1161bfe4c6697d33aa2162d5cf6..fe944cbbb3357d223549de096324a03d01985007 100644 (file)
--- a/php.spec
+++ b/php.spec
 %endif
 
 %define                rel             0.1
-%define                subver  alpha1
+%define                subver  alpha2
 %define                orgname php
 %define                ver_suffix 71
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -155,7 +155,7 @@ License:    PHP 3.01 and Zend and BSD
 Group:         Libraries
 #Source0:      http://php.net/distributions/%{orgname}-%{version}.tar.xz
 Source0:       https://downloads.php.net/~krakjoe/php-%{version}%{subver}.tar.xz
-# Source0-md5: bba5158cf155a63bc6a1daf51b7b34a7
+# Source0-md5: 71e2e66a62ba839868dac762ca54dbee
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -315,7 +315,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jsonver         1.4.0
 %define                pharver         2.0.2
 %define                sqlite3ver      0.7-dev
-%define                zipver          1.13.2
+%define                zipver          1.13.3
 %define                phpdbgver       0.5.0
 
 %define                _zend_zts               %{!?with_zts:0}%{?with_zts:1}
This page took 0.057396 seconds and 4 git commands to generate.