]> git.pld-linux.org Git - packages/php.git/commitdiff
use alternatives for php-fpm binary
authorElan Ruusamäe <glen@delfi.ee>
Mon, 21 Nov 2016 17:11:00 +0000 (19:11 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 22 Nov 2016 10:12:17 +0000 (12:12 +0200)
php.spec

index af3fb91a7175b9fa88580f502cc9960c21aaced7..44d992cc7bb35dba78f922e8fae78922f04d3424 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -482,6 +482,7 @@ Requires(postun):   /usr/sbin/userdel
 Requires(pre): /bin/id
 Requires(pre): /usr/sbin/useradd
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      alternatives
 Requires:      php-dirs >= 1.4-2
 Requires:      rc-scripts
 Provides:      php(fcgi)
@@ -2595,6 +2596,9 @@ cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-fpm
 %{__sed} -i -e '/su/d' $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-fpm
 %endif
 
+# touch for ghost for alternatives
+touch $RPM_BUILD_ROOT%{_sbindir}/php-fpm
+
 %{__sed} -i -e '
        s#/usr/lib/php#%{php_extensiondir}#
        s#/etc/php/#%{_sysconfdir}/#
@@ -2692,11 +2696,13 @@ fi
 %post fpm
 /sbin/chkconfig --add %{name}-fpm
 %service %{name}-fpm restart
+update-alternatives --install %{_sbindir}/php-fpm php-fpm %{_sbindir}/php%{ver_suffix}-fpm %{ver_suffix} || :
 
 %preun fpm
 if [ "$1" = "0" ]; then
        %service %{name}-fpm stop
        /sbin/chkconfig --del %{name}-fpm
+       update-alternatives --remove php-fpm %{_sbindir}/php-fpm || :
 fi
 
 %postun fpm
@@ -2913,6 +2919,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-fpm.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-fpm.d/www.conf
 %attr(755,root,root) %{_sbindir}/%{name}-fpm
+%ghost %{_sbindir}/php-fpm
 %{_mandir}/man8/%{name}-fpm.8*
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}-fpm
 %attr(754,root,root) /etc/rc.d/init.d/%{name}-fpm
This page took 0.062247 seconds and 4 git commands to generate.