]> git.pld-linux.org Git - packages/php.git/commitdiff
update shared patches
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 20 Jul 2017 04:43:12 +0000 (07:43 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Thu, 20 Jul 2017 04:47:59 +0000 (07:47 +0300)
pcre-shared.patch
php.spec
spl-shared.patch

index 8fa14f9b79e8e67ac4a0aeaf5b8a58ac83380d49..fc3e6d1be32e586f2ffc918f959e674607e3e2b9 100644 (file)
  
        zend_llist_destroy(&extension_lists.engine);
        zend_llist_destroy(&extension_lists.functions);
+--- php-5.3.1/ext/phar/Makefile.frag~  2009-07-23 15:48:04.000000000 +0000
++++ php-5.3.1/ext/phar/Makefile.frag   2009-11-30 16:10:29.687175948 +0000
+@@ -10,7 +10,7 @@
+               $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \
+               if test "x$(PHP_MODULES)" != "x"; then \
+               $(top_srcdir)/build/shtool echo -n -- " -d extension_dir=$(top_builddir)/modules"; \
+-              for i in spl bz2 zlib phar; do \
++              for i in pcre spl bz2 zlib phar; do \
+                       if test -f "$(top_builddir)/modules/$$i.la"; then \
+                               . $(top_builddir)/modules/$$i.la; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
+                       fi; \
index f46cb2d81a144e3eecb385df575a40b53abadbb3..df3bf77c3818d3b20d87de947eb14335d65aa0b2 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -3,6 +3,7 @@
 # - package ext/sodium https://github.com/php/php-src/pull/2560
 # - --with-password-argon2 https://wiki.php.net/rfc/argon2_password_hash
 # - zip: read/write encrypted archive, relying on libzip 1.2.0,
+# - Use of bundled libzip is deprecated, --with-libzip option is recommended.
 # TODO 5.6:
 # - enable --with-fpm-systemd, but ensure it checks for sd_booted()
 # - build with system libgd 2.1, see 73c5128
@@ -155,7 +156,7 @@ Summary(ru.UTF-8):  PHP Версии 7 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
 Version:       7.2.0
-Release:       0.1
+Release:       0.3
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
index cf0fc4ed436bb2e539d6ffded83048d00534063c..a928d0cad36a22d788a1661cc49e6d03f1aa2693 100644 (file)
@@ -8,61 +8,6 @@
 +  PHP_NEW_EXTENSION(spl, php_spl.c spl_functions.c spl_engine.c spl_iterators.c spl_array.c spl_directory.c spl_exceptions.c spl_observer.c spl_dllist.c spl_heap.c spl_fixedarray.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
    PHP_INSTALL_HEADERS([ext/spl], [php_spl.h spl_array.h spl_directory.h spl_engine.h spl_exceptions.h spl_functions.h spl_iterators.h spl_observer.h spl_dllist.h spl_heap.h spl_fixedarray.h])
    PHP_ADD_EXTENSION_DEP(spl, pcre, true)
---- php-5.3.1/ext/spl/spl_iterators.c~ 2009-07-04 20:31:27.000000000 +0000
-+++ php-5.3.1/ext/spl/spl_iterators.c  2009-11-27 16:35:33.729087793 +0000
-@@ -58,7 +58,13 @@
- PHPAPI zend_class_entry *spl_ce_AppendIterator;
- PHPAPI zend_class_entry *spl_ce_RegexIterator;
- PHPAPI zend_class_entry *spl_ce_RecursiveRegexIterator;
-+#if COMPILE_DL_SPL
-+#undef spl_ce_Countable
-+zend_class_entry *spl_ce_Countable; // real instance
-+extern PHPAPI zend_class_entry *spl_ce_Countable_p; // external one
-+#else
- PHPAPI zend_class_entry *spl_ce_Countable;
-+#endif
- PHPAPI zend_class_entry *spl_ce_RecursiveTreeIterator;
- ZEND_BEGIN_ARG_INFO(arginfo_recursive_it_void, 0)
-@@ -3286,6 +3292,10 @@
-       REGISTER_SPL_STD_CLASS_EX(EmptyIterator, NULL, spl_funcs_EmptyIterator);
-       REGISTER_SPL_ITERATOR(EmptyIterator);
-+#if COMPILE_DL_SPL
-+      spl_ce_Countable_p = spl_ce_Countable;
-+#endif
-+
-       REGISTER_SPL_SUB_CLASS_EX(RecursiveTreeIterator, RecursiveIteratorIterator, spl_RecursiveTreeIterator_new, spl_funcs_RecursiveTreeIterator);
-       REGISTER_SPL_CLASS_CONST_LONG(RecursiveTreeIterator, "BYPASS_CURRENT",      RTIT_BYPASS_CURRENT);
-       REGISTER_SPL_CLASS_CONST_LONG(RecursiveTreeIterator, "BYPASS_KEY",          RTIT_BYPASS_KEY);
---- php-5.4.0alpha3/ext/spl/spl_iterators.h~   2011-07-27 11:48:08.000000000 +0300
-+++ php-5.4.0alpha3/ext/spl/spl_iterators.h    2011-08-08 00:12:10.892993117 +0300
-@@ -51,7 +51,12 @@
- extern PHPAPI zend_class_entry *spl_ce_AppendIterator;
- extern PHPAPI zend_class_entry *spl_ce_RegexIterator;
- extern PHPAPI zend_class_entry *spl_ce_RecursiveRegexIterator;
-+#if COMPILE_DL_SPL
-+#define spl_ce_Countable spl_ce_Countable_p
-+extern PHPAPI zend_class_entry *spl_ce_Countable_p;
-+#else
- extern PHPAPI zend_class_entry *spl_ce_Countable;
-+#endif
- extern PHPAPI zend_class_entry *spl_ce_CallbackFilterIterator;
- extern PHPAPI zend_class_entry *spl_ce_RecursiveCallbackFilterIterator;
---- php-7.1.0alpha2/ext/standard/array.c~      2016-07-04 17:52:16.000000000 +0300
-+++ php-7.1.0alpha2/ext/standard/array.c       2016-07-04 18:54:43.937173429 +0300
-@@ -48,6 +48,10 @@
- #include "zend_smart_str.h"
- #include "ext/spl/spl_array.h"
-+#if COMPILE_DL_SPL
-+PHPAPI zend_class_entry *spl_ce_Countable_p = NULL; // external one
-+#endif
-+
- /* {{{ defines */
- #define EXTR_OVERWRITE                        0
- #define EXTR_SKIP                             1
 --- php-7.1.0alpha1/ext/pdo/pdo.c~     2016-06-07 23:56:47.000000000 +0300
 +++ php-7.1.0alpha1/ext/pdo/pdo.c      2016-06-13 23:24:51.238259131 +0300
 @@ -117,7 +117,9 @@
@@ -82,7 +27,7 @@
                if test "x$(PHP_MODULES)" != "x"; then \
                $(top_srcdir)/build/shtool echo -n -- " -d extension_dir=$(top_builddir)/modules"; \
 -              for i in bz2 zlib phar; do \
-+              for i in pcre spl bz2 zlib phar; do \
++              for i in spl bz2 zlib phar; do \
                        if test -f "$(top_builddir)/modules/$$i.la"; then \
                                . $(top_builddir)/modules/$$i.la; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
                        fi; \
This page took 0.081143 seconds and 4 git commands to generate.