]> git.pld-linux.org Git - packages/php.git/commitdiff
- rel 2; fix bug 60598 auto/th/php-5.3.27-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 29 Aug 2013 13:53:56 +0000 (15:53 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 29 Aug 2013 13:53:56 +0000 (15:53 +0200)
php-bug-60598.patch [new file with mode: 0644]
php.spec

diff --git a/php-bug-60598.patch b/php-bug-60598.patch
new file mode 100644 (file)
index 0000000..613889f
--- /dev/null
@@ -0,0 +1,16 @@
+diff --git a/Zend/zend_objects_API.c b/Zend/zend_objects_API.c
+index 1fe5d0c..b5dd48f 100644
+--- a/Zend/zend_objects_API.c
++++ b/Zend/zend_objects_API.c
+@@ -57,6 +57,11 @@ ZEND_API void zend_objects_store_call_destructors(zend_objects_store *objects TS
+                                       obj->dtor(obj->object, i TSRMLS_CC);
+                                       obj = &objects->object_buckets[i].bucket.obj;
+                                       obj->refcount--;
++
++                                      if (obj->refcount == 0) {
++                                              /* in case gc_collect_cycle is triggered before free_storage */
++                                              GC_REMOVE_ZOBJ_FROM_BUFFER(obj);
++                                      }
+                               }
+                       }
+               }
index 6cfe67e9855294da5c9a520c2e1b91ebd6951c97..3633e03866dc640afc08243fd0e22ba914bf8a12 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -119,7 +119,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %endif
 %endif
 
-%define                rel     1
+%define                rel     2
 %define                orgname php
 %define                ver_suffix 53
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -193,6 +193,7 @@ Patch44:    %{orgname}-include_path.patch
 Patch45:       %{orgname}-imap-annotations.patch
 Patch46:       %{orgname}-imap-myrights.patch
 Patch47:       suhosin.patch
+Patch48:       php-bug-60598.patch
 Patch49:       %{orgname}-m4-divert.patch
 Patch50:       extension-shared-optional-dep.patch
 Patch51:       spl-shared.patch
@@ -1950,6 +1951,7 @@ cp -p php.ini-production php.ini
 %if %{with suhosin}
 %patch47 -p1
 %endif
+%patch48 -p1
 %patch49 -p1
 %patch50 -p1
 %patch51 -p1
This page took 0.078929 seconds and 4 git commands to generate.