]> git.pld-linux.org Git - packages/php.git/commitdiff
fix crash in zif_exif_read_data on ac-amd64 auto/ac/php-5.2.17-20130717.2 auto/th/php52-5.2.17-20130717.2
authorElan Ruusamäe <glen@delfi.ee>
Tue, 22 Oct 2013 13:19:48 +0000 (16:19 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 22 Oct 2013 13:31:19 +0000 (16:31 +0300)
exif-crash-bug-36.patch [new file with mode: 0644]
php.spec

diff --git a/exif-crash-bug-36.patch b/exif-crash-bug-36.patch
new file mode 100644 (file)
index 0000000..2deb983
--- /dev/null
@@ -0,0 +1,13 @@
+https://code.google.com/p/php52-backports/issues/detail?id=36
+fix crashes on amd64 on ac (glibc 2.3.6)
+--- php-5.2.17/ext/exif/exif.c~        2013-10-22 16:16:26.000000000 +0300
++++ php-5.2.17/ext/exif/exif.c 2013-10-22 16:16:29.959714312 +0300
+@@ -2746,7 +2746,7 @@
+ {
+       int de, i=0, section_index = SECTION_MAKERNOTE;
+       int NumDirEntries, old_motorola_intel;
+-      size_t offset_diff;
++      int offset_diff;
+       const maker_note_type *maker_note;
+       char *dir_start;
index 58fbf94ee82fb9c2adcc11391d0215881227762a..bcefee2dac370318b3e00fee0f9918a1cd53788b 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -111,7 +111,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %define                magic_mime      /usr/share/misc/magic.mime
 %endif
 
-%define                rel             1
+%define                rel             2
 %define                orgname php
 %define                ver_suffix 52
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -214,6 +214,7 @@ Patch67:    php-db.patch
 Patch69:       bug-50563.patch
 Patch70:       php-crypt-null.patch
 Patch71:       php-apache24.patch
+Patch72:       exif-crash-bug-36.patch
 # CENTALT patches
 # Backport from 5.3.6
 Patch311:      php-5.3.6-bug-47435.patch
@@ -1927,6 +1928,7 @@ done
 %patch69 -p4
 %patch70 -p1
 %patch71 -p1
+%patch72 -p1
 
 # Bugfix backport from 5.3.6
 %patch311 -p1 -b .bug-47435
This page took 0.059566 seconds and 4 git commands to generate.