]> git.pld-linux.org Git - packages/php.git/commitdiff
- don't require mime magic file to be present at build time; libtool 2.2 support
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 16 Jun 2008 08:15:36 +0000 (08:15 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-libtool.patch -> 1.6
    php-mime_magic.patch -> 1.1
    php.spec -> 1.723

php-libtool.patch [new file with mode: 0644]
php-mime_magic.patch [new file with mode: 0644]
php.spec

diff --git a/php-libtool.patch b/php-libtool.patch
new file mode 100644 (file)
index 0000000..380cd0a
--- /dev/null
@@ -0,0 +1,20 @@
+--- php/scripts/phpize.in.org  2008-06-16 10:03:28.882568639 +0200
++++ php/scripts/phpize.in      2008-06-16 10:04:37.424018256 +0200
+@@ -8,7 +8,7 @@
+ builddir="`pwd`"
+ SED="@SED@"
+-FILES_BUILD="mkdep.awk scan_makefile_in.awk shtool libtool.m4"
++FILES_BUILD="mkdep.awk scan_makefile_in.awk shtool libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
+ FILES="acinclude.m4 Makefile.global config.sub config.guess ltmain.sh run-tests*.php"
+ CLEAN_FILES="$FILES *.o *.lo *.la .deps .libs/ build/ include/ modules/ install-sh \
+       mkinstalldirs missing config.nice config.sub config.guess configure configure.in \
+@@ -127,7 +127,7 @@
+  
+   (cd "$phpdir" && cp $FILES_BUILD "$builddir"/build)
+   (cd "$phpdir" && cp $FILES "$builddir")
+-  (cd "$builddir" && cat acinclude.m4 ./build/libtool.m4 > aclocal.m4)
++  (cd "$builddir" && cat acinclude.m4 ./build/{libtool,lt~obsolete,ltoptions,ltsugar,ltversion}.m4 > aclocal.m4)
+ }
+ phpize_replace_prefix()
diff --git a/php-mime_magic.patch b/php-mime_magic.patch
new file mode 100644 (file)
index 0000000..c5128c6
--- /dev/null
@@ -0,0 +1,11 @@
+--- php-5.2.6/ext/mime_magic/config.m4 2007-07-03 19:25:34.000000000 +0200
++++ php-5.2.6.new/ext/mime_magic/config.m4     2008-06-16 09:32:48.996084697 +0200
+@@ -18,8 +18,6 @@
+   if test "$PHP_MIME_MAGIC" != "yes"; then
+     if test -f $PHP_MIME_MAGIC; then
+       PHP_MIME_MAGIC_FILE_PATH=$PHP_MIME_MAGIC
+-    else
+-      AC_MSG_ERROR([File '$PHP_MIME_MAGIC' not found!])
+     fi
+   else
+     MAGIC_MIME_LOCATIONS="/usr/local/apache/conf/magic /usr/local/etc/apache/conf/magic /etc/apache/magic /etc/httpd/conf/magic /usr/share/magic.mime /usr/share/misc/magic.mime /etc/magic.mime"
index f35d074b3cb33120c3b91056635e679ae7528194..bc7de27e29b2f71d3a85924e131d5c41478090f5 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -73,7 +73,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel 5
+%define                rel 5.1
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -134,7 +134,8 @@ Patch32:    %{name}-apr-apu.patch
 Patch33:       %{name}-fcgi-error_log-no-newlines.patch
 Patch34:       %{name}-curl-limit-speed.patch
 Patch35:       %{name}-ac.patch
-
+Patch36:       %{name}-mime_magic.patch
+Patch37:       %{name}-libtool.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -1598,6 +1599,8 @@ patch -p1 < %{PATCH22} || exit 1
 %patch33 -p1
 %patch34 -p1
 %patch35 -p1
+%patch36 -p1
+%patch37 -p1
 
 # conflict seems to be resolved by recode patches
 rm -f ext/recode/config9.m4
@@ -1949,7 +1952,9 @@ mv $RPM_BUILD_ROOT%{_sysconfdir}/{conf.d/{ncurses,pcntl,readline}.ini,cli.d}
 
 # use system automake and {lib,sh}tool
 ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_libdir}/php/build
-ln -snf %{_aclocaldir}/libtool.m4 $RPM_BUILD_ROOT%{_libdir}/php/build
+for i in libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4; do
+       ln -snf %{_aclocaldir}/libtool.m4 $RPM_BUILD_ROOT%{_libdir}/php/build
+done
 ln -snf %{_datadir}/libtool/config/ltmain.sh $RPM_BUILD_ROOT%{_libdir}/php/build
 ln -snf %{_bindir}/shtool $RPM_BUILD_ROOT%{_libdir}/php/build
 
This page took 0.043421 seconds and 4 git commands to generate.