]> git.pld-linux.org Git - packages/php.git/commitdiff
- added some --with-*-dir=shared and changed link-libs patch to fix
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 3 Aug 2001 16:45:42 +0000 (16:45 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  gd.so and gmp.so linking (link libraries to module, not libphp_common)
- release 3

Changed files:
    php-link-libs.patch -> 1.3
    php.spec -> 1.99

php-link-libs.patch
php.spec

index fe2250ccdd4525bf5196e8d151664b01088889e9..cc0d885a04118b76a5e52060a52f063bcce593cb 100644 (file)
  
  fi
  
+--- php-4.0.6.orig/ext/gmp/config.m4   Tue Mar 27 22:34:27 2001
++++ php-4.0.6/ext/gmp/config.m4        Fri Aug  3 15:34:22 2001
+@@ -23,5 +23,6 @@
+   PHP_EXTENSION(gmp, $ext_shared)
+   AC_DEFINE(HAVE_GMP, 1, [ ])
+-  PHP_ADD_LIBRARY_WITH_PATH(gmp, $GMP_DIR/lib)
++  PHP_ADD_LIBRARY_WITH_PATH(gmp, $GMP_DIR/lib, GMP_SHARED_LIBADD)
+ fi
++PHP_SUBST(GMP_SHARED_LIBADD)
index b48aca50c3873f61399afe3b9c1e250e66303c36..ada9c06ad7b43d99d48513d3e896c11545639315 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -16,7 +16,7 @@ Summary(fr):  Le langage de script embarque-HTML PHP pour Apache
 Summary(pl):   Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache
 Name:          php
 Version:       4.0.6
-Release:       2
+Release:       3
 Epoch:         1
 Group:         Libraries
 Group(de):     Libraries
@@ -34,22 +34,24 @@ Patch0:             %{name}-imap.patch
 Patch1:                %{name}-mysql-socket.patch
 Patch2:                %{name}-mail.patch
 Patch3:                %{name}-link-libs.patch
-Patch4:                %{name}-DESTDIR.patch
-Patch5:                %{name}-gd-shared.patch
+#Patch4:               %{name}-DESTDIR.patch
+#Patch5:               %{name}-gd-shared.patch
 Patch6:                %{name}-session-path.patch
-Patch7:                %{name}-libtool_version_check_fix.patch
-Patch8:                %{name}-pdflib.patch
+#Patch7:               %{name}-libtool_version_check_fix.patch
+#Patch8:               %{name}-pdflib.patch
 Patch9:                %{name}-am_ac_lt.patch
 Patch10:       %{name}-fastcgi.patch
 Patch11:       %{name}-shared.patch
 Patch12:       %{name}-ac250.patch
 Patch13:       %{name}-pearinstall.patch
+#Patch14:      %{name}-linking.patch
 Icon:          php4.gif
 URL:           http://www.php.net/
 BuildRequires: apache(EAPI)-devel
 BuildRequires: zip
 BuildRequires: bison
 BuildRequires: flex
+BuildRequires: perl
 BuildRequires: db3-devel >= 3.1.17
 BuildRequires: freetype-devel >= 2.0
 BuildRequires: gd-devel >= 2.0.1
@@ -759,9 +761,9 @@ PreReq:             %{name}-common = %{version}
 This is a dynamic shared object (DSO) for Apache that will add curl
 support to PHP.
 
-#%description curl -l pl
-#Modu³ PHP umo¿liwiaj±cy korzystanie z biblioteki curl.
-#
+%description curl -l pl
+Modu³ PHP umo¿liwiaj±cy korzystanie z biblioteki curl.
+
 #%package xslt
 #Summary:      xslt extension module for PHP
 #Summary(pl):  Modu³ xslt dla PHP
@@ -808,6 +810,7 @@ support to PHP.
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
+#%patch14 -p1
 
 %build
 CFLAGS="%{rpmcflags} -DEAPI -I/usr/X11R6/include"; export CFLAGS
@@ -841,7 +844,12 @@ for i in cgi apxs ; do
        --with-mysql=shared,/usr \
        --with-mysql-sock=/var/lib/mysql/mysql.sock \
        --with-gd=shared \
+       --with-jpeg-dir=shared \
+       --with-zlib-dir=shared \
+       --with-png-dir=shared \
        --enable-gd-native-ttf \
+       --with-freetype-dir=shared \
+       --with-t1lib=shared \
        --with-dbase=shared \
        --with-filepro=shared \
        --enable-ftp=shared \
@@ -856,8 +864,6 @@ for i in cgi apxs ; do
        --with-mm \
        --with-pcre-regex=shared \
        --enable-posix=shared \
-       --with-freetype-dir=shared \
-       --with-t1lib \
        --with-recode=shared \
        --enable-ucd-snmp-hack \
        --enable-dba=shared \
This page took 0.056011 seconds and 4 git commands to generate.