]> git.pld-linux.org Git - packages/php.git/commitdiff
7.2.0alpha3
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 6 Jul 2017 14:59:55 +0000 (17:59 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Mon, 10 Jul 2017 20:21:16 +0000 (23:21 +0300)
fix-test-run.patch
libtool-tag.patch
pcre-shared.patch
php-include_path.patch
php-ini.patch
php-link-libs.patch
php-no_pear_install.patch
php-pear.patch
php-shared.patch
php.spec

index 42afec5dfe8d8840a79ec54dadb8478c57cb2330..bd3c3d7df0a98473f9eede0135cb1a9744eb7830 100644 (file)
@@ -1,5 +1,5 @@
---- php-5.4.0alpha2/configure.in~      2011-08-07 12:43:31.000000000 +0300
-+++ php-5.4.0alpha2/configure.in       2011-08-07 12:44:11.495394662 +0300
+--- php-5.4.0alpha2/configure.ac~      2011-08-07 12:43:31.000000000 +0300
++++ php-5.4.0alpha2/configure.ac       2011-08-07 12:44:11.495394662 +0300
 @@ -1271,6 +1271,11 @@
    ;;
  esac
index 951fd1eeac2f9d316a6b7ddd4551dc4cf852e4bb..d7e5400e48747e6224e25ae172ce70357bccbcb0 100644 (file)
@@ -1,5 +1,5 @@
---- php-5.6.0RC4/configure.in~ 2014-08-20 16:08:27.000000000 +0300
-+++ php-5.6.0RC4/configure.in  2014-08-21 20:49:14.693072513 +0300
+--- php-5.6.0RC4/configure.ac~ 2014-08-20 16:08:27.000000000 +0300
++++ php-5.6.0RC4/configure.ac  2014-08-21 20:49:14.693072513 +0300
 @@ -1408,6 +1408,9 @@
  dnl libtool 1.4.3 needs this.
  PHP_SET_LIBTOOL_VARIABLE([--preserve-dup-deps])
index ae69ebdac93a52951525ebdc4f3020d14b6a2c5d..8fa14f9b79e8e67ac4a0aeaf5b8a58ac83380d49 100644 (file)
      PHP_ADD_BUILD_DIR($ext_builddir/pcrelib)
      PHP_INSTALL_HEADERS([ext/pcre], [php_pcre.h pcrelib/])
      AC_DEFINE(HAVE_BUNDLED_PCRE, 1, [ ])
---- php-7.0/ext/pcre/php_pcre.h~       2015-05-21 17:57:06.000000000 +0300
-+++ php-7.0/ext/pcre/php_pcre.h        2015-05-24 14:56:27.528425546 +0300
+--- php-7.2.0alpha3/ext/pcre/php_pcre.h~       2017-07-04 12:26:40.000000000 +0300
++++ php-7.2.0alpha3/ext/pcre/php_pcre.h        2017-07-07 01:45:58.017098044 +0300
 @@ -34,7 +34,12 @@
  #endif
  
- PHPAPI zend_string *php_pcre_replace(zend_string *regex, zend_string *subject_str, char *subject, int subject_len, zval *replace_val, int is_callable_replace, int limit, int *replace_count);
+ PHPAPI zend_string *php_pcre_replace(zend_string *regex, zend_string *subject_str, char *subject, int subject_len, zend_string *replace_str, int limit, int *replace_count);
 +#if COMPILE_DL_PCRE
 +#define pcre_get_compiled_regex pcre_get_compiled_regex_p
 +extern PHPAPI pcre* (*pcre_get_compiled_regex)(zend_string *regex, pcre_extra **extra, int *options);
index a1c3afeb6c9e4bf06f6492ceb9c133a557b6608e..d956cc7d56a98dc562a0fe002f83f6a452245e2f 100644 (file)
@@ -1,5 +1,5 @@
---- php-5.2.0/configure.in.includedir
-+++ php-5.2.0/configure.in
+--- php-5.2.0/configure.ac.includedir
++++ php-5.2.0/configure.ac
 @@ -1101,7 +1101,7 @@
  EXPANDED_DATADIR=$datadir
  EXPANDED_PHP_CONFIG_FILE_PATH=`eval echo "$PHP_CONFIG_FILE_PATH"`
index 565546655596a9a57b2793536c7f2c60318b169d..0a110e782feee3ea19376da46a2035983ecea764 100644 (file)
@@ -1,5 +1,5 @@
---- php-7.1.0RC3/php.ini~      2016-10-04 18:47:57.000000000 +0300
-+++ php-7.1.0RC3/php.ini       2016-10-04 18:50:05.861335161 +0300
+--- php-7.2.0alpha3/php.ini~   2017-07-06 18:09:13.000000000 +0300
++++ php-7.2.0alpha3/php.ini    2017-07-07 01:34:23.339507466 +0300
 @@ -82,6 +82,20 @@
  ; much more verbose when it comes to errors. We recommending using the
  ; development version only in development environments as errors shown to
  ;;;;;;;;;;;;;;;;
  ; File Uploads ;
  ;;;;;;;;;;;;;;;;
-@@ -824,47 +824,8 @@
- ; If you only provide the name of the extension, PHP will look for it in its
- ; default extension directory.
+@@ -838,47 +838,8 @@
+ ; deprecated in a future PHP major version. So, when it is possible, please
+ ; move to the new ('extension=<ext>) syntax.
  ;
--; Windows Extensions
--; Note that ODBC support is built in, so no dll is needed for it.
--; Note that many DLL files are located in the extensions/ (PHP 4) ext/ (PHP 5+)
--; extension folders as well as the separate PECL DLL download (PHP 5+).
--; Be sure to appropriately set the extension_dir directive.
+-; Notes for Windows environments :
 -;
--;extension=php_bz2.dll
--;extension=php_curl.dll
--;extension=php_fileinfo.dll
--;extension=php_ftp.dll
--;extension=php_gd2.dll
--;extension=php_gettext.dll
--;extension=php_gmp.dll
--;extension=php_intl.dll
--;extension=php_imap.dll
--;extension=php_interbase.dll
--;extension=php_ldap.dll
--;extension=php_mbstring.dll
--;extension=php_exif.dll      ; Must be after mbstring as it depends on it
--;extension=php_mysqli.dll
--;extension=php_oci8_12c.dll  ; Use with Oracle Database 12c Instant Client
--;extension=php_openssl.dll
--;extension=php_pdo_firebird.dll
--;extension=php_pdo_mysql.dll
--;extension=php_pdo_oci.dll
--;extension=php_pdo_odbc.dll
--;extension=php_pdo_pgsql.dll
--;extension=php_pdo_sqlite.dll
--;extension=php_pgsql.dll
--;extension=php_shmop.dll
+-; - ODBC support is built in, so no dll is needed for it.
+-; - Many DLL files are located in the extensions/ (PHP 4) or ext/ (PHP 5+)
+-;   extension folders as well as the separate PECL DLL download (PHP 5+).
+-;   Be sure to appropriately set the extension_dir directive.
+-;
+-;extension=bz2
+-;extension=curl
+-;extension=fileinfo
+-;extension=gd2
+-;extension=gettext
+-;extension=gmp
+-;extension=intl
+-;extension=imap
+-;extension=interbase
+-;extension=ldap
+-;extension=mbstring
+-;extension=exif      ; Must be after mbstring as it depends on it
+-;extension=mysqli
+-;extension=oci8_12c  ; Use with Oracle Database 12c Instant Client
+-;extension=openssl
+-;extension=pdo_firebird
+-;extension=pdo_mysql
+-;extension=pdo_oci
+-;extension=pdo_odbc
+-;extension=pdo_pgsql
+-;extension=pdo_sqlite
+-;extension=pgsql
+-;extension=shmop
 -
 -; The MIBS data available in the PHP distribution must be installed.
 -; See http://www.php.net/manual/en/snmp.installation.php
--;extension=php_snmp.dll
+-;extension=snmp
 -
--;extension=php_soap.dll
--;extension=php_sockets.dll
--;extension=php_sqlite3.dll
--;extension=php_tidy.dll
--;extension=php_xmlrpc.dll
--;extension=php_xsl.dll
-+; Ideally in PLD Linux you should install appropriate php71-<extension> or
-+; php71-pecl-<extension> package.
+-;extension=soap
+-;extension=sockets
+-;extension=sqlite3
+-;extension=tidy
+-;extension=xmlrpc
+-;extension=xsl
++; Ideally in PLD Linux you should install appropriate php72-<extension> or
++; php72-pecl-<extension> package.
  
  ;;;;;;;;;;;;;;;;;;;
  ; Module Settings ;
index 23a7acc0073fe62566c735c7b013cdf48dba450a..c20149ebbfcea3f0cb8070170f69df9b7f3c4241 100644 (file)
@@ -1,5 +1,5 @@
---- php-4.3.0/configure.in.orig        Fri Dec 27 05:07:18 2002
-+++ php-4.3.0/configure.in     Thu Jan  2 20:34:43 2003
+--- php-4.3.0/configure.ac.orig        Fri Dec 27 05:07:18 2002
++++ php-4.3.0/configure.ac     Thu Jan  2 20:34:43 2003
 @@ -288,7 +288,6 @@
  PHP_CHECK_FUNC(htonl, socket)
  PHP_CHECK_FUNC(gethostname, nsl)
index f31c4a5dfac55fd08d5c38c5151211d5b9bf3e4a..75eb9bd4e26b5fee7dc946b6eec0fdc788b3b158 100644 (file)
@@ -1,5 +1,5 @@
---- php-5.4.0alpha2/configure.in~      2011-08-01 12:23:18.000000000 +0300
-+++ php-5.4.0alpha2/configure.in       2011-08-01 12:24:20.209743190 +0300
+--- php-5.4.0alpha2/configure.ac~      2011-08-01 12:23:18.000000000 +0300
++++ php-5.4.0alpha2/configure.ac       2011-08-01 12:24:20.209743190 +0300
 @@ -1429,7 +1429,7 @@
  fi;
  
index 400359d4e47458f60ab22f71a7c7315f1ddc303c..74a03d64e51f65c26745b302985fdfd6a5c3d8d7 100644 (file)
@@ -1,5 +1,5 @@
---- php-5.3.1/configure.in~    2010-02-19 23:26:13.000000000 +0200
-+++ php-5.3.1/configure.in     2010-02-19 23:27:58.273207305 +0200
+--- php-5.3.1/configure.ac~    2010-02-19 23:26:13.000000000 +0200
++++ php-5.3.1/configure.ac     2010-02-19 23:27:58.273207305 +0200
 @@ -934,11 +934,6 @@
    with_pear=no
  fi
index b414183de354f8d484535fc012f951af0025c8f1..24c6848ebef867b9e829892c1bd3dd41ed4b38d8 100644 (file)
@@ -1,5 +1,5 @@
---- php-7.0.0RC3/configure.in~ 2015-09-26 14:55:35.000000000 +0300
-+++ php-7.0.0RC3/configure.in  2015-09-26 15:13:29.581882625 +0300
+--- php-7.0.0RC3/configure.ac~ 2015-09-26 14:55:35.000000000 +0300
++++ php-7.0.0RC3/configure.ac  2015-09-26 15:13:29.581882625 +0300
 @@ -224,6 +224,9 @@
  dnl check for -R, etc. switch
  PHP_RUNPATH_SWITCH
index fecca1134c7eb318659e02b0deca4353c0f518b5..14ae0aac822ec146aaac69f6fcf4a647487c37ef 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,3 +1,5 @@
+# TODO 7.2:
+# - package ext/sodium https://github.com/php/php-src/pull/2560
 # TODO 5.6:
 # - enable --with-fpm-systemd, but ensure it checks for sd_booted()
 # - build with system libgd 2.1, see 73c5128
 %undefine      with_filter
 %endif
 
+%define                subver alpha3
 %define                orgname php
-%define                ver_suffix 71
+%define                ver_suffix 72
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
@@ -149,16 +152,17 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.1.6
-Release:       1
+Version:       7.2.0
+Release:       0.1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
 # TSRM is licensed under BSD
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
-Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: eafc7a79cc8cc62c9292c96f9c9ccf90
+#Source0:      https://php.net/distributions/%{orgname}-%{version}.tar.xz
+Source0:       https://downloads.php.net/~remi/php-%{version}%{subver}.tar.xz
+# Source0-md5: de555e594f4211d0152c6a762762ae01
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -299,10 +303,10 @@ BuildRoot:        %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir                     %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20160303
-%define                zend_module_api         20160303
-%define                zend_extension_api      320160303
-%define                php_pdo_api_version     20150127
+%define                php_api_version         20160731
+%define                zend_module_api         20160731
+%define                zend_extension_api      320160731
+%define                php_pdo_api_version     20170320
 
 # Extension versions
 %define                bz2ver          1.0
@@ -312,8 +316,8 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                intlver         1.1.0
 %define                jsonver         1.5.0
 %define                pharver         2.0.2
-%define                sqlite3ver      0.7-dev
-%define                zipver          1.13.5
+%define                sqlite3ver      %{version}
+%define                zipver          1.14.0
 %define                phpdbgver       0.5.0
 
 %define                _zend_zts               %{!?with_zts:0}%{?with_zts:1}
@@ -2162,8 +2166,8 @@ if test "$ver" != "%{pharver}"; then
        : Update the pharver macro and rebuild.
        exit 1
 fi
-ver=$(sed -n '/#define PHP_SQLITE3_VERSION/{s/.* "//;s/".*$//;p}' ext/sqlite3/php_sqlite3.h)
-if test "$ver" != "%{sqlite3ver}"; then
+ver=$(awk '/#define PHP_SQLITE3_VERSION/ {print $3}' ext/sqlite3/php_sqlite3.h | xargs)
+if test "$ver" != "PHP_VERSION"; then
        : Error: Upstream Sqlite3 version is now ${ver}, expecting %{sqlite3ver}.
        : Update the sqlite3ver macro and rebuild.
        exit 1
This page took 0.062458 seconds and 4 git commands to generate.