]> git.pld-linux.org Git - packages/php.git/commitdiff
- package php-fpm status html (uses json response via ajax to update)
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 12 Jan 2012 08:27:14 +0000 (08:27 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-fpm-config.patch -> 1.14
    php.spec -> 1.972

php-fpm-config.patch
php.spec

index af78b5c3ca241a452501bca727149ac632678d4c..ad3bf69ef21388267cb4cc4e0c67191bbb78433e 100644 (file)
  ;env[TMP] = /tmp
  ;env[TMPDIR] = /tmp
  ;env[TEMP] = /tmp
+--- php-5.3.9/sapi/fpm/status.html.in~ 2011-10-08 23:43:12.000000000 +0300
++++ php-5.3.9/sapi/fpm/status.html.in  2012-01-12 02:19:09.573191879 +0200
+@@ -96,7 +96,7 @@
+                       var sort_index;
+                       var sort_order;
+-                      doc_url.value = location.protocol + '//' + location.host + "/status?json&full";
++                      doc_url.value = location.protocol + '//' + location.host + "/fpm-status?json&full";
+                       ths = document.getElementsByTagName("th");
+                       for (var i=0; i<ths.length; i++) {
+--- php-5.3.9/sapi/fpm/Makefile.frag~  2012-01-11 21:49:42.000000000 +0200
++++ php-5.3.9/sapi/fpm/Makefile.frag   2012-01-12 02:20:25.553355153 +0200
+@@ -21,7 +21,7 @@
+       @echo "Installing PHP FPM config:        $(INSTALL_ROOT)$(sysconfdir)/" && \
+       $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir) || :
+-      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf.default || :
++      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf || :
+       @echo "Installing PHP FPM man page:      $(INSTALL_ROOT)$(mandir)/man8/"
+       @$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man8
index 0d5e8c50f4cc5f35200857e471b4d682654d28a6..67cd7dee6d0fb84293536ee799e52a913adddf57 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2402,11 +2402,10 @@ cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/php-cgi-fcgi.ini
 
 # install FCGI PM
 %if %{with fpm}
-install -d $RPM_BUILD_ROOT{%{_sysconfdir}/fpm.d,%{_sbindir}}
-libtool --mode=install install -p sapi/fpm/php-fpm $RPM_BUILD_ROOT%{_sbindir}
-cp -p sapi/fpm/php-fpm.8 $RPM_BUILD_ROOT%{_mandir}/man8
-cp -p sapi/fpm/php-fpm.conf $RPM_BUILD_ROOT%{_sysconfdir}
-install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
+%{__make} -f Makefile.fpm install-fpm \
+       INSTALL_ROOT=$RPM_BUILD_ROOT
+
+install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_sysconfdir}/fpm.d}
 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/php-fpm
 install -d $RPM_BUILD_ROOT/etc/logrotate.d
 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/php-fpm
@@ -2858,6 +2857,8 @@ fi
 %{_mandir}/man8/php-fpm.8*
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/php-fpm
 %attr(754,root,root) /etc/rc.d/init.d/php-fpm
+%dir %{_datadir}/fpm
+%{_datadir}/fpm/status.html
 %endif
 
 %files common
This page took 0.06319 seconds and 4 git commands to generate.