]> git.pld-linux.org Git - packages/php.git/commitdiff
version php-fpm paths (5.2 changes)
authorElan Ruusamäe <glen@delfi.ee>
Wed, 1 Aug 2012 22:56:27 +0000 (01:56 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 1 Aug 2012 23:00:21 +0000 (02:00 +0300)
php.spec

index c17a2adbd8e69c65f3d41d3b4e321b95146c34f9..afc16ae9c347bd456a30db000a6930e1b7ca4afd 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2452,12 +2452,19 @@ libtool --silent --mode=install install sapi/fcgi/php-cgi $RPM_BUILD_ROOT%{_bind
 
 # install FCGI PM
 %if %{with fpm}
-libtool --silent --mode=install install sapi/fpm/php-cgi $RPM_BUILD_ROOT%{_sbindir}/php.fpm
-%{__make} install-fpm -f Makefile.fpm \
-       INSTALL_ROOT=$RPM_BUILD_ROOT
-install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/php-fpm
+install -d $RPM_BUILD_ROOT{%{_sysconfdir}/fpm.d,%{_sbindir}}
+libtool --mode=install install -p sapi/fpm/php-fpm $RPM_BUILD_ROOT%{_sbindir}/%{name}-fpm
+cp -p sapi/fpm/php-fpm.8 $RPM_BUILD_ROOT%{_mandir}/man8/%{name}-fpm.8
+cp -p sapi/fpm/php-fpm.conf $RPM_BUILD_ROOT%{_sysconfdir}
+install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
+install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-fpm
+%{__sed} -i -e '
+       s#/usr/lib/php#%{php_extensiondir}#
+       s#/etc/php#%{_sysconfdir}#
+       s#@processname@#%{name}-fpm#g
+' $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-fpm $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.conf
 install -d $RPM_BUILD_ROOT/etc/logrotate.d
-install %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/php-fpm
+cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-fpm
 %endif
 
 # install CLI
@@ -2735,9 +2742,10 @@ fi
 %files fpm
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fpm.conf
-%attr(755,root,root) %{_sbindir}/php-fpm
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/php-fpm
-%attr(754,root,root) /etc/rc.d/init.d/php-fpm
+%attr(755,root,root) %{_sbindir}/%{name}-fpm
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}-fpm
+%attr(754,root,root) /etc/rc.d/init.d/%{name}-fpm
+%{_mandir}/man8/%{name}-fpm.8
 %endif
 
 %files common
This page took 1.146291 seconds and 4 git commands to generate.