]> git.pld-linux.org Git - packages/php.git/commitdiff
version phar files
authorElan Ruusamäe <glen@delfi.ee>
Mon, 7 Sep 2015 14:27:30 +0000 (17:27 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 7 Sep 2015 14:27:54 +0000 (17:27 +0300)
php.spec

index 55729fbd4d2f1db01a17e750c8f2587bc722f044..1d2f16be16b9e493f0363435283b9d065926a1ba 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2534,8 +2534,11 @@ cp -pf Makefile.cli Makefile
        phpbuilddir=%{_libdir}/%{name}/build \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
+# version the .phar files
+mv $RPM_BUILD_ROOT%{_bindir}/phar{,%{ver_suffix}}.phar
+mv $RPM_BUILD_ROOT%{_mandir}/man1/phar{,%{ver_suffix}}.phar.1
 # make link relative
-ln -sfn phar.phar $RPM_BUILD_ROOT%{_bindir}/phar
+ln -sfn phar%{ver_suffix}.phar $RPM_BUILD_ROOT%{_bindir}/phar
 
 # version suffix
 v=$(echo %{version} | cut -d. -f1-2)
@@ -3246,9 +3249,9 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/phar.ini
 %attr(755,root,root) %{php_extensiondir}/phar.so
 %attr(755,root,root) %{_bindir}/phar
-%attr(755,root,root) %{_bindir}/phar.phar
+%attr(755,root,root) %{_bindir}/phar%{ver_suffix}.phar
 %{_mandir}/man1/phar.1*
-%{_mandir}/man1/phar.phar.1
+%{_mandir}/man1/phar%{ver_suffix}.phar.1
 %endif
 
 %files posix
This page took 1.235972 seconds and 4 git commands to generate.