]> git.pld-linux.org Git - packages/php.git/commitdiff
up to 5.3.21
authorElan Ruusamäe <glen@delfi.ee>
Tue, 22 Jan 2013 21:36:36 +0000 (23:36 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 22 Jan 2013 21:36:36 +0000 (23:36 +0200)
17-January-2013
* Zend Engine:
- Fixed bug #63762 (Sigsegv when Exception::$trace is changed by user).

* cURL extension:
- Fixed bug (segfault due to libcurl connection caching).
- Fixed bug #63795 (CURL >= 7.28.0 no longer support value 1 for CURLOPT_SSL_VERIFYHOST).
- Fixed bug #63352 (Can't enable hostname validation when using curl stream wrappers).
- Fixed bug #55438 (Curlwapper is not sending http header randomly).

php.spec
suhosin.patch

index 7e4681ebd64ea6c4f53bb62a38488cd49f743cdb..8c2836b8496c29768e389782299d9b769019fa7c 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -117,7 +117,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %define                php_suffix %{nil}
 %endif
 
-%define                rel     3
+%define                rel     1
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -125,13 +125,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.3.20
+Version:       5.3.21
 Release:       %{rel}%{?with_type_hints:.th}%{?with_oci8:.oci}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.bz2
-# Source0-md5: 00241b9e89e93adf3baac32c56211e4e
+# Source0-md5: 1b214fc19bb5f5c0902ba27c74d5f4a2
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
index 82dbcc7e8caebcc68db9fd0d386260a9d493cc95..79f63ec6bfea6f846bf1127c852602fbc16230c2 100644 (file)
@@ -1200,15 +1200,15 @@ diff -Naurp php-5.3.6RC1/sapi/apache_hooks/mod_php5.c php-5.3.6RC1.oden/sapi/apa
                                                        }
 +#if SUHOSIN_PATCH
 +#if ZEND_DEBUG
-+                                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
++                                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +#else
-+                                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
++                                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +#endif
 +#else
  #if ZEND_DEBUG
-                                                       php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
+                                                       php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
  #else
-                                                       php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
+                                                       php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
  #endif
 +#endif
                                                        php_request_shutdown((void *) 0);
@@ -1220,12 +1220,12 @@ diff -Naurp php-5.3.6RC1/sapi/apache_hooks/mod_php5.c php-5.3.6RC1.oden/sapi/apa
                                }
  
                                request_started = 1;
--                              php_printf("PHP %s (%s) (built: %s %s) %s\nCopyright (c) 1997-2012 The PHP Group\n%s",
+-                              php_printf("PHP %s (%s) (built: %s %s) %s\nCopyright (c) 1997-2013 The PHP Group\n%s",
 +                              php_printf("PHP %s "
 +#if SUHOSIN_PATCH
 +                                              "with Suhosin-Patch "
 +#endif
-+                                              "(%s) (built: %s %s) %s\nCopyright (c) 1997-2012 The PHP Group\n%s",
++                                              "(%s) (built: %s %s) %s\nCopyright (c) 1997-2013 The PHP Group\n%s",
                                        PHP_VERSION, sapi_module.name, __DATE__, __TIME__,
  #if ZEND_DEBUG && defined(HAVE_GCOV)
                                        "(DEBUG GCOV)",
@@ -1237,7 +1237,7 @@ diff -Naurp php-5.3.6RC1/Zend/Makefile.am php-5.3.6RC1.oden/Zend/Makefile.am
        zend_default_classes.c \
        zend_iterators.c zend_interfaces.c zend_exceptions.c \
 -      zend_strtod.c zend_closures.c zend_float.c
-+      zend_strtod.c zend_closures.c zend_float.c zend_canary.c zend_alloc_canary.c 
++      zend_strtod.c zend_closures.c zend_float.c zend_canary.c zend_alloc_canary.c
  
  libZend_la_LDFLAGS =
  libZend_la_LIBADD = @ZEND_EXTRA_LIBS@
This page took 0.066422 seconds and 4 git commands to generate.