]> git.pld-linux.org Git - packages/php.git/commitdiff
- resolve ambiguity of exit()/die() aliases, we want exit code not exit message
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 14 Apr 2010 09:14:46 +0000 (09:14 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php.spec -> 1.805.2.60

php.spec

index 42a215fbdd21a0f2dc018403fefb346b7155ee29..8027b386480cfe904b0fea5e8c0207eda99c759f 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2110,7 +2110,7 @@ cp -af php_config.h.cli main/php_config.h
 [ "$(echo '<?=php_sapi_name();' | ./sapi/cli/php -n)" = cli ] || exit 1
 
 # check for stupid xml parse breakage where &lt; and &gt; just get lost in parse result
-./sapi/cli/php -n -dextension_dir=modules -dextension=xml.so -r '$p = xml_parser_create(); xml_parse_into_struct($p, "<x>&lt;</x>", $vals, $index); exit(empty($vals[0]["value"]));'
+./sapi/cli/php -n -dextension_dir=modules -dextension=xml.so -r '$p = xml_parser_create(); xml_parse_into_struct($p, "<x>&lt;</x>", $vals, $index); exit((int )empty($vals[0]["value"]));'
 
 # Generate stub .ini files for each extension
 rm -rf conf.d
This page took 1.171227 seconds and 4 git commands to generate.